aboutsummaryrefslogtreecommitdiff
path: root/net/icmpchat/Makefile
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2002-10-29 05:17:17 +0000
committerPatrick Li <pat@FreeBSD.org>2002-10-29 05:17:17 +0000
commit339790fd2dd5ded7c55d87af4375eaa2ebe16eb9 (patch)
treef056aadc6083519369f42653e70c3afad5603fa3 /net/icmpchat/Makefile
parent71d710d093a864f2f427578d6ac3167d3817be0f (diff)
downloadports-339790fd2dd5ded7c55d87af4375eaa2ebe16eb9.tar.gz
ports-339790fd2dd5ded7c55d87af4375eaa2ebe16eb9.zip
Add net/icmpchat - Simple chat program based on the ICMP protocol.
PR: ports/44579 Submitted by: Matthew West <mwest@uct.ac.za>
Notes
Notes: svn path=/head/; revision=69075
Diffstat (limited to 'net/icmpchat/Makefile')
-rw-r--r--net/icmpchat/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/net/icmpchat/Makefile b/net/icmpchat/Makefile
new file mode 100644
index 000000000000..9e7154ecdd28
--- /dev/null
+++ b/net/icmpchat/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: icmpchat
+# Date created: 8 October 2002
+# Whom: mwest@uct.ac.za
+#
+# $FreeBSD$
+#
+
+PORTNAME= icmpchat
+PORTVERSION= 0.5.1
+CATEGORIES= net
+MASTER_SITES= http://www.codito.de/prog/
+
+MAINTAINER= mwest@uct.ac.za
+
+USE_REINPLACE= yes
+
+pre-patch:
+ @${REINPLACE_CMD} -e 's|-O3 -Wall|${CFLAGS}|;s|= gcc|?= gcc|; \
+ s|default|all|' ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/icmpchat ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ @${INSTALL} -d -o ${DOCOWN} -g ${DOCGRP} -m 555 ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>