aboutsummaryrefslogtreecommitdiff
path: root/net/icmpinfo
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>1997-06-24 08:09:18 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>1997-06-24 08:09:18 +0000
commit5fc685cfae5c7630eb694863575cb451038eaaf9 (patch)
treeb0a2022abf8a01be5ade15795317278bc12dbb61 /net/icmpinfo
parentaef30ddc44035037487e3f922985e348ad5ff6f9 (diff)
downloadports-5fc685cfae5c7630eb694863575cb451038eaaf9.tar.gz
ports-5fc685cfae5c7630eb694863575cb451038eaaf9.zip
icmpinfo is a tool for looking at the icmp messages received on
the running host.
Notes
Notes: svn path=/head/; revision=7060
Diffstat (limited to 'net/icmpinfo')
-rw-r--r--net/icmpinfo/Makefile31
-rw-r--r--net/icmpinfo/distinfo1
-rw-r--r--net/icmpinfo/pkg-comment1
-rw-r--r--net/icmpinfo/pkg-descr24
-rw-r--r--net/icmpinfo/pkg-plist3
5 files changed, 60 insertions, 0 deletions
diff --git a/net/icmpinfo/Makefile b/net/icmpinfo/Makefile
new file mode 100644
index 000000000000..d548c359cd0f
--- /dev/null
+++ b/net/icmpinfo/Makefile
@@ -0,0 +1,31 @@
+# ex:ts=8
+# Ports collection makefile for: icmpinfo
+# Version required: 1.11
+# Date created: Mon June 23, 1997
+# Whom: David O'Brien (obrien@FreeBSD.org)
+#
+# $Id$
+#
+
+DISTNAME= icmpinfo-1.11
+CATEGORIES= net sysutil
+MASTER_SITES= ftp://hplyot.obspm.fr/net/ \
+ ftp.leo.org:/pub/comp/networking/net-tools/icmpinfo/
+
+MAINTAINER= obrien@NUXI.com
+
+ALL_TARGET=
+MAN1= icmpinfo.1
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/icmpinfo ${PREFIX}/bin
+ /usr/sbin/chown root ${PREFIX}/bin
+ /bin/chmod 4555 ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/icmpinfo.man ${PREFIX}/man/man1/${MAN1}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/icmpinfo
+ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/icmpinfo
+.endif
+
+
+.include <bsd.port.mk>
diff --git a/net/icmpinfo/distinfo b/net/icmpinfo/distinfo
new file mode 100644
index 000000000000..b3ef4dfaf531
--- /dev/null
+++ b/net/icmpinfo/distinfo
@@ -0,0 +1 @@
+MD5 (icmpinfo-1.11.tar.gz) = 65c3acdf2f87f9ab9aa1a055d76f8976
diff --git a/net/icmpinfo/pkg-comment b/net/icmpinfo/pkg-comment
new file mode 100644
index 000000000000..d0bf0e35fb8e
--- /dev/null
+++ b/net/icmpinfo/pkg-comment
@@ -0,0 +1 @@
+looks at the icmp messages received by the host
diff --git a/net/icmpinfo/pkg-descr b/net/icmpinfo/pkg-descr
new file mode 100644
index 000000000000..442ee6eb772e
--- /dev/null
+++ b/net/icmpinfo/pkg-descr
@@ -0,0 +1,24 @@
+ICMPINFO:
+
+ icmpinfo is a tool for looking at the icmp messages received on
+ the running host.
+
+ The source code comes from an heavily modified BSD ping source.
+
+USAGE:
+
+icmpinfo o Gives info about weird packets only [mainly icmp_unreachable].
+icmpinfo -v o Gives info about all icmp packets [that includes your own
+ traceroutes...] except pings (icmp_echo_reply).
+icmpinfo -vv o To see pings too.
+icmpinfo -vvv o Will add an ascci/hexa dump of the packet.
+icmpinfo -n o Avoids name queries (faster, lighter).
+icmpinfo -p o Avoids port number to service name queries (faster, lighter).
+icmpinfo -s o Also decode the ip_src field which is the address of the
+ interface receiving the packet. This option is not usefull
+ for hosts with a single network interface.
+icmpinfo -l o Run like a daemon (forks) and output to SYSLOG.
+ (It now checks that you are root for that)
+
+-- David
+ obrien@NUXI.com
diff --git a/net/icmpinfo/pkg-plist b/net/icmpinfo/pkg-plist
new file mode 100644
index 000000000000..22f2939f8b64
--- /dev/null
+++ b/net/icmpinfo/pkg-plist
@@ -0,0 +1,3 @@
+bin/icmpinfo
+man/man1/icmpinfo.1.gz
+share/doc/icmpinfo/README