aboutsummaryrefslogtreecommitdiff
path: root/net/iodine/Makefile
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2007-03-29 11:04:20 +0000
committerRong-En Fan <rafan@FreeBSD.org>2007-03-29 11:04:20 +0000
commitdc16d6fd12cd968e09d0b3812beb0643d1b08d2e (patch)
tree9780c8af2c063a91a3f9a1d867d33ad3a12a6cb4 /net/iodine/Makefile
parentc01c2f6964f0bc198298b0436c4aa2ca34b953af (diff)
downloadports-dc16d6fd12cd968e09d0b3812beb0643d1b08d2e.tar.gz
ports-dc16d6fd12cd968e09d0b3812beb0643d1b08d2e.zip
- Update to 0.4.0
Notes
Notes: svn path=/head/; revision=188738
Diffstat (limited to 'net/iodine/Makefile')
-rw-r--r--net/iodine/Makefile16
1 files changed, 10 insertions, 6 deletions
diff --git a/net/iodine/Makefile b/net/iodine/Makefile
index 82d4ae8cb8a0..02b2d05e3354 100644
--- a/net/iodine/Makefile
+++ b/net/iodine/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= iodine
-PORTVERSION= 0.3.4
+PORTVERSION= 0.4.0
CATEGORIES= net
MASTER_SITES= http://code.kryo.se/iodine/
@@ -17,15 +17,19 @@ PLIST_FILES= bin/iodine sbin/iodined
PORTDOCS= CHANGELOG README TODO
+MAN8= iodine.8
+
.include <bsd.port.pre.mk>
-post-patch:
- @${REINPLACE_CMD} -e 's,^CC =,CC ?=,' -e 's,^CFLAGS =,CFLAGS +=,' \
- ${WRKSRC}/Makefile
+do-build:
+ @cd ${WRKSRC}/src; ${MAKE} all
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/iodine ${PREFIX}/bin
- ${INSTALL_PROGRAM} ${WRKSRC}/iodined ${PREFIX}/sbin
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/iodine ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/iodined ${PREFIX}/sbin
+.for m in ${MAN8}
+ ${INSTALL_MAN} ${WRKSRC}/man/${m} ${MANPREFIX}/man/man8
+.endfor
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
.for f in ${PORTDOCS}