aboutsummaryrefslogtreecommitdiff
path: root/net/isc-dhcp31-server
diff options
context:
space:
mode:
authorAlexander Langer <alex@FreeBSD.org>2001-05-21 19:30:29 +0000
committerAlexander Langer <alex@FreeBSD.org>2001-05-21 19:30:29 +0000
commit6f8b6924651a4a2a695f7b5080209c3273a6e9ae (patch)
tree1339d2e1f006e5723f966cd43831a178a933bebb /net/isc-dhcp31-server
parentf12984189c42bc58fd8571102a75f8f636f1fe76 (diff)
downloadports-6f8b6924651a4a2a695f7b5080209c3273a6e9ae.tar.gz
ports-6f8b6924651a4a2a695f7b5080209c3273a6e9ae.zip
Update to 3.0.r7.
PR: 27478 Submitted by: Cyrille Lefevre <clefevre@poboxes.com> (maintainer)
Notes
Notes: svn path=/head/; revision=42880
Diffstat (limited to 'net/isc-dhcp31-server')
-rw-r--r--net/isc-dhcp31-server/Makefile59
-rw-r--r--net/isc-dhcp31-server/distinfo2
-rw-r--r--net/isc-dhcp31-server/pkg-plist67
3 files changed, 72 insertions, 56 deletions
diff --git a/net/isc-dhcp31-server/Makefile b/net/isc-dhcp31-server/Makefile
index cd40fc5248a7..73d69e15e12b 100644
--- a/net/isc-dhcp31-server/Makefile
+++ b/net/isc-dhcp31-server/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= dhcp
-PORTVERSION= 3.0.r4
+PORTVERSION= 3.0.r7
CATEGORIES= net
MASTER_SITES= ftp://ftp.isc.org/isc/%SUBDIR%/ \
${US_MASTER_SITES} ${JAPAN_MASTER_SITES} \
@@ -32,7 +32,11 @@ MAINTAINER= clefevre@poboxes.com
HAS_CONFIGURE= yes
-PLIST_SUB= PKGBASE="${PKGBASE}"
+PLIST_SUB= DATA_DIR="${DATA_DIR}" RCD_SUBDIR="${RCD_SUBDIR}" \
+ CONF_SUBDIR="${CONF_SUBDIR}" SAMP_SUBDIR="${SAMP_SUBDIR}" \
+ BIN_SUBDIR="${BIN_SUBDIR}" INC_SUBDIR="${INC_SUBDIR}" \
+ LIB_SUBDIR="${LIB_SUBDIR}" DOC_SUBDIR="${DOC_SUBDIR}" \
+ SAMP_SUFFIX="${SAMP_SUFFIX}"
MAN3= dhcpctl.3 omapi.3
MAN5= dhclient.conf.5 dhclient.leases.5 dhcp-contrib.5 \
@@ -96,27 +100,32 @@ RELEASE= ${PORTVERSION}
PATCH_SUBDIRS= common minires dst omapip server client relay dhcpctl
+SAMP_SUFFIX= .sample
+
BIN_FILES= dhclient dhcpd dhcrelay
+CONF_FILES= dhclient.conf
SAMP_FILES= client/dhclient.conf server/dhcpd.conf
-RCD_FILES= isc-dhcpd.sh.sample
+RCD_FILES= isc-dhcpd.sh${SAMP_SUFFIX}
DOC_FILES= CHANGES COPYRIGHT README RELNOTES
DATA_FILES= dhclient.leases dhcpd.leases
-CONF_FILES= dhclient.conf
-BIN_DIR= ${PREFIX}/sbin
-ETC_DIR= ${PREFIX}/etc
-RCD_DIR= ${PREFIX}/etc/rc.d
-DOC_DIR= ${PREFIX}/share/doc/${PKGBASE}
-VARDB_DIR= /var/db
-VARRUN_DIR= /var/run
+BIN_SUBDIR= sbin
+CONF_SUBDIR= etc
+SAMP_SUBDIR= ${CONF_SUBDIR}
+RCD_SUBDIR= etc/rc.d
+INC_SUBDIR= include
+LIB_SUBDIR= lib
+DOC_SUBDIR= share/doc/${PKGBASE}
+DATA_DIR= /var/db
-STRIP?= strip
+STRIP_CMD?= strip
#
# Post-patch
#
-post-patch: patch-scripts patch-makefile-conf patch-makefiles-dist
+post-patch: patch-scripts patch-makefile-conf patch-makefiles-dist \
+ patch-man-pages
patch-scripts:
@${PERL} -pi.fbsd -e 's.!!PREFIX!!.${PREFIX}.g' \
@@ -132,6 +141,11 @@ patch-makefiles-dist:
${WRKSRC}/${subdir}/Makefile.dist
.endfor
+# temporary hack - no patch file needed for this typo.
+# grrr! don't know how to delete lines in perl :(
+patch-man-pages:
+ @${PERL} -pi.fbsd -e 's/^\.Fd$$//' ${WRKSRC}/dhcpctl/dhcpctl.3
+
#
# Post-install
#
@@ -142,40 +156,41 @@ post-install: strip-binary-files install-startup-files \
strip-binary-files:
.for file in ${BIN_FILES}
-.if exists({BIN_DIR}/${file})
- @${STRIP} ${BIN_DIR}/${file}
+.if exists(${PREFIX}/${BIN_SUBDIR}/${file})
+ @${STRIP_CMD} ${PREFIX}/${BIN_SUBDIR}/${file}
.endif
.endfor
install-startup-files:
.for file in ${RCD_FILES}
- @${INSTALL_SCRIPT} ${FILESDIR}/${file} ${RCD_DIR}/${file}
+ @${INSTALL_SCRIPT} ${FILESDIR}/${file} ${PREFIX}/${RCD_SUBDIR}
.endfor
install-doc-files:
.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOC_DIR}
+ @${MKDIR} ${PREFIX}/${DOC_SUBDIR}
.for file in ${DOC_FILES}
- @${INSTALL_DATA} ${WRKSRC}/${file} ${DOC_DIR}/${file}
+ @${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/${DOC_SUBDIR}
.endfor
.endif
install-sample-files:
.for file in ${SAMP_FILES}
- @${INSTALL_DATA} ${WRKSRC}/${file} ${ETC_DIR}/${file:T}.sample
+ @${INSTALL_DATA} ${WRKSRC}/${file} \
+ ${PREFIX}/${SAMP_SUBDIR}/${file:T}${SAMP_SUFFIX}
.endfor
create-data-files:
.for file in ${DATA_FILES}
-.if !exists(${VARDB_DIR}/${file})
- @${TOUCH} ${VARDB_DIR}/${file}
+.if !exists(${DATA_DIR}/${file})
+ @${TOUCH} ${DATA_DIR}/${file}
.endif
.endfor
create-conf-files:
.for file in ${CONF_FILES}
-.if !exists(${ETC_DIR}/${file})
- @${TOUCH} ${ETC_DIR}/${file}
+.if !exists(${PREFIX}/${CONF_SUBDIR}/${file})
+ @${TOUCH} ${PREFIX}/${CONF_SUBDIR}/${file}
.endif
.endfor
diff --git a/net/isc-dhcp31-server/distinfo b/net/isc-dhcp31-server/distinfo
index 490b530386e8..d11a69e3814d 100644
--- a/net/isc-dhcp31-server/distinfo
+++ b/net/isc-dhcp31-server/distinfo
@@ -1 +1 @@
-MD5 (dhcp-3.0rc4.tar.gz) = 3f270f45836027b107ffc79eecf0b76e
+MD5 (dhcp-3.0rc7.tar.gz) = 835be51c217c629d46fbcb422b1c91a9
diff --git a/net/isc-dhcp31-server/pkg-plist b/net/isc-dhcp31-server/pkg-plist
index 82294d786883..8659cec3c16c 100644
--- a/net/isc-dhcp31-server/pkg-plist
+++ b/net/isc-dhcp31-server/pkg-plist
@@ -1,34 +1,35 @@
@comment $FreeBSD$
-etc/dhclient.conf.sample
-etc/dhcpd.conf.sample
-etc/rc.d/isc-dhcpd.sh.sample
-include/dhcpctl.h
-include/isc/boolean.h
-include/isc/dst.h
-include/isc/int.h
-include/isc/lang.h
-include/isc/list.h
-include/isc/result.h
-include/isc/types.h
-include/omapip/alloc.h
-include/omapip/buffer.h
-include/omapip/omapip.h
-lib/libdhcpctl.a
-lib/libomapi.a
-sbin/dhclient
-sbin/dhclient-script
-sbin/dhcpd
-sbin/dhcrelay
-%%PORTDOCS%%share/doc/%%PKGBASE%%/CHANGES
-%%PORTDOCS%%share/doc/%%PKGBASE%%/COPYRIGHT
-%%PORTDOCS%%share/doc/%%PKGBASE%%/README
-%%PORTDOCS%%share/doc/%%PKGBASE%%/RELNOTES
-@dirrm include/isc
-@dirrm include/omapip
-%%PORTDOCS%%@dirrm share/doc/%%PKGBASE%%
-@exec [ -f /var/db/dhclient.leases ] || touch /var/db/dhclient.leases
-@unexec [ -s /var/db/dhclient.leases ] || rm -f /var/db/dhclient.leases
-@exec [ -f /var/db/dhcpd.leases ] || touch /var/db/dhcpd.leases
-@unexec [ -s /var/db/dhcpd.leases ] || rm -f /var/db/dhcpd.leases
-@exec [ -f %D/etc/dhclient.conf ] || touch %D/etc/dhclient.conf
-@unexec [ -L %D/etc/dhclient.conf -o -s %D/etc/dhclient.conf ] || rm -f %D/etc/dhclient.conf
+%%SAMP_SUBDIR%%/dhclient.conf%%SAMP_SUFFIX%%
+%%SAMP_SUBDIR%%/dhcpd.conf%%SAMP_SUFFIX%%
+%%RCD_SUBDIR%%/isc-dhcpd.sh%%SAMP_SUFFIX%%
+%%INC_SUBDIR%%/dhcpctl.h
+%%INC_SUBDIR%%/isc/boolean.h
+%%INC_SUBDIR%%/isc/dst.h
+%%INC_SUBDIR%%/isc/int.h
+%%INC_SUBDIR%%/isc/lang.h
+%%INC_SUBDIR%%/isc/list.h
+%%INC_SUBDIR%%/isc/result.h
+%%INC_SUBDIR%%/isc/types.h
+%%INC_SUBDIR%%/omapip/alloc.h
+%%INC_SUBDIR%%/omapip/buffer.h
+%%INC_SUBDIR%%/omapip/omapip.h
+%%LIB_SUBDIR%%/libdhcpctl.a
+%%LIB_SUBDIR%%/libomapi.a
+%%BIN_SUBDIR%%/dhclient
+%%BIN_SUBDIR%%/dhclient-script
+%%BIN_SUBDIR%%/dhcpd
+%%BIN_SUBDIR%%/dhcrelay
+%%PORTDOCS%%%%DOC_SUBDIR%%/CHANGES
+%%PORTDOCS%%%%DOC_SUBDIR%%/COPYRIGHT
+%%PORTDOCS%%%%DOC_SUBDIR%%/README
+%%PORTDOCS%%%%DOC_SUBDIR%%/RELNOTES
+@dirrm %%INC_SUBDIR%%/isc
+@dirrm %%INC_SUBDIR%%/omapip
+%%PORTDOCS%%@dirrm %%DOC_SUBDIR%%
+@unexec rm -f %%RCD_SUBDIR%%/isc-dhcpd.sh
+@exec [ -f %%DATA_DIR%%/dhclient.leases ] || touch %%DATA_DIR%%/dhclient.leases
+@unexec [ -s %%DATA_DIR%%/dhclient.leases ] || rm -f %%DATA_DIR%%/dhclient.leases
+@exec [ -f %%DATA_DIR%%/dhcpd.leases ] || touch %%DATA_DIR%%/dhcpd.leases
+@unexec [ -s %%DATA_DIR%%/dhcpd.leases ] || rm -f %%DATA_DIR%%/dhcpd.leases
+@exec [ -f %D/%%CONF_SUBDIR%%/dhclient.conf ] || touch %D/%%CONF_SUBDIR%%/dhclient.conf
+@unexec [ -L %D/%%CONF_SUBDIR%%/dhclient.conf -o -s %D/%%CONF_SUBDIR%%/dhclient.conf ] || rm -f %D/%%CONF_SUBDIR%%/dhclient.conf