aboutsummaryrefslogtreecommitdiff
path: root/net/jwhois
diff options
context:
space:
mode:
authorMakoto Matsushita <matusita@FreeBSD.org>2003-04-19 05:21:57 +0000
committerMakoto Matsushita <matusita@FreeBSD.org>2003-04-19 05:21:57 +0000
commitab3162212b58b30582c3d983b6c0ec8e75c67509 (patch)
treec91781b6854ceadefe145b4b48f60222f1fa5f75 /net/jwhois
parent4e41411a0ddef1ac1a291231c15b629f4e848826 (diff)
downloadports-ab3162212b58b30582c3d983b6c0ec8e75c67509.tar.gz
ports-ab3162212b58b30582c3d983b6c0ec8e75c67509.zip
Add a patch to fix a problem with *.org lookup redirection.
Bump PORTREVISION. Submitted by: Phil Pennock <pdp@nl.demon.net> Obtained from: jwhois vendor CVS repository
Notes
Notes: svn path=/head/; revision=79258
Diffstat (limited to 'net/jwhois')
-rw-r--r--net/jwhois/Makefile2
-rw-r--r--net/jwhois/files/patch-ae20
2 files changed, 21 insertions, 1 deletions
diff --git a/net/jwhois/Makefile b/net/jwhois/Makefile
index d860a5060c8c..11901ae78d67 100644
--- a/net/jwhois/Makefile
+++ b/net/jwhois/Makefile
@@ -7,7 +7,7 @@
PORTNAME= jwhois
PORTVERSION= 3.2.1
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= jwhois
diff --git a/net/jwhois/files/patch-ae b/net/jwhois/files/patch-ae
new file mode 100644
index 000000000000..8c6452e27103
--- /dev/null
+++ b/net/jwhois/files/patch-ae
@@ -0,0 +1,20 @@
+--- src/lookup.c 2002/08/02 22:17:41 1.33
++++ src/lookup.c 2003/02/04 21:21:16 1.34
+@@ -391,7 +391,7 @@
+ {
+ memcpy(bptr, text, strlen(text)+1);
+
+- strptr = (char *)strtok(bptr, "\n");
++ strptr = (char *)strtok(bptr, "\r\n");
+ while (strptr)
+ {
+ rpb.allocated = 0;
+@@ -443,7 +443,7 @@
+ }
+ else if (ind == -2)
+ return -1;
+- strptr = (char *)strtok(NULL, "\n");
++ strptr = (char *)strtok(NULL, "\r\n");
+ }
+ }
+ }