aboutsummaryrefslogtreecommitdiff
path: root/net/kf
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2005-01-08 17:21:21 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2005-01-08 17:21:21 +0000
commit1b819830f1346a13350f6435ec1e2c15e8de9845 (patch)
tree2d9b927295da4a0a31861c79aad696157fabbcba /net/kf
parentc6d260351eb300e2352277cd97f80d021a6fd8f5 (diff)
downloadports-1b819830f1346a13350f6435ec1e2c15e8de9845.tar.gz
ports-1b819830f1346a13350f6435ec1e2c15e8de9845.zip
- Update to 0.4
- While I'm here: utilize %%DATADIR%% in pkg-plist PR: ports/75683 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=125838
Diffstat (limited to 'net/kf')
-rw-r--r--net/kf/Makefile3
-rw-r--r--net/kf/distinfo4
-rw-r--r--net/kf/files/patch-archive_viewer.c12
-rw-r--r--net/kf/files/patch-src-Makefile.in13
-rw-r--r--net/kf/files/patch-src-connection.c12
-rw-r--r--net/kf/files/patch-src-emoticons.c13
-rw-r--r--net/kf/files/patch-src-popup_group.c20
-rw-r--r--net/kf/pkg-plist231
8 files changed, 132 insertions, 176 deletions
diff --git a/net/kf/Makefile b/net/kf/Makefile
index 3e50534c67bf..1986f5ce207c 100644
--- a/net/kf/Makefile
+++ b/net/kf/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= kf
-PORTVERSION= 0.2
-PORTREVISION= 1
+PORTVERSION= 0.4
CATEGORIES= net
MASTER_SITES= http://www.habazie.rams.pl/kf/files/ \
http://www.jabberstudio.org/projects/kf/releases/
diff --git a/net/kf/distinfo b/net/kf/distinfo
index 19ee1bd0c884..4b1399dfd5d1 100644
--- a/net/kf/distinfo
+++ b/net/kf/distinfo
@@ -1,2 +1,2 @@
-MD5 (kf-0.2.tar.gz) = 61091daffbd03ef4eb3155df3abed0ca
-SIZE (kf-0.2.tar.gz) = 294670
+MD5 (kf-0.4.tar.gz) = d21d7622dbec870bd10f367e5ef5a195
+SIZE (kf-0.4.tar.gz) = 363208
diff --git a/net/kf/files/patch-archive_viewer.c b/net/kf/files/patch-archive_viewer.c
new file mode 100644
index 000000000000..3b8faf120751
--- /dev/null
+++ b/net/kf/files/patch-archive_viewer.c
@@ -0,0 +1,12 @@
+--- src/archive_viewer.c.orig Sat Jan 8 18:43:37 2005
++++ src/archive_viewer.c Sat Jan 8 18:44:12 2005
+@@ -340,8 +340,8 @@
+ return;
+ }
+ for (node = node->children; node; node = node->next) {
+- foo_debug ("Reading item %s\n", node->name);
+ KfArchiveConversation *conversation = NULL;
++ foo_debug ("Reading item %s\n", node->name);
+ if (xmlStrcmp (node->name, (const xmlChar *) "item") == 0) {
+ GtkTreeIter iter;
+ xmlChar *name;
diff --git a/net/kf/files/patch-src-Makefile.in b/net/kf/files/patch-src-Makefile.in
deleted file mode 100644
index 9ba28d91cc16..000000000000
--- a/net/kf/files/patch-src-Makefile.in
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/Makefile.in.orig Mon Dec 20 13:36:48 2004
-+++ src/Makefile.in Mon Dec 20 13:37:29 2004
-@@ -90,8 +90,8 @@
-
-
- #kf_LDADD = @PACKAGE_LIBS@ $(INTLLIBS)
--CFLAGS = -Wall -Wmissing-declarations
--LDFLAGS = -g
-+CFLAGS = @CFLAGS@ -Wall -Wmissing-declarations
-+LDFLAGS = @LDFLAGS@ -g
- kf_LDADD = @PACKAGE_LIBS@
- mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
- CONFIG_HEADER = ../config.h
diff --git a/net/kf/files/patch-src-connection.c b/net/kf/files/patch-src-connection.c
deleted file mode 100644
index 5ad1edb6547a..000000000000
--- a/net/kf/files/patch-src-connection.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/connection.c.orig Wed Sep 29 11:16:38 2004
-+++ src/connection.c Wed Oct 20 02:48:18 2004
-@@ -71,8 +71,8 @@
-
- void kf_connection_set_proxy (const gchar *server, gint port,
- const gchar *uname, const gchar *passwd) {
-- foo_debug ("Setting proxy '%s'...", server);
- LmProxy *proxy;
-+ foo_debug ("Setting proxy '%s'...", server);
- if (server) {
- proxy = lm_proxy_new_with_server (LM_PROXY_TYPE_HTTP, server, port);
- if (*uname == '\0') uname = NULL;
diff --git a/net/kf/files/patch-src-emoticons.c b/net/kf/files/patch-src-emoticons.c
deleted file mode 100644
index 5e3a66248883..000000000000
--- a/net/kf/files/patch-src-emoticons.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/emoticons.c.orig Thu Dec 16 22:50:31 2004
-+++ src/emoticons.c Thu Dec 16 22:51:27 2004
-@@ -347,9 +347,9 @@
- gchar *caption; /* Should be enough... */
-
- if (kf_preferences_get_int ("chatShowStamps")) {
-+ gchar *sstamp;
- struct tm *stime;
- stime = localtime ((time_t *) &stamp);
-- gchar *sstamp;
-
- gtk_text_buffer_get_end_iter (buffer, &iter);
- if (stamp < time (NULL) - 3600 * 24) {
diff --git a/net/kf/files/patch-src-popup_group.c b/net/kf/files/patch-src-popup_group.c
deleted file mode 100644
index 9a263429cc60..000000000000
--- a/net/kf/files/patch-src-popup_group.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/popup_group.c.orig Wed Sep 29 11:16:39 2004
-+++ src/popup_group.c Wed Oct 20 02:54:15 2004
-@@ -40,14 +40,15 @@
- void kf_popup_groups_menu_attach (GladeXML *glade, KfJabberRosterItem *roster_item) {
- GtkWidget *parent;
- GtkWidget *menu;
-+ GtkWidget *new_group, *separator;
-+ GList *groups;
-
- parent = glade_xml_get_widget (glade, "popup_group");
- if ((menu = gtk_menu_item_get_submenu (GTK_MENU_ITEM (parent)))) {
- gtk_widget_destroy (menu);
- }
- // } else {
-- GtkWidget *new_group, *separator;
-- GList *groups = kf_gui_get_groups ();
-+ groups = kf_gui_get_groups ();
-
- menu = gtk_menu_new ();
-
diff --git a/net/kf/pkg-plist b/net/kf/pkg-plist
index e21fd9e390f3..ee7b7ed26c1f 100644
--- a/net/kf/pkg-plist
+++ b/net/kf/pkg-plist
@@ -1,121 +1,124 @@
bin/kf
-share/kf/add_contact.png
-share/kf/archive.glade
-share/kf/archive.glade.h
-share/kf/away.png
-share/kf/bass.wav
-share/kf/browse.glade
-share/kf/browse.glade.h
-share/kf/browse_aim.png
-share/kf/browse_book.png
-share/kf/browse_gg.png
-share/kf/browse_icq.png
-share/kf/browse_jud.png
-share/kf/browse_mail.png
-share/kf/browse_msn.png
-share/kf/browse_news.png
-share/kf/browse_room.png
-share/kf/browse_sms.png
-share/kf/browse_tlen.png
-share/kf/browse_user.png
-share/kf/browse_user2.png
-share/kf/browse_weather.png
-share/kf/browse_yahoo.png
-share/kf/button.wav
-share/kf/button_search.png
-share/kf/chat.glade
-share/kf/chat.glade.h
-share/kf/chat.png
-share/kf/dnd.png
-share/kf/dock.glade
-share/kf/dock.glade.h
-share/kf/emoticons/beer.png
-share/kf/emoticons/bigsmile.png
-share/kf/emoticons/broken_heart.png
-share/kf/emoticons/cool.png
-share/kf/emoticons/cry.png
-share/kf/emoticons/emoticons.def
-share/kf/emoticons/evil.png
-share/kf/emoticons/heart.png
-share/kf/emoticons/icon_arrow.gif
-share/kf/emoticons/icon_biggrin.gif
-share/kf/emoticons/icon_confused.gif
-share/kf/emoticons/icon_cool.gif
-share/kf/emoticons/icon_cry.gif
-share/kf/emoticons/icon_eek.gif
-share/kf/emoticons/icon_evil.gif
-share/kf/emoticons/icon_exclaim.gif
-share/kf/emoticons/icon_frown.gif
-share/kf/emoticons/icon_idea.gif
-share/kf/emoticons/icon_lol.gif
-share/kf/emoticons/icon_mad.gif
-share/kf/emoticons/icon_mrgreen.gif
-share/kf/emoticons/icon_neutral.gif
-share/kf/emoticons/icon_question.gif
-share/kf/emoticons/icon_razz.gif
-share/kf/emoticons/icon_redface.gif
-share/kf/emoticons/icon_rolleyes.gif
-share/kf/emoticons/icon_sad.gif
-share/kf/emoticons/icon_smile.gif
-share/kf/emoticons/icon_surprised.gif
-share/kf/emoticons/icon_twisted.gif
-share/kf/emoticons/icon_wink.gif
-share/kf/emoticons/mad.png
-share/kf/emoticons/neutral.png
-share/kf/emoticons/online.png
-share/kf/emoticons/s.png
-share/kf/emoticons/sad.png
-share/kf/emoticons/smile.png
-share/kf/emoticons/tongue.png
-share/kf/emoticons/tux.png
-share/kf/emoticons/twisted.png
-share/kf/emoticons/wink.png
-share/kf/harp.wav
-share/kf/invisible.png
-share/kf/kf.glade
-share/kf/kf.glade.h
-share/kf/kf.png
-share/kf/logo.png
-share/kf/menu_configure.png
-share/kf/menu_register.png
-share/kf/menu_search.png
-share/kf/msg.glade
-share/kf/msg.glade.h
-share/kf/muc.glade
-share/kf/muc.glade.h
-share/kf/muc.png
-share/kf/muc_join.glade
-share/kf/muc_join.glade.h
-share/kf/network.png
-share/kf/new_account.glade
-share/kf/new_account.glade.h
-share/kf/online.png
-share/kf/password.png
-share/kf/pix_chat.png
-share/kf/pix_message.png
-share/kf/pix_system.png
-share/kf/plus.png
-share/kf/register.glade
-share/kf/register.glade.h
-share/kf/search.glade
-share/kf/search.glade.h
-share/kf/show_offline.png
-share/kf/status.glade
-share/kf/status.glade.h
-share/kf/subscribe.glade
-share/kf/subscribe.glade.h
-share/kf/unavailable.png
-share/kf/unavailable_desc.png
-share/kf/unknown.png
-share/kf/vcard.glade
-share/kf/vcard.glade.h
-share/kf/www.png
-share/kf/xa.png
+%%DATADIR%%/add_contact.png
+%%DATADIR%%/archive.glade
+%%DATADIR%%/archive.glade.h
+%%DATADIR%%/away.png
+%%DATADIR%%/bass.wav
+%%DATADIR%%/browse.glade
+%%DATADIR%%/browse.glade.h
+%%DATADIR%%/browse_aim.png
+%%DATADIR%%/browse_book.png
+%%DATADIR%%/browse_gg.png
+%%DATADIR%%/browse_icq.png
+%%DATADIR%%/browse_jud.png
+%%DATADIR%%/browse_mail.png
+%%DATADIR%%/browse_msn.png
+%%DATADIR%%/browse_news.png
+%%DATADIR%%/browse_room.png
+%%DATADIR%%/browse_sms.png
+%%DATADIR%%/browse_tlen.png
+%%DATADIR%%/browse_user.png
+%%DATADIR%%/browse_user2.png
+%%DATADIR%%/browse_weather.png
+%%DATADIR%%/browse_yahoo.png
+%%DATADIR%%/button.wav
+%%DATADIR%%/button_search.png
+%%DATADIR%%/chat.glade
+%%DATADIR%%/chat.glade.h
+%%DATADIR%%/chat.png
+%%DATADIR%%/dnd.png
+%%DATADIR%%/dock.glade
+%%DATADIR%%/dock.glade.h
+%%DATADIR%%/emoticons/beer.png
+%%DATADIR%%/emoticons/bigsmile.png
+%%DATADIR%%/emoticons/broken_heart.png
+%%DATADIR%%/emoticons/cool.png
+%%DATADIR%%/emoticons/cry.png
+%%DATADIR%%/emoticons/emoticons.def
+%%DATADIR%%/emoticons/evil.png
+%%DATADIR%%/emoticons/heart.png
+%%DATADIR%%/emoticons/icon_arrow.gif
+%%DATADIR%%/emoticons/icon_biggrin.gif
+%%DATADIR%%/emoticons/icon_confused.gif
+%%DATADIR%%/emoticons/icon_cool.gif
+%%DATADIR%%/emoticons/icon_cry.gif
+%%DATADIR%%/emoticons/icon_eek.gif
+%%DATADIR%%/emoticons/icon_evil.gif
+%%DATADIR%%/emoticons/icon_exclaim.gif
+%%DATADIR%%/emoticons/icon_frown.gif
+%%DATADIR%%/emoticons/icon_idea.gif
+%%DATADIR%%/emoticons/icon_lol.gif
+%%DATADIR%%/emoticons/icon_mad.gif
+%%DATADIR%%/emoticons/icon_mrgreen.gif
+%%DATADIR%%/emoticons/icon_neutral.gif
+%%DATADIR%%/emoticons/icon_question.gif
+%%DATADIR%%/emoticons/icon_razz.gif
+%%DATADIR%%/emoticons/icon_redface.gif
+%%DATADIR%%/emoticons/icon_rolleyes.gif
+%%DATADIR%%/emoticons/icon_sad.gif
+%%DATADIR%%/emoticons/icon_smile.gif
+%%DATADIR%%/emoticons/icon_surprised.gif
+%%DATADIR%%/emoticons/icon_twisted.gif
+%%DATADIR%%/emoticons/icon_wink.gif
+%%DATADIR%%/emoticons/mad.png
+%%DATADIR%%/emoticons/neutral.png
+%%DATADIR%%/emoticons/online.png
+%%DATADIR%%/emoticons/s.png
+%%DATADIR%%/emoticons/sad.png
+%%DATADIR%%/emoticons/smile.png
+%%DATADIR%%/emoticons/tongue.png
+%%DATADIR%%/emoticons/tux.png
+%%DATADIR%%/emoticons/twisted.png
+%%DATADIR%%/emoticons/wink.png
+%%DATADIR%%/harp.wav
+%%DATADIR%%/invisible.png
+%%DATADIR%%/kf.glade
+%%DATADIR%%/kf.glade.h
+%%DATADIR%%/kf.png
+%%DATADIR%%/logo.png
+%%DATADIR%%/menu_configure.png
+%%DATADIR%%/menu_register.png
+%%DATADIR%%/menu_search.png
+%%DATADIR%%/msg.glade
+%%DATADIR%%/msg.glade.h
+%%DATADIR%%/muc.glade
+%%DATADIR%%/muc.glade.h
+%%DATADIR%%/muc.png
+%%DATADIR%%/muc_join.glade
+%%DATADIR%%/muc_join.glade.h
+%%DATADIR%%/network.png
+%%DATADIR%%/new_account.glade
+%%DATADIR%%/new_account.glade.h
+%%DATADIR%%/online.png
+%%DATADIR%%/password.png
+%%DATADIR%%/pix_chat.png
+%%DATADIR%%/pix_message.png
+%%DATADIR%%/pix_system.png
+%%DATADIR%%/plus.png
+%%DATADIR%%/register.glade
+%%DATADIR%%/register.glade.h
+%%DATADIR%%/search.glade
+%%DATADIR%%/search.glade.h
+%%DATADIR%%/show_offline.png
+%%DATADIR%%/status.glade
+%%DATADIR%%/status.glade.h
+%%DATADIR%%/subscribe.glade
+%%DATADIR%%/subscribe.glade.h
+%%DATADIR%%/unavailable.png
+%%DATADIR%%/unavailable_desc.png
+%%DATADIR%%/unknown.png
+%%DATADIR%%/vcard.glade
+%%DATADIR%%/vcard.glade.h
+%%DATADIR%%/www.png
+%%DATADIR%%/xa.png
+share/locale/bg/LC_MESSAGES/kf.mo
share/locale/pl/LC_MESSAGES/kf.mo
share/locale/ru/LC_MESSAGES/kf.mo
+@dirrm share/locale/bg/LC_MESSAGES
@dirrm share/locale/pl/LC_MESSAGES
@dirrm share/locale/ru/LC_MESSAGES
+@dirrm share/locale/bg
@dirrm share/locale/pl
@dirrm share/locale/ru
-@dirrm share/kf/emoticons
-@dirrm share/kf
+@dirrm %%DATADIR%%/emoticons
+@dirrm %%DATADIR%%