aboutsummaryrefslogtreecommitdiff
path: root/net/lambdamoo
diff options
context:
space:
mode:
authorSeiichirou Hiraoka <flathill@FreeBSD.org>2000-01-05 20:27:21 +0000
committerSeiichirou Hiraoka <flathill@FreeBSD.org>2000-01-05 20:27:21 +0000
commitb7081b5e8f921b791377b1021cf5c9dc72af73f5 (patch)
tree3dfe581f71eff3b85cf5322ff80cf8f87778960d /net/lambdamoo
parent45a5c96017adee316fe728450e2ba52ecae9ec42 (diff)
downloadports-b7081b5e8f921b791377b1021cf5c9dc72af73f5.tar.gz
ports-b7081b5e8f921b791377b1021cf5c9dc72af73f5.zip
Submitted by: flathill@FreeBSD.org
The most commonly used program to run MOOs
Notes
Notes: svn path=/head/; revision=24446
Diffstat (limited to 'net/lambdamoo')
-rw-r--r--net/lambdamoo/Makefile34
-rw-r--r--net/lambdamoo/distinfo1
-rw-r--r--net/lambdamoo/files/README.FreeBSD27
-rw-r--r--net/lambdamoo/files/patch-aa11
-rw-r--r--net/lambdamoo/pkg-comment1
-rw-r--r--net/lambdamoo/pkg-descr14
-rw-r--r--net/lambdamoo/pkg-plist6
7 files changed, 94 insertions, 0 deletions
diff --git a/net/lambdamoo/Makefile b/net/lambdamoo/Makefile
new file mode 100644
index 000000000000..dcabb6242322
--- /dev/null
+++ b/net/lambdamoo/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: LambdaMOO
+# Version required: 1.8.0r8
+# Date created: Jul 3 1999
+# Whom: Seiichirou Hiraoka
+#
+# $FreeBSD$
+#
+
+DISTNAME= LambdaMOO-1.8.0r8
+PKGNAME= lambdamoo-1.8.0r8
+CATEGORIES= net
+MASTER_SITES= ftp://ftp.place.org/pub/moo/unofficial/
+
+MAINTAINER= flathill@FreeBSD.ORG
+
+WRKSRC= ${WRKDIR}/MOO-1.8.0r8
+GNU_CONFIGURE= yes
+ALL_TARGET=
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/moo ${PREFIX}/sbin
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/LambdaMOO
+ @(cd ${WRKSRC};\
+ ${INSTALL_MAN} Minimal.db README README.Minimal \
+ ${PREFIX}/share/doc/LambdaMOO; \
+ )
+ @${INSTALL_DATA} ${FILESDIR}/README.FreeBSD \
+ ${PREFIX}/share/doc/LambdaMOO
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/lambdamoo/distinfo b/net/lambdamoo/distinfo
new file mode 100644
index 000000000000..3052ed89dae2
--- /dev/null
+++ b/net/lambdamoo/distinfo
@@ -0,0 +1 @@
+MD5 (LambdaMOO-1.8.0r8.tar.gz) = e902178700ff0bbe24edfb412be6dfde
diff --git a/net/lambdamoo/files/README.FreeBSD b/net/lambdamoo/files/README.FreeBSD
new file mode 100644
index 000000000000..6161e988965f
--- /dev/null
+++ b/net/lambdamoo/files/README.FreeBSD
@@ -0,0 +1,27 @@
+How to play LambdaMOO
+
+1. Get core database,
+ ftp://ftp.lambda.moo.mud.org/pub/MOO/LambdaMOO-latest.tar.gz.
+
+ If you want to get other two commonly used core databases, visit
+ http://www.moo.mud.org/.
+
+2. /usr/local/sbin/moo INITIAL-DB-FILE CHECKPOINT-DB-FILE.
+
+!NOTICE!
+
+According to MOO-Cows FAQ in http://www.moo.mud.org/moo-faq/,
+LambdaCore-latest.db has password problem on FreeBSD.
+Apply following patch to resolve.
+
+--- LambdaCore-latest.db.orig Sun Jul 4 08:34:16 1999
++++ LambdaCore-latest.db Sun Jul 4 14:05:25 1999
+@@ -227748,7 +227748,7 @@
+ elseif (length(args) != 2)
+ player:notify(tostr("Usage: ", verb, " <old-password> <new-password>"));
+ return;
+-elseif (player.password != crypt(tostr(args[1]), player.password))
++elseif (player.password != crypt(tostr(args[1]), player.password[4..5]))
+ player:notify("That's not your old password.");
+ return;
+ elseif (is_clear_property(player, "password"))
diff --git a/net/lambdamoo/files/patch-aa b/net/lambdamoo/files/patch-aa
new file mode 100644
index 000000000000..d9522357c30d
--- /dev/null
+++ b/net/lambdamoo/files/patch-aa
@@ -0,0 +1,11 @@
+--- config.h.in.orig Sun Jul 4 16:45:44 1999
++++ config.h.in Sun Jul 4 16:45:54 1999
+@@ -163,7 +163,7 @@
+ * system provides the named functions.
+ */
+
+-#undef HAVE_CRYPT
++/* #undef HAVE_CRYPT */
+ #undef HAVE_MATHERR
+ #undef HAVE_MKFIFO
+ #undef HAVE_REMOVE
diff --git a/net/lambdamoo/pkg-comment b/net/lambdamoo/pkg-comment
new file mode 100644
index 000000000000..b92f57179e88
--- /dev/null
+++ b/net/lambdamoo/pkg-comment
@@ -0,0 +1 @@
+The most commonly used program to run MOOs
diff --git a/net/lambdamoo/pkg-descr b/net/lambdamoo/pkg-descr
new file mode 100644
index 000000000000..7405c420a30c
--- /dev/null
+++ b/net/lambdamoo/pkg-descr
@@ -0,0 +1,14 @@
+LambdaMOO is a network-accessible, multi-user, programmable, interactive
+system well-suited to the construction of text-based adventure games,
+conferencing systems, and other collaborative software.
+
+Its most common use, however, is as a multi-participant,
+low-bandwidth virtual reality, and it is with this focus in mind
+that I describe it here.
+
+See also /usr/local/share/doc/LambdaMOO.
+
+http://www.moo.mud.org/
+
+- Seiichirou Hiraoka
+flathill@FreeBSD.ORG
diff --git a/net/lambdamoo/pkg-plist b/net/lambdamoo/pkg-plist
new file mode 100644
index 000000000000..07a18553525b
--- /dev/null
+++ b/net/lambdamoo/pkg-plist
@@ -0,0 +1,6 @@
+sbin/moo
+share/doc/LambdaMOO/Minimal.db
+share/doc/LambdaMOO/README
+share/doc/LambdaMOO/README.FreeBSD
+share/doc/LambdaMOO/README.Minimal
+@dirrm share/doc/LambdaMOO