aboutsummaryrefslogtreecommitdiff
path: root/net/lanbrowsing
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2004-09-03 17:00:29 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2004-09-03 17:00:29 +0000
commit800460fc76154e739ac7008ed874e8b3bd43b060 (patch)
tree752801a5d9f8ee467393db77fb4f2c57da16d7b2 /net/lanbrowsing
parentde9ec12a4ffbcf1c14a3ec8481bb9b95ff18de2e (diff)
downloadports-800460fc76154e739ac7008ed874e8b3bd43b060.tar.gz
ports-800460fc76154e739ac7008ed874e8b3bd43b060.zip
Factor out the lanbrowsing part of kdenetwork3 into its own port.
Notes
Notes: svn path=/head/; revision=118052
Diffstat (limited to 'net/lanbrowsing')
-rw-r--r--net/lanbrowsing/Makefile56
-rw-r--r--net/lanbrowsing/distinfo2
-rw-r--r--net/lanbrowsing/files/lisa.sh23
-rw-r--r--net/lanbrowsing/files/patch-lanbrowsing_kcmlisa_setupwizard.cpp19
-rw-r--r--net/lanbrowsing/pkg-descr10
-rw-r--r--net/lanbrowsing/pkg-plist28
6 files changed, 138 insertions, 0 deletions
diff --git a/net/lanbrowsing/Makefile b/net/lanbrowsing/Makefile
new file mode 100644
index 000000000000..afec21d4fbc3
--- /dev/null
+++ b/net/lanbrowsing/Makefile
@@ -0,0 +1,56 @@
+# New ports collection makefile for: lanbrowsing
+# Date created: September 02 2004
+# Whom: Michael Nottebrock <lofi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= lanbrowsing
+PORTVERSION= ${KDE_VERSION}
+CATEGORIES= net kde
+MASTER_SITES= ${MASTER_SITE_KDE}
+MASTER_SITE_SUBDIR= stable/${PORTVERSION:S/.0//}/src
+PKGNAMEPREFIX= kdenetwork-
+DISTNAME= kdenetwork-${PORTVERSION}
+DIST_SUBDIR= KDE
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Lanbrowsing facility and backend for KDE
+
+RUN_DEPENDS= nmblookup:${PORTSDIR}/net/samba3
+
+CONFLICTS= kdenetwork-3.3.0
+
+USE_KDELIBS_VER=3
+PREFIX= ${KDE_PREFIX}
+
+USE_RC_SUBR= yes
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+WRKSRC= ${WRKDIR}/kdenetwork-${PORTVERSION}
+INSTALLS_SHLIB= yes
+
+RC_SCRIPTS_SUB= PREFIX=${PREFIX} \
+ RC_SUBR=${RC_SUBR}
+
+.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
+.include <bsd.port.pre.mk>
+
+pre-configure:
+ ${ECHO_CMD} ${PORTNAME} doc > ${WRKSRC}/inst-apps
+ ${REINPLACE_CMD} \
+ 's|^SUBDIRS =.*lisa.*$$|SUBDIRS =\. lisa|g' \
+ ${WRKSRC}/doc/Makefile.in
+ @${REINPLACE_CMD} -e 's|/etc|${PREFIX}/etc|g' \
+ ${WRKSRC}/lanbrowsing/kcmlisa/main.cpp \
+ ${WRKSRC}/lanbrowsing/kcmlisa/kcmlisa.cpp \
+ ${WRKSRC}/lanbrowsing/kcmlisa/setupwizard.cpp
+
+post-install:
+ @${MKDIR} ${PREFIX}/etc/rc.d
+ @${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
+ ${FILESDIR}/lisa.sh > ${PREFIX}/etc/rc.d/lisa.sh
+ @${CHMOD} +x ${PREFIX}/etc/rc.d/lisa.sh
+
+.include <bsd.port.post.mk>
diff --git a/net/lanbrowsing/distinfo b/net/lanbrowsing/distinfo
new file mode 100644
index 000000000000..af80768704f4
--- /dev/null
+++ b/net/lanbrowsing/distinfo
@@ -0,0 +1,2 @@
+MD5 (KDE/kdenetwork-3.3.0.tar.bz2) = ae7d989594ec2a7c073478e4535c284b
+SIZE (KDE/kdenetwork-3.3.0.tar.bz2) = 6971120
diff --git a/net/lanbrowsing/files/lisa.sh b/net/lanbrowsing/files/lisa.sh
new file mode 100644
index 000000000000..4f609cc04bdb
--- /dev/null
+++ b/net/lanbrowsing/files/lisa.sh
@@ -0,0 +1,23 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+# PROVIDE: lisa
+# REQUIRE: LOGIN
+# KEYWORD: FreeBSD
+
+lisa_enable="NO"
+lisa_conffile="%%PREFIX%%/etc/lisarc"
+
+. %%RC_SUBR%%
+
+name="lisa"
+rcvar=`set_rcvar`
+command="%%PREFIX%%/bin/lisa"
+command_args="-q -c ${lisa_conffile}"
+required_files="${lisa_conffile}"
+
+load_rc_config $name
+
+run_rc_command "$1"
diff --git a/net/lanbrowsing/files/patch-lanbrowsing_kcmlisa_setupwizard.cpp b/net/lanbrowsing/files/patch-lanbrowsing_kcmlisa_setupwizard.cpp
new file mode 100644
index 000000000000..f82319ba2273
--- /dev/null
+++ b/net/lanbrowsing/files/patch-lanbrowsing_kcmlisa_setupwizard.cpp
@@ -0,0 +1,19 @@
+--- lanbrowsing/kcmlisa/setupwizard.cpp.orig Fri Jun 25 11:10:25 2004
++++ lanbrowsing/kcmlisa/setupwizard.cpp Sun Aug 29 18:49:41 2004
+@@ -349,11 +349,11 @@
+ m_finalPage=new QVBox(this);
+ QLabel *info=new QLabel(i18n("<br>Your LAN browsing has been successfully set up.<br><br>"
+ "Make sure that the LISa server is started during the "
+- "boot process. How this is done depends on your "
+- "distribution and OS. Usually you have to insert it somewhere "
+- "in a boot script under <code>/etc</code>.<br>"
+- "Start the LISa server as root and without any command line options.<br>"
+- "The config file will now be saved to <code>/etc/lisarc</code>.<br>"
++ "boot process. The kdenetwork port has installed "
++ "a startup-script (lisa.sh) into <code>/usr/local/etc/rc.d</code>. "
++ "To activate lisa, put lisa_enable=\"YES\" into your rc.conf.<br> "
++ "<br>"
++ "The config file will now be saved to <code>/usr/local/etc/lisarc</code>.<br>"
+ "To test the server, try <code>lan:/</code> in Konqueror.<br><br>"
+ "If you have problems or suggestions, visit http://lisa-home.sourceforge.net."),m_finalPage);
+ info->setTextFormat(Qt::RichText);
diff --git a/net/lanbrowsing/pkg-descr b/net/lanbrowsing/pkg-descr
new file mode 100644
index 000000000000..605ec0044bcd
--- /dev/null
+++ b/net/lanbrowsing/pkg-descr
@@ -0,0 +1,10 @@
+This is the lanbrowsing utility package for KDE. It contains:
+
+- The lan:/ kioslave for Konqueror which lets you browse
+ several services on your local network like http, ftp, smb and nfs.
+
+- The LISa daemon, the backend for the lan:/ kioslave which scans your network
+ for hosts and services.
+
+- A wizard to setup the LISa daemon.
+
diff --git a/net/lanbrowsing/pkg-plist b/net/lanbrowsing/pkg-plist
new file mode 100644
index 000000000000..5c95d0937c18
--- /dev/null
+++ b/net/lanbrowsing/pkg-plist
@@ -0,0 +1,28 @@
+bin/lisa
+bin/reslisa
+etc/rc.d/lisa.sh
+lib/kde3/kcm_lanbrowser.la
+lib/kde3/kcm_lanbrowser.so
+lib/kde3/kio_lan.la
+lib/kde3/kio_lan.so
+share/applnk/.hidden/kcmkiolan.desktop
+share/applnk/.hidden/kcmlisa.desktop
+share/applnk/.hidden/kcmreslisa.desktop
+share/apps/konqsidebartng/virtual_folders/services/lisa.desktop
+share/apps/konqueror/dirtree/remote/lan.desktop
+share/apps/lisa/README
+share/doc/HTML/en/lisa/common
+share/doc/HTML/en/lisa/index.cache.bz2
+share/doc/HTML/en/lisa/index.docbook
+share/services/lan.protocol
+share/services/rlan.protocol
+@dirrm share/doc/HTML/en/lisa
+@dirrm share/apps/lisa
+@dirrm share/apps/konqueror/dirtree/remote
+@dirrm share/apps/konqueror/dirtree
+@dirrm share/apps/konqueror
+@dirrm share/apps/konqsidebartng/virtual_folders/services
+@dirrm share/apps/konqsidebartng/virtual_folders
+@dirrm share/apps/konqsidebartng
+@dirrm share/applnk/.hidden
+@dirrm share/applnk