aboutsummaryrefslogtreecommitdiff
path: root/net/libnids/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2007-01-31 14:09:55 +0000
committerPav Lucistnik <pav@FreeBSD.org>2007-01-31 14:09:55 +0000
commiteb81a88093e7d71530eebb2957f8ba4317b26ee6 (patch)
tree9290c97700f22b8ed6b87a10fda7d195dac09f04 /net/libnids/Makefile
parente6b247dce1d9f6355a583ef6269fdbba110eaea8 (diff)
downloadports-eb81a88093e7d71530eebb2957f8ba4317b26ee6.tar.gz
ports-eb81a88093e7d71530eebb2957f8ba4317b26ee6.zip
- Patch net/libnet* to versioned libraries and header files, so they can
coexist PR: ports/103861 Submitted by: alepulver Tested by: pointyhat With hat: portmgr
Notes
Notes: svn path=/head/; revision=183770
Diffstat (limited to 'net/libnids/Makefile')
-rw-r--r--net/libnids/Makefile18
1 files changed, 13 insertions, 5 deletions
diff --git a/net/libnids/Makefile b/net/libnids/Makefile
index 76103a1eb6e7..7b63389a8c1a 100644
--- a/net/libnids/Makefile
+++ b/net/libnids/Makefile
@@ -7,7 +7,7 @@
PORTNAME= libnids
PORTVERSION= 1.21
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -20,19 +20,23 @@ OPTIONS= LIBNET "Include code requiring libnet" ON \
GLIB2 "Use GLIB2 for multiprocessing support" ON
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
MAKE_ENV= LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+MAN3= libnids.3
+
.include <bsd.port.pre.mk>
.if !defined(WITHOUT_LIBNET)
.if !defined(WITHOUT_LIBNET10)
-BUILD_DEPENDS+= libnet*<=1.1.0,1:${PORTSDIR}/net/libnet10
+BUILD_DEPENDS+= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet10
+LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet10-config
.else
-BUILD_DEPENDS+= libnet*>=1.1.2,1:${PORTSDIR}/net/libnet
+BUILD_DEPENDS+= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet
+LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
.endif
.else
CONFIGURE_ARGS+= --disable-libnet
@@ -44,7 +48,11 @@ LIB_DEPENDS+= glib-2.0:${PORTSDIR}/devel/glib20
CONFIGURE_ARGS+= --disable-libglib
.endif
-MAN3= libnids.3
+post-patch:
+ @${REINPLACE_CMD} -Ee \
+ 's|(LNET_CFLAGS=).*|\1"`${LIBNET_CONFIG} --defines` `${LIBNET_CONFIG} --cflags`"|; \
+ s|(LNETLIB=).*|\1"`${LIBNET_CONFIG} --libs`"|' \
+ ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
do-install:
${INSTALL_DATA} ${WRKSRC}/src/nids.h ${PREFIX}/include