aboutsummaryrefslogtreecommitdiff
path: root/net/libsocket++
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2014-02-10 13:05:31 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2014-02-10 13:05:31 +0000
commit8a4e5643c0d82e907e3551cfae6565802a3048ef (patch)
treef648723cffa01c271dff6b3b40a45c9f9852feda /net/libsocket++
parente6ef2c96d51dcd2db98bddebfb9c1b05b2b7387b (diff)
downloadports-8a4e5643c0d82e907e3551cfae6565802a3048ef.tar.gz
ports-8a4e5643c0d82e907e3551cfae6565802a3048ef.zip
- Convert USE_AUTOTOOLS=libtool to USES=libtool.
- Replace pre-configure target with USE_AUTOTOOLS. - Staging and DOCS option. PR: 186603 Submitted by: tijl
Notes
Notes: svn path=/head/; revision=343627
Diffstat (limited to 'net/libsocket++')
-rw-r--r--net/libsocket++/Makefile20
-rw-r--r--net/libsocket++/files/patch-autogen20
-rw-r--r--net/libsocket++/pkg-plist7
3 files changed, 14 insertions, 33 deletions
diff --git a/net/libsocket++/Makefile b/net/libsocket++/Makefile
index 598914c1e73d..d93cacc494bb 100644
--- a/net/libsocket++/Makefile
+++ b/net/libsocket++/Makefile
@@ -3,6 +3,7 @@
PORTNAME= libsocket++
PORTVERSION= 1.12.13
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://src.linuxhacker.at/socket++/
DISTNAME= socket++-${PORTVERSION}
@@ -12,21 +13,20 @@ COMMENT= A C++ wrapper library to the sockets
LICENSE= BSD
LICENSE_FILE= ${WRKSRC}/COPYING
+
+OPTIONS_DEFINE= DOCS
+
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-USE_AUTOTOOLS= automake autoconf libtool
-SCRIPTS_ENV+= ACLOCAL_FLAGS="-I ${LOCALBASE}/share/aclocal/"
+USES= libtool
+USE_AUTOTOOLS= aclocal autoheader automake autoconf libtoolize
+AUTOMAKE_ARGS= -a -c
+LIBTOOLIZE_ARGS=-i -c
INFO= socket++
-NO_STAGE= yes
-pre-configure:
- @(cd ${WRKSRC}; ${SETENV} ${SCRIPTS_ENV} ${SH} ./autogen)
-
post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/doc/libsocket++
- ${INSTALL_MAN} ${WRKSRC}/README ${PREFIX}/share/doc/libsocket++
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/net/libsocket++/files/patch-autogen b/net/libsocket++/files/patch-autogen
deleted file mode 100644
index 819a8917181c..000000000000
--- a/net/libsocket++/files/patch-autogen
+++ /dev/null
@@ -1,20 +0,0 @@
---- autogen.orig Tue Mar 18 15:47:57 2003
-+++ autogen Wed Jul 7 17:45:10 2004
-@@ -14,12 +14,12 @@
- else
-- libtoolize --automake
-+ ${LIBTOOLIZE} --automake
- fi
- echo "aclocal..."
--aclocal
-+${ACLOCAL} ${ACLOCAL_FLAGS}
- echo "autoheader..."
--autoheader
-+${AUTOHEADER}
- echo "automake..."
--automake --add-missing
-+${AUTOMAKE} --add-missing
- echo "autoconf..."
--autoconf
-+${AUTOCONF}
-
diff --git a/net/libsocket++/pkg-plist b/net/libsocket++/pkg-plist
index 32e0ceb711f4..c70d216487a8 100644
--- a/net/libsocket++/pkg-plist
+++ b/net/libsocket++/pkg-plist
@@ -1,7 +1,8 @@
lib/libsocket++.a
lib/libsocket++.la
-lib/libsocket++.so.1
lib/libsocket++.so
+lib/libsocket++.so.1
+lib/libsocket++.so.1.0.2
include/socket++/fork.h
include/socket++/echo.h
include/socket++/ftp.h
@@ -12,6 +13,6 @@ include/socket++/smtp.h
include/socket++/sockinet.h
include/socket++/sockstream.h
include/socket++/sockunix.h
-%%PORTDOCS%%share/doc/libsocket++/README
-@dirrm share/doc/libsocket++
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm include/socket++