aboutsummaryrefslogtreecommitdiff
path: root/net/libtnl/Makefile
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-02-18 00:23:57 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-02-18 00:23:57 +0000
commit300b5df8c3647880b32a7c039fffa602e9384751 (patch)
tree9191886b034d7fc1528c762b71c82079ece3b61e /net/libtnl/Makefile
parent1afed7cc8da801ffb0bc77b2d47cf4d42cd312b6 (diff)
downloadports-300b5df8c3647880b32a7c039fffa602e9384751.tar.gz
ports-300b5df8c3647880b32a7c039fffa602e9384751.zip
Adding port net/libtnl, the Torque networking library which implements a C++ networking API for high-performance simulations and games.
Submitted by: aaron Approved by: tobez
Notes
Notes: svn path=/head/; revision=156244
Diffstat (limited to 'net/libtnl/Makefile')
-rw-r--r--net/libtnl/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/net/libtnl/Makefile b/net/libtnl/Makefile
new file mode 100644
index 000000000000..bb78ac4df78b
--- /dev/null
+++ b/net/libtnl/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: libtnl
+# Date created: 26 Jan 2006
+# Whom: aaron@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= libtnl
+PORTVERSION= 1.5.0
+CATEGORIES= net devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
+MASTER_SITE_SUBDIR= opentnl
+DISTNAME= tnl-${PORTVERSION}-source
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= A robust, secure, easy to use cross-platform C++ networking API
+
+WRKSRC= ${WRKDIR}/tnl/tnl
+INSTALLS_SHLIB= yes
+ONLY_FOR_ARCHS= i386
+
+post-extract:
+ @${CP} ${PATCHDIR}/Makefile.bsd ${WRKSRC}/Makefile
+
+pre-install:
+ ${MKDIR} ${PREFIX}/include/tnl
+
+.include <bsd.port.mk>