aboutsummaryrefslogtreecommitdiff
path: root/net/licq
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2004-08-03 19:58:35 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2004-08-03 19:58:35 +0000
commitd80b83baa88a0ca84a2f492a4fea6e06b77fdafa (patch)
tree5a9f380c5f4b98b31e86c3d27d7b02a1c3f53ed3 /net/licq
parent25b060c90f35aaff75d3b1306db321eccf334b65 (diff)
downloadports-d80b83baa88a0ca84a2f492a4fea6e06b77fdafa.tar.gz
ports-d80b83baa88a0ca84a2f492a4fea6e06b77fdafa.zip
- fix gcc34 problem
PR: 69823 Submitted by: Francois Tigeot
Notes
Notes: svn path=/head/; revision=115358
Diffstat (limited to 'net/licq')
-rw-r--r--net/licq/Makefile6
-rw-r--r--net/licq/files/patch-socket.cpp42
-rw-r--r--net/licq/files/patch-user.cpp11
3 files changed, 41 insertions, 18 deletions
diff --git a/net/licq/Makefile b/net/licq/Makefile
index 055a19cc514d..c86cb335bc9f 100644
--- a/net/licq/Makefile
+++ b/net/licq/Makefile
@@ -7,7 +7,7 @@
PORTNAME= base
PORTVERSION= ${LICQ_VER}
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net
PKGNAMESUFFIX= ${SOCKS_SUFFIX}${PKGNAMESUFFIX2}
@@ -60,8 +60,4 @@ post-install:
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/${LICQ_PORT}/Makefile.inc"
-.if ${OSVERSION} >= 502122
-BROKEN= new gcc: cast to non-reference type
-.endif
-
.include <bsd.port.post.mk>
diff --git a/net/licq/files/patch-socket.cpp b/net/licq/files/patch-socket.cpp
index 36d9f1d9f585..b13f17e44d56 100644
--- a/net/licq/files/patch-socket.cpp
+++ b/net/licq/files/patch-socket.cpp
@@ -1,6 +1,6 @@
---- src/socket.cpp.orig Thu Jan 2 22:08:06 2003
-+++ src/socket.cpp Wed Jan 8 07:58:47 2003
-@@ -13,6 +13,9 @@
+--- src/socket.cpp.orig Mon Jun 16 19:09:46 2003
++++ src/socket.cpp Mon Aug 2 16:05:55 2004
+@@ -20,6 +20,9 @@
#include <netdb.h>
#include <fcntl.h>
#include <unistd.h>
@@ -10,7 +10,15 @@
#ifdef HAVE_INET_ATON
#include <arpa/inet.h>
-@@ -427,7 +430,11 @@
+@@ -49,7 +52,6 @@
+ #ifdef USE_SOCKS5
+
+ #define SOCKS
+-#define INCLUDE_PROTOTYPES
+ extern "C" {
+ #include <socks.h>
+ }
+@@ -489,7 +491,11 @@
m_sRemoteAddr.sin_family = AF_INET;
// if connect fails then call CloseConnection to clean up before returning
@@ -22,13 +30,21 @@
if (connect(m_nDescriptor, (struct sockaddr *)&m_sRemoteAddr, sizeofSockaddr) < 0)
{
// errno has been set
---- src/socket.cpp.orig Wed Jan 29 13:19:59 2003
-+++ src/socket.cpp Wed Jan 29 13:20:20 2003
-@@ -42,7 +42,6 @@
- #ifdef USE_SOCKS5
+@@ -1078,7 +1084,7 @@
+ bool TCPSocket::SecureConnect()
+ {
+ pthread_mutex_init(&mutex_ssl, NULL);
+- m_pSSL = SSL_new(gSSL_CTX);
++ m_p_SSL = SSL_new(gSSL_CTX);
+ #ifdef SSL_DEBUG
+ m_pSSL->debug = 1;
+ #endif
+@@ -1111,7 +1117,7 @@
+ {
+ pthread_mutex_init(&mutex_ssl, NULL);
- #define SOCKS
--#define INCLUDE_PROTOTYPES
- extern "C" {
- #include <socks.h>
- }
+- m_pSSL = SSL_new(gSSL_CTX);
++ m_p_SSL = SSL_new(gSSL_CTX);
+ SSL_set_session(m_pSSL, NULL);
+ SSL_set_fd(m_pSSL, m_nDescriptor);
+ int i = SSL_accept(m_pSSL);
diff --git a/net/licq/files/patch-user.cpp b/net/licq/files/patch-user.cpp
new file mode 100644
index 000000000000..558025936493
--- /dev/null
+++ b/net/licq/files/patch-user.cpp
@@ -0,0 +1,11 @@
+--- src/user.cpp.orig Mon Jun 16 19:09:46 2003
++++ src/user.cpp Fri Jul 30 20:10:16 2004
+@@ -3184,7 +3184,7 @@
+ m_fConf.ReadBool("HideIP", m_bHideIp, false);
+ m_fConf.ReadNum("RCG", m_nRandomChatGroup, ICQ_RANDOMxCHATxGROUP_NONE);
+ m_fConf.ReadStr("AutoResponse", szTemp, "");
+- m_fConf.ReadNum("SSTime", (unsigned long)m_nSSTime, 0L);
++ m_fConf.ReadNum("SSTime", (unsigned long&)m_nSSTime, 0L);
+ m_fConf.ReadNum("SSCount", m_nSSCount, 0);
+ SetAutoResponse(szTemp);
+