aboutsummaryrefslogtreecommitdiff
path: root/net/limewire
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2002-07-11 22:00:14 +0000
committerPatrick Li <pat@FreeBSD.org>2002-07-11 22:00:14 +0000
commit50b1f434a5d67565ac1a3e39c8a4e3b5815833f0 (patch)
tree935de2d5a1cbfddbbb767a8196648f7d92e54194 /net/limewire
parent52d02028e02fd37b2b4b9deee0b2f6446bd79704 (diff)
downloadports-50b1f434a5d67565ac1a3e39c8a4e3b5815833f0.tar.gz
ports-50b1f434a5d67565ac1a3e39c8a4e3b5815833f0.zip
Add new port net/limewire - A Java based gnutella client
PR: ports/35266 Submitted by: Kyle Martin <mkm@ieee.org> Reviewed by: lioux
Notes
Notes: svn path=/head/; revision=62832
Diffstat (limited to 'net/limewire')
-rw-r--r--net/limewire/Makefile39
-rw-r--r--net/limewire/distinfo1
-rw-r--r--net/limewire/files/patch-runLime.sh15
-rw-r--r--net/limewire/pkg-comment1
-rw-r--r--net/limewire/pkg-descr10
-rw-r--r--net/limewire/pkg-plist10
6 files changed, 76 insertions, 0 deletions
diff --git a/net/limewire/Makefile b/net/limewire/Makefile
new file mode 100644
index 000000000000..56b24976cefe
--- /dev/null
+++ b/net/limewire/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: limewire
+# Date created: Fri Feb 22 00:28:41 CST 2002
+# Whom: Kyle Martin <mkm@ieee.org> et al
+#
+# $FreeBSD$
+#
+
+PORTNAME= limewire
+PORTVERSION= 2.4
+CATEGORIES= net java
+MASTER_SITES= http://www3.limewire.com/download/
+DISTNAME= LimeWireLinux
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= mkm@ieee.org
+
+USE_JAVA= 1.3+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+NO_CDROM= "License does not allow"
+
+JAR_DIR= ${PREFIX}/share/java/jar/limewire
+PLIST_SUB= JAR_DIR="${JAR_DIR:S/${PREFIX}//}"
+
+post-patch:
+ @${SED} 's|%%JAR_DIR%%|${JAR_DIR}|; s|%%LOCALBASE%%|${LOCALBASE}|' \
+ ${WRKSRC}/runLime.sh > ${WRKSRC}/runLime.sh.sed
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/runLime.sh.sed ${PREFIX}/bin/limewire
+ @${MKDIR} ${JAR_DIR}
+ @${INSTALL_DATA} ${WRKSRC}/*.jar ${WRKSRC}/MessagesBundle.properties \
+ ${JAR_DIR}
+.ifndef(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/license_agreement.txt ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/limewire/distinfo b/net/limewire/distinfo
new file mode 100644
index 000000000000..09f37d6ed4a4
--- /dev/null
+++ b/net/limewire/distinfo
@@ -0,0 +1 @@
+MD5 (LimeWireLinux.tgz) = 26106151da2813230570a11480decde6
diff --git a/net/limewire/files/patch-runLime.sh b/net/limewire/files/patch-runLime.sh
new file mode 100644
index 000000000000..0f970f9b8413
--- /dev/null
+++ b/net/limewire/files/patch-runLime.sh
@@ -0,0 +1,15 @@
+--- runLime.sh.orig Thu Mar 14 14:00:50 2002
++++ runLime.sh Thu Jul 11 17:07:02 2002
+@@ -7,8 +7,9 @@
+ # work around some limitations in the JDK1.3. For more information
+ # see http://java.sun.com/j2se/1.3/relnotes.html#vm
+ #
+-CLASSPATH=".:collections.jar:xerces.jar:jl011.jar"
+-export CLASSPATH
++CLASSPATH="%%JAR_DIR%%"
+ J2SE_PREEMPTCLOSE=1
+ export J2SE_PREEMPTCLOSE
+-java -jar RunLime.jar
++exec %%LOCALBASE%%/bin/javavm \
++ -cp ${CLASSPATH}/collections.jar:${CLASSPATH}/xerces.jar:${CLASSPATH}/jl011.jar \
++ -jar ${CLASSPATH}/LimeWire.jar
diff --git a/net/limewire/pkg-comment b/net/limewire/pkg-comment
new file mode 100644
index 000000000000..97c178b4bb1c
--- /dev/null
+++ b/net/limewire/pkg-comment
@@ -0,0 +1 @@
+A Java based gnutella client
diff --git a/net/limewire/pkg-descr b/net/limewire/pkg-descr
new file mode 100644
index 000000000000..1dbccdcfe326
--- /dev/null
+++ b/net/limewire/pkg-descr
@@ -0,0 +1,10 @@
+LimeWire is a software package which enables individuals to search
+for and share computer files with anyone on the internet. A product
+of Lime Wire, LLC, LimeWire is compatible with the Gnutella
+file-sharing protocol and can connect with anyone else running
+Gnutella-compatible software. The LimeWire program will connect at
+startup, via the internet, to the LimeWire Gateway, a specialized
+intelligent Gnutella router, to maximize the user's viewable network
+space.
+
+WWW: http://www.limewire.com/
diff --git a/net/limewire/pkg-plist b/net/limewire/pkg-plist
new file mode 100644
index 000000000000..780e7f702df9
--- /dev/null
+++ b/net/limewire/pkg-plist
@@ -0,0 +1,10 @@
+bin/limewire
+%%PORTDOCS%%share/doc/limewire/license_agreement.txt
+%%JAR_DIR%%/LimeWire.jar
+%%JAR_DIR%%/MessagesBundle.properties
+%%JAR_DIR%%/collections.jar
+%%JAR_DIR%%/jl011.jar
+%%JAR_DIR%%/xerces.jar
+@dirrm %%JAR_DIR%%
+@unexec rmdir %D/share/java/jar 2>/dev/null || true
+%%PORTDOCS%%@dirrm share/doc/limewire