aboutsummaryrefslogtreecommitdiff
path: root/net/miniupnpc
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2009-08-13 14:52:01 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2009-08-13 14:52:01 +0000
commitc216e0e34f22d56f8c065a425289ad826f92438c (patch)
treef0965a0dd01536ae8405d28c4314b659af0ee7da /net/miniupnpc
parent08819b4e6fc2aa75ce77153482eacb0e3cce0d39 (diff)
downloadports-c216e0e34f22d56f8c065a425289ad826f92438c.tar.gz
ports-c216e0e34f22d56f8c065a425289ad826f92438c.zip
- compile in FreeBSD version string
- add support for slave ports PR: 137612 Submitted by: Anonymous
Notes
Notes: svn path=/head/; revision=239439
Diffstat (limited to 'net/miniupnpc')
-rw-r--r--net/miniupnpc/Makefile21
-rw-r--r--net/miniupnpc/files/patch-updateminiupnpcstrings.sh11
2 files changed, 29 insertions, 3 deletions
diff --git a/net/miniupnpc/Makefile b/net/miniupnpc/Makefile
index e7e45183e736..94fc04f7824f 100644
--- a/net/miniupnpc/Makefile
+++ b/net/miniupnpc/Makefile
@@ -7,19 +7,34 @@
PORTNAME= miniupnpc
PORTVERSION= 1.3
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://miniupnp.free.fr/files/
MAINTAINER= dinoex@FreeBSD.org
-COMMENT= UPnP IGD client lightweight library
+COMMENT?= UPnP IGD client lightweight library
+HAS_CONFIGURE= yes
USE_GMAKE= yes
+USE_LDCONFIG= yes
+
+CONFIGURE_SCRIPT= updateminiupnpcstrings.sh
MAKE_ENV+= INSTALLPREFIX=${PREFIX}
CFLAGS+= -fPIC
-USE_LDCONFIG= yes
+
+.include <bsd.port.pre.mk>
+
+.if !defined(SLAVE_PORT)
MAN3= miniupnpc.3
+.endif
+
+.if defined(WITH_DEBUG)
+CFLAGS+= -DDEBUG
+.endif
+.if !defined(SLAVE_PORT)
post-install:
${INSTALL_MAN} ${WRKSRC}/man3/miniupnpc.3 ${PREFIX}/man/man3/
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net/miniupnpc/files/patch-updateminiupnpcstrings.sh b/net/miniupnpc/files/patch-updateminiupnpcstrings.sh
new file mode 100644
index 000000000000..1a6e4f7b7fff
--- /dev/null
+++ b/net/miniupnpc/files/patch-updateminiupnpcstrings.sh
@@ -0,0 +1,11 @@
+--- updateminiupnpcstrings.sh~
++++ updateminiupnpcstrings.sh
+@@ -27,7 +27,7 @@ fi
+
+ echo "Detected OS [$OS_NAME] version [$OS_VERSION]"
+
+-EXPR="s/OS_STRING\s\".*\"/OS_STRING \"${OS_NAME}\/${OS_VERSION}\"/"
++EXPR="/OS_STRING/s|\".*\"|\"${OS_NAME}/${OS_VERSION}\"|"
+ #echo $EXPR
+ echo "Backuping $FILE to $FILE.bak."
+ cp $FILE $FILE.bak