aboutsummaryrefslogtreecommitdiff
path: root/net/morebalance
diff options
context:
space:
mode:
authorClement Laforet <clement@FreeBSD.org>2004-06-02 10:06:30 +0000
committerClement Laforet <clement@FreeBSD.org>2004-06-02 10:06:30 +0000
commited3c9e74c36f3ec1dcad25ecca4531fb4ed646d7 (patch)
treec466de0b6237da49a6bc6b64a6a4338ed18909ed /net/morebalance
parente71642a6393f301e08a86f75db1d9076efdb1965 (diff)
downloadports-ed3c9e74c36f3ec1dcad25ecca4531fb4ed646d7.tar.gz
ports-ed3c9e74c36f3ec1dcad25ecca4531fb4ed646d7.zip
- Update to 0.3
- Update WWW - Fix dependency on ggz.2 - clean up the port
Notes
Notes: svn path=/head/; revision=110661
Diffstat (limited to 'net/morebalance')
-rw-r--r--net/morebalance/Makefile31
-rw-r--r--net/morebalance/distinfo4
-rw-r--r--net/morebalance/files/patch-Makefile33
-rw-r--r--net/morebalance/pkg-descr2
-rw-r--r--net/morebalance/pkg-plist1
5 files changed, 29 insertions, 42 deletions
diff --git a/net/morebalance/Makefile b/net/morebalance/Makefile
index a90e2853b9e8..b101bcb78c4c 100644
--- a/net/morebalance/Makefile
+++ b/net/morebalance/Makefile
@@ -6,30 +6,24 @@
#
PORTNAME= morebalance
-PORTVERSION= 0.2
+PORTVERSION= 0.3
CATEGORIES= net
-MASTER_SITES= http://sheepkiller.nerim.net/ports/${PORTNAME}/ \
- http://mindx.dyndns.org/morebalance/
+MASTER_SITES= http://morebalance.coolprojects.org/
MAINTAINER= clement@FreeBSD.org
COMMENT= A modular open source user-space load balancing system
+LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre \
+ gnutls.13:${PORTSDIR}/security/gnutls \
+ ggz.2:${PORTSDIR}/games/libggz
+
CFLAGS+= ${PTHREAD_CFLAGS} -I${LOCALBASE}/include
-MAKE_ARGS+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS}"
-USE_GETOPT_LONG= yes
-
-.if defined(WITH_PCRE)
-LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
-CFLAGS+= -DUSE_PCRE
-LDFLAGS+= -L${LOCALBASE}/lib -lpcre
-.endif
-
-.if defined(WITH_TLS)
-LIB_DEPENDS+= gnutls.13:${PORTSDIR}/security/gnutls \
- ggz.1:${PORTSDIR}/games/libggz
-CFLAGS+= -DUSE_TLS
-LDFLAGS+= -lggz -lgnutls -L${LOCALBASE}/lib
-.endif
+MAKE_ARGS+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+USE_GETTEXT= YES
+USE_GETOPT_LONG=yes
+
+LDFLAGS+= -L${LOCALBASE}/lib -lpcre -lggz -lgnutls \
+ -L${LOCALBASE}/lib ${PTHREAD_LIBS}
MAN1= morebalance.1
MAN5= morebalance.conf.5
@@ -39,5 +33,6 @@ do-install:
@${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.conf ${PREFIX}/etc/${PORTNAME}.conf.sample
@${INSTALL_MAN} ${WRKSRC}/doc/${PORTNAME}.1 ${MANPREFIX}/man/man1
@${INSTALL_MAN} ${WRKSRC}/doc/${PORTNAME}.conf.5 ${MANPREFIX}/man/man5
+ @${MAKE_ENV} ${MAKE} -C ${WRKSRC} install-messages
.include <bsd.port.mk>
diff --git a/net/morebalance/distinfo b/net/morebalance/distinfo
index 3d2708b930bc..35b36f72062b 100644
--- a/net/morebalance/distinfo
+++ b/net/morebalance/distinfo
@@ -1,2 +1,2 @@
-MD5 (morebalance-0.2.tar.gz) = 2b917d789dcc620abe68df295d91fec7
-SIZE (morebalance-0.2.tar.gz) = 25507
+MD5 (morebalance-0.3.tar.gz) = 54067547d3ce92320edb0ac81e05b7e9
+SIZE (morebalance-0.3.tar.gz) = 35825
diff --git a/net/morebalance/files/patch-Makefile b/net/morebalance/files/patch-Makefile
index d1113ed77130..eeade5ca46a4 100644
--- a/net/morebalance/files/patch-Makefile
+++ b/net/morebalance/files/patch-Makefile
@@ -1,34 +1,25 @@
---- Makefile.orig Wed Oct 8 13:54:08 2003
-+++ Makefile Sat Oct 11 15:38:37 2003
-@@ -1,26 +1,21 @@
- VERSION = 0.2
--#PCRE=-lpcre
--#GNUTLS=-lggz -lgnutls
+--- Makefile.orig Tue Jun 1 23:06:03 2004
++++ Makefile Wed Jun 2 11:55:57 2004
+@@ -1,19 +1,14 @@
+ VERSION = 0.3
+-PCRE=-lpcre
+-GNUTLS=-lggz -lgnutls
-
-CC = gcc
-CFLAGS = -Wall -O3 -ggdb3
OBJECTS = main.o conf.o sys.o magic.o server.o ipban.o filter.o
+-prefix = /usr/local
+-confprefix = /usr/local/etc
++prefix = ${PREFIX}
++confprefix = ${PREFIX}/etc
+
all: morebalance
morebalance: $(OBJECTS)
- $(CC) -o $@ $(OBJECTS) -lpthread $(PCRE) $(GNUTLS)
-+ $(CC) $(CFLAGS) -o $@ $(OBJECTS) $(LDFLAGS)
++ $(CC) -o $@ $(OBJECTS) $(CFLAGS) $(LDFLAGS)
clean:
rm -f *.o
- rm -f morebalance
-
- install: morebalance
-- install -d -m755 $(DESTDIR)$(prefix)/usr/bin
-- install -d -m755 $(DESTDIR)$(prefix)/etc
-- cp morebalance $(DESTDIR)$(prefix)/usr/bin
-- cp morebalance.conf $(DESTDIR)$(prefix)/etc
-+ install -d -m755 $(DESTDIR)$(PREFIX)/bin
-+ install -d -m755 $(DESTDIR)$(PREFIX)/etc
-+ cp morebalance $(DESTDIR)$(PREFIX)/bin
-+ cp morebalance.conf $(DESTDIR)$(PREFIX)/etc
-
- distclean: clean
- rm -f configure-stamp
diff --git a/net/morebalance/pkg-descr b/net/morebalance/pkg-descr
index 0133a85808d0..7d587e3da4d8 100644
--- a/net/morebalance/pkg-descr
+++ b/net/morebalance/pkg-descr
@@ -1,4 +1,4 @@
MoreBalance is a modular open source user-space load balancing system.
It also serves as a general fun networking tool.
-WWW: http://mindx.dyndns.org/morebalance/
+WWW: http://morebalance.coolprojects.org/
diff --git a/net/morebalance/pkg-plist b/net/morebalance/pkg-plist
index 3534fe8203a7..0fdfa8ab12ef 100644
--- a/net/morebalance/pkg-plist
+++ b/net/morebalance/pkg-plist
@@ -1,2 +1,3 @@
sbin/morebalance
etc/morebalance.conf.sample
+share/locale/de/LC_MESSAGES/morebalance.mo