aboutsummaryrefslogtreecommitdiff
path: root/net/mpich2/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2005-05-26 01:44:10 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2005-05-26 01:44:10 +0000
commit53187cf14286c4ace15ba65a49e9937aa2a607b7 (patch)
tree3ad54796b6a6c5e42abd04314a88c7e375079aaa /net/mpich2/Makefile
parent892bccab4df65f9b7f0aa42819f103e706409902 (diff)
downloadports-53187cf14286c4ace15ba65a49e9937aa2a607b7.tar.gz
ports-53187cf14286c4ace15ba65a49e9937aa2a607b7.zip
Convert to OPTIONS.
Approved by: maintainer
Notes
Notes: svn path=/head/; revision=136140
Diffstat (limited to 'net/mpich2/Makefile')
-rw-r--r--net/mpich2/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/net/mpich2/Makefile b/net/mpich2/Makefile
index 18ccfa50fe41..722a8e819daa 100644
--- a/net/mpich2/Makefile
+++ b/net/mpich2/Makefile
@@ -20,6 +20,13 @@ COMMENT= Message Passing Interface (MPI) Library
CONFIGURE_ARGS= -prefix=${PREFIX}/mpich
+OPTIONS= X11 "Enable MPE graphics" on \
+ TK "Build with TK support" on \
+ JAVA "Build with Java support" off \
+ SSH "Enable SSH client support" on
+
+.include <bsd.port.pre.mk>
+
.if defined(WITHOUT_X11)
WITHOUT_TK= yes
CONFIGURE_ARGS+=--disable-mpe_graphics
@@ -177,9 +184,6 @@ MAN4= CLOG_Init.4 CLOG_commtype.4 CLOG_cput.4 CLOG_csync.4 \
MPE_Describe_event.4 MPE_Get_mouse_press.4 MPE_Make_color_array.4 \
MPE_Print_datatype_unpack_action.4
-.include <bsd.port.pre.mk>
-
-# To disable ssh client support, build with WITHOUT_SSH set.
# Use ssh instead of rsh
.if !defined(WITHOUT_SSH)
.if ${OSVERSION} >= 400016 && exists(/usr/bin/ssh)