aboutsummaryrefslogtreecommitdiff
path: root/net/mpich2/Makefile
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2007-12-11 21:09:42 +0000
committerThierry Thomas <thierry@FreeBSD.org>2007-12-11 21:09:42 +0000
commitc31aab128da0f637de1fa45c16690c2842593002 (patch)
tree498a7f6461456499a5970a550494693d14423920 /net/mpich2/Makefile
parenta9994c58fbc6ecae4f10f94901eba0d418924d27 (diff)
downloadports-c31aab128da0f637de1fa45c16690c2842593002.tar.gz
ports-c31aab128da0f637de1fa45c16690c2842593002.zip
- Upgrade to 1.0.6p1;
Changelog at <http://www-unix.mcs.anl.gov/mpi/mpich/106p1.txt> - Fix pkgconfig.
Notes
Notes: svn path=/head/; revision=203026
Diffstat (limited to 'net/mpich2/Makefile')
-rw-r--r--net/mpich2/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/net/mpich2/Makefile b/net/mpich2/Makefile
index 42bc5db4f3f4..be8c811ffa98 100644
--- a/net/mpich2/Makefile
+++ b/net/mpich2/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= mpich2
-PORTVERSION= 1.0.6
-PORTEPOCH= 2
+DISTVERSION= 1.0.6p1
+PORTEPOCH= 3
CATEGORIES= net parallel
MASTER_SITES= ftp://ftp.mcs.anl.gov/pub/mpi/ \
http://www-unix.mcs.anl.gov/mpi/mpich/downloads/
@@ -30,6 +30,7 @@ COMMENT= A portable implementation of MPI-1 and MPI-2
USE_PYTHON= yes
USE_PERL5_BUILD=yes
+USE_GNOME= pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
@@ -137,6 +138,10 @@ pre-configure:
${WRKSRC}/src/mpe2/man/man4/${mp}
.endfor
+post-configure:
+ ${REINPLACE_CMD} -e 's|$${exec_prefix}|${PREFIX}|g; \
+ s|$${prefix}|${PREFIX}|g' ${WRKSRC}/src/pkgconfig/mpich2-ch3.pc
+
post-install:
${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PREFIX}
${CHOWN} -R ${BINOWN}:${BINGRP} ${PREFIX}/bin