aboutsummaryrefslogtreecommitdiff
path: root/net/mpich2
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2006-12-10 23:22:57 +0000
committerThierry Thomas <thierry@FreeBSD.org>2006-12-10 23:22:57 +0000
commit98f015721365f77c1c78d209329bb8c137a3bbb9 (patch)
tree05c45d0b95a5729b14f2c0e30b824b15dc0ba3fe /net/mpich2
parent2cc744a2245ff0125e0972dc0e1599dfe7e31bf4 (diff)
downloadports-98f015721365f77c1c78d209329bb8c137a3bbb9.tar.gz
ports-98f015721365f77c1c78d209329bb8c137a3bbb9.zip
Re-enable the Fortran 90 module: fixed with gcc-withfortran-4.1.2_20061208.
Notes
Notes: svn path=/head/; revision=179437
Diffstat (limited to 'net/mpich2')
-rw-r--r--net/mpich2/Makefile17
1 files changed, 8 insertions, 9 deletions
diff --git a/net/mpich2/Makefile b/net/mpich2/Makefile
index bf19ac9b9474..238eff1a1d06 100644
--- a/net/mpich2/Makefile
+++ b/net/mpich2/Makefile
@@ -64,17 +64,16 @@ RUN_DEPENDS+= javavm:${PORTSDIR}/java/javavmwrapper
PLIST_SUB+= JAVA=""
.endif
-#.if defined(WITHOUT_F90)
+.if defined(WITHOUT_F90)
CONFIGURE_ARGS+= --disable-f90
PLIST_SUB+= F90="@comment "
-#.else
-# Disabled ATM
-#F90= gfortran41
-#BUILD_DEPENDS+= ${F90}:${PORTSDIR}/lang/gfortran
-#F90FLAGS+= -ff2c
-#CONFIGURE_ENV+= F90=${F90} F90FLAGS=${F90FLAGS}
-#PLIST_SUB+= F90=""
-#.endif
+.else
+F90= gfortran41
+BUILD_DEPENDS+= ${F90}:${PORTSDIR}/lang/gfortran
+F90FLAGS+= -ff2c
+CONFIGURE_ENV+= F90=${F90} F90FLAGS=${F90FLAGS}
+PLIST_SUB+= F90=""
+.endif
.if defined(WITH_SMPD)
CONFIGURE_ARGS+= --with-pmi=smpd --with-pm=smpd