aboutsummaryrefslogtreecommitdiff
path: root/net/mpich2
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2009-11-28 10:44:43 +0000
committerThierry Thomas <thierry@FreeBSD.org>2009-11-28 10:44:43 +0000
commita9969884fb77e493740fae5649c192f9c5a9ab15 (patch)
tree353bf7afe9b7b7d79fb8c7b7b5c8dd4f7f9b65f6 /net/mpich2
parent289c33108801f310f804e01542e50c3d8d3bd649 (diff)
downloadports-a9969884fb77e493740fae5649c192f9c5a9ab15.tar.gz
ports-a9969884fb77e493740fae5649c192f9c5a9ab15.zip
- Upgrade to 1.2.1
Changelog at <https://svn.mcs.anl.gov/repos/mpi/mpich2/tags/release/mpich2-1.2.1/CHANGES> - Don't set PREFIX anymore to $PREFIX/mpich2.
Notes
Notes: svn path=/head/; revision=244903
Diffstat (limited to 'net/mpich2')
-rw-r--r--net/mpich2/Makefile47
-rw-r--r--net/mpich2/distinfo6
-rw-r--r--net/mpich2/files/manpages24
-rw-r--r--net/mpich2/files/patch-Makefile.in16
-rw-r--r--net/mpich2/files/patch-configure6
-rw-r--r--net/mpich2/files/patch-src_mpe2_src_slog2sdk_trace_rlog_configure10
-rw-r--r--net/mpich2/files/patch-src_mpe2_src_slog2sdk_trace_sample_configure10
-rw-r--r--net/mpich2/files/patch-src_mpi_romio_adio_ad_hfs_ad_hfs_fcntl.c14
-rw-r--r--net/mpich2/files/pkg-message.in4
-rw-r--r--net/mpich2/pkg-plist48
10 files changed, 98 insertions, 87 deletions
diff --git a/net/mpich2/Makefile b/net/mpich2/Makefile
index 3691d070864b..c4e1b2d3409c 100644
--- a/net/mpich2/Makefile
+++ b/net/mpich2/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME= mpich2
-DISTVERSION= 1.1.1p1
-PORTREVISION= 1
+PORTVERSION= 1.2.1
PORTEPOCH= 4
CATEGORIES= net parallel
-MASTER_SITES= http://www.mcs.anl.gov/research/projects/mpich2/downloads/tarballs/${DISTVERSION}/
+MASTER_SITES= http://www.mcs.anl.gov/research/projects/mpich2/downloads/tarballs/${PORTVERSION}/
DIST_SUBDIR= mpich
#PATCH_SITES= ftp://ftp.mcs.anl.gov/pub/mpi/mpich2-patch/
#PATCHFILES=
@@ -27,8 +26,15 @@ LIB_DEPENDS= execinfo.1:${PORTSDIR}/devel/libexecinfo
# - WITHOUT_JAVA don't build MPE Jumpshot-4
# - WITHOUT_X11 disable MPE graphics routines
# - WITH_SMPD use SMPD instead of MPD for OS-mixed cluster
+# - WITH_RECV_TIMEOUT set a non-default MPIEXEC_RECV_TIMEOUT
#-----------------------------------------------------------------------
+.if defined(MAINTAINER_MODE)
+WITH_RECV_TIMEOUT?= 100
+.else
+WITH_RECV_TIMEOUT?= 20
+.endif
+
USE_PYTHON= yes
USE_PERL5_BUILD=yes
USE_GNOME= pkgconfig
@@ -47,15 +53,18 @@ MAKE_ENV+= VERBOSE=1
.endif
MAKE_JOBS_UNSAFE= yes
+CONFLICTS= lam-7.* mpiexec-0.*
+
USE_FORTRAN= yes
F90FLAGS+= ${FFLAGS}
CONFIGURE_ENV+= F90="${FC}" F90FLAGS="${F90FLAGS}"
-NO_MTREE= yes
USE_LDCONFIG= yes
SUB_FILES= pkg-message
+VERSO= 1.2
+PLIST_SUB= VER=${VERSO}
.if defined(WITHOUT_X11)
CONFIGURE_ARGS+= --disable-graphics
WITHOUT_JAVA= yes
@@ -86,7 +95,7 @@ CONFIGURE_ARGS+= --with-pmi=simple --with-pm=mpd
PLIST_SUB+= PM_MPD="" PM_SMPD="@comment "
.endif
-LIBSSO= fmpich mpich mpichcxx
+LIBSSO= fmpich mpich mpichcxx mpichf90
THREAD2FIX= configure test/mpi/threads/comm/Makefile.in \
test/mpi/threads/pt2pt/Makefile.in \
@@ -98,6 +107,9 @@ LOCALBASE2FIX= src/mpe2/src/slog2sdk/trace_rlog/configure \
src/mpe2/src/graphics/configure
DOC2PATCH= Makefile.in src/mpe2/sbin/mpeinstall.in \
src/openpa/Makefile.in src/mpi/romio/util/romioinstall.in
+CONFPFX2FIX1= man/man1/mpd.1 src/pm/mpd/mpd.py
+CONFPFX2FIX2= README doc/installguide/install.tex.vin \
+ src/pm/mpd/mpdlib.py src/pm/mpd/mpdroot.c
.include <bsd.port.pre.mk>
@@ -122,8 +134,6 @@ BROKEN= Requested timer clock_gettime (POSIX) is not available for ${OSREL}
.include "${FILESDIR}/manpages"
.endif
-PREFIX:= ${PREFIX}/${PORTNAME}
-
pre-everything::
@${ECHO_MSG}
@${ECHO_MSG} "You could define the following options:"
@@ -136,6 +146,7 @@ pre-everything::
.if !defined(WITH_SMPD)
@${ECHO_MSG} "- WITH_SMPD use SMPD instead of MPD, to work with SMPD under MS Windows"
.endif
+ @${ECHO_MSG} "- WITH_RECV_TIMEOUT set it to a value > 20 on slow machines"
@${ECHO_MSG}
pre-configure:
@@ -154,6 +165,16 @@ pre-configure:
${REINPLACE_CMD} -e 's|lib doc share|lib share|' \
${WRKSRC}/src/mpe2/src/slog2sdk/sbin/install-package.in
.endif
+ ${REINPLACE_CMD} -e '/MPIEXEC_RECV_TIMEOUT/s|20,|${WITH_RECV_TIMEOUT},|' \
+ ${WRKSRC}/src/pm/mpd/mpiexec.py
+ ${REINPLACE_CMD} -e 's|%%SRCDIR%%|${WRKSRC}|' ${WRKSRC}/${CONFIGURE_SCRIPT}
+.for cnf in ${CONFPFX2FIX1}
+ ${REINPLACE_CMD} -e 's|/etc|${PREFIX}/etc|' ${WRKSRC}/${cnf}
+.endfor
+.for cnf in ${CONFPFX2FIX2}
+ ${REINPLACE_CMD} -e 's|/etc/mpd.conf|${PREFIX}/etc/mpd.conf|' \
+ ${WRKSRC}/${cnf}
+.endfor
post-configure:
${REINPLACE_CMD} -e 's|$${exec_prefix}|${PREFIX}|g; \
@@ -161,15 +182,19 @@ post-configure:
${WRKSRC}/src/packaging/pkgconfig/mpich2-ch3.pc
post-install:
- ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PREFIX}
- ${CHOWN} -R ${BINOWN}:${BINGRP} ${PREFIX}/bin
.for lib in ${LIBSSO}
- ${MV} ${PREFIX}/lib/lib${lib}.so.1.1 ${PREFIX}/lib/lib${lib}.so.1
+ ${MV} ${PREFIX}/lib/lib${lib}.so.1.2 ${PREFIX}/lib/lib${lib}.so.1
${LN} -sf ${PREFIX}/lib/lib${lib}.so.1 ${PREFIX}/lib/lib${lib}.so
- ${LN} -sf ${PREFIX}/lib/lib${lib}.so.1 ${PREFIX}/lib/lib${lib}.so.1.1
+ ${LN} -sf ${PREFIX}/lib/lib${lib}.so.1 ${PREFIX}/lib/lib${lib}.so.1.2
.endfor
@${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${PREFIX}/bin
@${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py ${PREFIX}/bin
+ @${ECHO_CMD} "MPD_SECRETWORD=change_on_install" > ${WRKDIR}/mpd.conf.dist
+ ${INSTALL_DATA} ${WRKDIR}/mpd.conf.dist ${PREFIX}/etc/
+ if [ ! -e ${PREFIX}/etc/mpd.conf ]; then \
+ ${INSTALL_DATA} ${WRKDIR}/mpd.conf.dist ${PREFIX}/etc/mpd.conf ; \
+ fi
+ ${CHMOD} 600 ${PREFIX}/etc/mpd.conf ${PREFIX}/etc/mpd.conf.dist
@${CAT} ${PKGMESSAGE}
.if defined(MAINTAINER_MODE)
diff --git a/net/mpich2/distinfo b/net/mpich2/distinfo
index 60c3e7d957e6..82e63471c38c 100644
--- a/net/mpich2/distinfo
+++ b/net/mpich2/distinfo
@@ -1,3 +1,3 @@
-MD5 (mpich/mpich2-1.1.1p1.tar.gz) = cb3da718237f2af826fcd85a4ab72047
-SHA256 (mpich/mpich2-1.1.1p1.tar.gz) = 10badc5afe55998f7be90f569447ce1b56c42ed0248c3a925090ad1e6a5d800f
-SIZE (mpich/mpich2-1.1.1p1.tar.gz) = 18343542
+MD5 (mpich/mpich2-1.2.1.tar.gz) = 0956a85fc7de2305eeb7cdd12742d9e9
+SHA256 (mpich/mpich2-1.2.1.tar.gz) = 394736543f021ac0ea73f3f40a58ca0320b7223487eb13991f0312aa9e8721c1
+SIZE (mpich/mpich2-1.2.1.tar.gz) = 18284454
diff --git a/net/mpich2/files/manpages b/net/mpich2/files/manpages
index 2cb7f8a28ac0..31dc6715569b 100644
--- a/net/mpich2/files/manpages
+++ b/net/mpich2/files/manpages
@@ -1,5 +1,22 @@
MAN1= \
MPI.1 \
+Zeroconf.1 \
+mpd.1 \
+mpdallexit.1 \
+mpdboot.1 \
+mpdcheck.1 \
+mpdchkpyver.1 \
+mpdcleanup.1 \
+mpdexit.1 \
+mpdgdbdrv.1 \
+mpdhelp.1 \
+mpdkilljob.1 \
+mpdlib.1 \
+mpdlistjobs.1 \
+mpdman.1 \
+mpdringtest.1 \
+mpdsigjob.1 \
+mpdtrace.1 \
mpicc.1 \
mpicxx.1 \
mpiexec.1 \
@@ -69,6 +86,10 @@ MPI_Comm_spawn_multiple.3 \
MPI_Comm_split.3 \
MPI_Comm_test_inter.3 \
MPI_Dims_create.3 \
+MPI_Dist_graph_create.3 \
+MPI_Dist_graph_create_adjacent.3 \
+MPI_Dist_graph_neighbors.3 \
+MPI_Dist_graph_neighbors_count.3 \
MPI_Errhandler_create.3 \
MPI_Errhandler_free.3 \
MPI_Errhandler_get.3 \
@@ -188,6 +209,7 @@ MPI_Issend.3 \
MPI_Keyval_create.3 \
MPI_Keyval_free.3 \
MPI_Lookup_name.3 \
+MPI_Op_commute.3 \
MPI_Op_create.3 \
MPI_Op_free.3 \
MPI_Open_port.3 \
@@ -203,7 +225,9 @@ MPI_Query_thread.3 \
MPI_Recv.3 \
MPI_Recv_init.3 \
MPI_Reduce.3 \
+MPI_Reduce_local.3 \
MPI_Reduce_scatter.3 \
+MPI_Reduce_scatter_block.3 \
MPI_Register_datarep.3 \
MPI_Request_free.3 \
MPI_Request_get_status.3 \
diff --git a/net/mpich2/files/patch-Makefile.in b/net/mpich2/files/patch-Makefile.in
index 40345dabeebc..2ddf3c33ed07 100644
--- a/net/mpich2/files/patch-Makefile.in
+++ b/net/mpich2/files/patch-Makefile.in
@@ -1,6 +1,6 @@
---- Makefile.in.orig 2009-06-03 03:49:03.000000000 +0200
-+++ Makefile.in 2009-06-27 12:20:51.000000000 +0200
-@@ -192,61 +192,61 @@
+--- Makefile.in.orig 2009-10-07 19:18:28.000000000 +0200
++++ Makefile.in 2009-10-09 21:41:59.000000000 +0200
+@@ -195,61 +195,61 @@
install: install-preamble FORCE_TARGET
if [ ! -d ${DESTDIR}${prefix} ] ; then $(MKDIR_P) ${DESTDIR}${prefix} ; fi
if [ ! -d ${DESTDIR}${datarootdir} ] ; then $(MKDIR_P) ${DESTDIR}${datarootdir} ; fi
@@ -111,10 +111,10 @@
if [ -s src/mpi/romio/include/mpiof.h ] ; then $(INSTALL_DATA) src/mpi/romio/include/mpiof.h ${DESTDIR}${includedir}/mpiof.h ; fi
if [ -s src/mpi/romio/include/mpio.h ] ; then $(INSTALL_DATA) src/mpi/romio/include/mpio.h ${DESTDIR}${includedir}/mpio.h ; fi
if [ -s lib/lib${MPIFLIBNAME}.a ] ; then $(INSTALL_DATA) lib/lib${MPIFLIBNAME}.a ${DESTDIR}${libdir}/lib${MPIFLIBNAME}.a ; fi
-@@ -260,10 +260,10 @@
- if [ -s lib/libf${MPILIBNAME}.@SHLIB_EXT@ ] ; then $(CREATESHLIB) --mode=install lib/libf${MPILIBNAME}.@SHLIB_EXT@ ${DESTDIR}${libdir}/libf${MPILIBNAME}.@SHLIB_EXT@ ; fi
- if [ -s lib/lib${MPILIBNAME}f90.@SHLIB_EXT@ ] ; then $(CREATESHLIB) --mode=install lib/lib${MPILIBNAME}f90.@SHLIB_EXT@ ${DESTDIR}${libdir}/lib${MPILIBNAME}f90.@SHLIB_EXT@ ; fi
- if [ -s lib/lib${MPICXXLIBNAME}.@SHLIB_EXT@ ] ; then $(CREATESHLIB) --mode=install lib/lib${MPICXXLIBNAME}.@SHLIB_EXT@ ${DESTDIR}${libdir}/lib${MPICXXLIBNAME}.@SHLIB_EXT@ ; fi
+@@ -263,10 +263,10 @@
+ if [ -s lib/libf${MPILIBNAME}.@SHLIB_EXT@ ] ; then $(CREATESHLIB) -version-info $(ABIVERSION) --mode=install lib/libf${MPILIBNAME}.@SHLIB_EXT@ ${DESTDIR}${libdir}/libf${MPILIBNAME}.@SHLIB_EXT@ ; fi
+ if [ -s lib/lib${MPILIBNAME}f90.@SHLIB_EXT@ ] ; then $(CREATESHLIB) -version-info $(ABIVERSION) --mode=install lib/lib${MPILIBNAME}f90.@SHLIB_EXT@ ${DESTDIR}${libdir}/lib${MPILIBNAME}f90.@SHLIB_EXT@ ; fi
+ if [ -s lib/lib${MPICXXLIBNAME}.@SHLIB_EXT@ ] ; then $(CREATESHLIB) -version-info $(ABIVERSION) --mode=install lib/lib${MPICXXLIBNAME}.@SHLIB_EXT@ ${DESTDIR}${libdir}/lib${MPICXXLIBNAME}.@SHLIB_EXT@ ; fi
- if [ -s $(srcdir)/doc/userguide/user.pdf ] ; then $(INSTALL_DATA) $(srcdir)/doc/userguide/user.pdf ${DESTDIR}${docdir}/user.pdf ; fi
- if [ -s $(srcdir)/doc/installguide/install.pdf ] ; then $(INSTALL_DATA) $(srcdir)/doc/installguide/install.pdf ${DESTDIR}${docdir}/install.pdf ; fi
- if [ -s $(srcdir)/doc/smpd/smpd_pmi.pdf ] ; then $(INSTALL_DATA) $(srcdir)/doc/smpd/smpd_pmi.pdf ${DESTDIR}${docdir}/smpd_pmi.pdf ; fi
@@ -123,6 +123,6 @@
+%%PORTDOCS%% if [ -s $(srcdir)/doc/installguide/install.pdf ] ; then $(INSTALL_DATA) $(srcdir)/doc/installguide/install.pdf ${DESTDIR}${docdir}/install.pdf ; fi
+%%PORTDOCS%% if [ -s $(srcdir)/doc/smpd/smpd_pmi.pdf ] ; then $(INSTALL_DATA) $(srcdir)/doc/smpd/smpd_pmi.pdf ${DESTDIR}${docdir}/smpd_pmi.pdf ; fi
+%%PORTDOCS%% if [ -s $(srcdir)/doc/logging/logging.pdf ] ; then $(INSTALL_DATA) $(srcdir)/doc/logging/logging.pdf ${DESTDIR}${docdir}/logging.pdf ; fi
- (cd src/util/thread && $(MAKE) INSTALL_STRIP_FLAG=$(INSTALL_STRIP_FLAG) install)
(cd src/env && $(MAKE) INSTALL_STRIP_FLAG=$(INSTALL_STRIP_FLAG) install)
(cd src/packaging/pkgconfig && $(MAKE) INSTALL_STRIP_FLAG=$(INSTALL_STRIP_FLAG) install)
+ (cd src/packaging/envmods && $(MAKE) INSTALL_STRIP_FLAG=$(INSTALL_STRIP_FLAG) install)
diff --git a/net/mpich2/files/patch-configure b/net/mpich2/files/patch-configure
index 76d7c75b8379..cb0d5563019e 100644
--- a/net/mpich2/files/patch-configure
+++ b/net/mpich2/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2009-07-21 23:48:05.000000000 +0200
-+++ configure 2009-07-22 18:53:59.000000000 +0200
-@@ -36096,12 +36096,12 @@
+--- configure.orig 2009-11-18 17:40:48.000000000 +0100
++++ configure 2009-11-24 21:26:56.000000000 +0100
+@@ -40383,12 +40383,12 @@
return 0;
}
_ACEOF
diff --git a/net/mpich2/files/patch-src_mpe2_src_slog2sdk_trace_rlog_configure b/net/mpich2/files/patch-src_mpe2_src_slog2sdk_trace_rlog_configure
deleted file mode 100644
index 6f6b47cc68ba..000000000000
--- a/net/mpich2/files/patch-src_mpe2_src_slog2sdk_trace_rlog_configure
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/mpe2/src/slog2sdk/trace_rlog/configure.orig Wed Nov 23 19:43:07 2005
-+++ src/mpe2/src/slog2sdk/trace_rlog/configure Mon Jul 17 20:22:48 2006
-@@ -22562,6 +22562,7 @@
- /usr/java/j2sdk* \
- /usr/local \
- /usr/local/java* \
-+ /usr/local/diablo-jdk* \
- /usr/local/jdk* \
- /usr/local/j2sdk* \
- /usr/share \
diff --git a/net/mpich2/files/patch-src_mpe2_src_slog2sdk_trace_sample_configure b/net/mpich2/files/patch-src_mpe2_src_slog2sdk_trace_sample_configure
deleted file mode 100644
index 6938d3a66f74..000000000000
--- a/net/mpich2/files/patch-src_mpe2_src_slog2sdk_trace_sample_configure
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/mpe2/src/slog2sdk/trace_sample/configure.orig Wed Nov 23 19:43:12 2005
-+++ src/mpe2/src/slog2sdk/trace_sample/configure Mon Jul 17 20:32:00 2006
-@@ -22561,6 +22561,7 @@
- /usr/local \
- /usr/local/java* \
- /usr/local/jdk* \
-+ /usr/local/diablo-jdk* \
- /usr/local/j2sdk* \
- /usr/share \
- /usr/share/java* \
diff --git a/net/mpich2/files/patch-src_mpi_romio_adio_ad_hfs_ad_hfs_fcntl.c b/net/mpich2/files/patch-src_mpi_romio_adio_ad_hfs_ad_hfs_fcntl.c
deleted file mode 100644
index 8b96154eaff5..000000000000
--- a/net/mpich2/files/patch-src_mpi_romio_adio_ad_hfs_ad_hfs_fcntl.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- ./src/mpi/romio/adio/ad_hfs/ad_hfs_fcntl.c.orig 2007-11-02 23:50:19.000000000 +0100
-+++ ./src/mpi/romio/adio/ad_hfs/ad_hfs_fcntl.c 2008-04-07 23:19:28.000000000 +0200
-@@ -20,7 +20,11 @@
-
- switch(flag) {
- case ADIO_FCNTL_GET_FSIZE:
-+#ifdef __FreeBSD__
-+ fcntl_struct->fsize = lseek(fd->fd_sys, 0, SEEK_END);
-+#else
- fcntl_struct->fsize = lseek64(fd->fd_sys, 0, SEEK_END);
-+#endif
- #ifdef HPUX
- if (fd->fp_sys_posn != -1)
- lseek64(fd->fd_sys, fd->fp_sys_posn, SEEK_SET);
diff --git a/net/mpich2/files/pkg-message.in b/net/mpich2/files/pkg-message.in
index fc10902e5382..2ae48f0fcf3d 100644
--- a/net/mpich2/files/pkg-message.in
+++ b/net/mpich2/files/pkg-message.in
@@ -2,6 +2,8 @@
MPICH-2 has been installed under %%PREFIX%%.
-Please include %%PREFIX%%/bin in your $PATH.
+ /!\ IMPORTANT /!\
+
+Please change the password in %%PREFIX%%/etc/mpd.conf
=======================================================================
diff --git a/net/mpich2/pkg-plist b/net/mpich2/pkg-plist
index 165a5f8bcc56..3b718377d84d 100644
--- a/net/mpich2/pkg-plist
+++ b/net/mpich2/pkg-plist
@@ -1,4 +1,3 @@
-@comment "PREFIX set to %D/mpich2."
bin/check_callstack
@comment SLOG-2 tools are not installed if NOPORTDOCS is set
%%JAVA%%bin/clog2TOslog2
@@ -75,8 +74,6 @@ bin/clog2_repair
%%PM_MPD%%bin/mpdtrace.py
%%PM_MPD%%bin/mpdtrace.pyc
%%PM_MPD%%bin/mpdtrace.pyo
-bin/mpecc.in
-bin/mpefc.in
bin/mpic++
bin/mpicc
bin/mpich2version
@@ -100,8 +97,10 @@ bin/parkill
%%JAVA%%bin/slog2navigator
%%JAVA%%bin/slog2print
%%JAVA%%bin/slog2updater
-%%JAVA%%bin/traceTOslog2.in
-%%JAVA%%bin/traceprint.in
+bin/smtpd.pyc
+bin/smtpd.pyo
+bin/smtpd2.6.pyc
+bin/smtpd2.6.pyo
etc/mpe_callstack_ldflags.conf
etc/mpe_f77env.conf
etc/mpe_graphics.conf
@@ -130,7 +129,6 @@ include/mpe_log.h
include/mpe_log_thread.h
include/mpe_logf.h
include/mpe_misc.h
-include/mpe_thread.h
include/mpi.h
include/mpi.mod
include/mpi_base.mod
@@ -157,6 +155,7 @@ include/primitives/opa_gcc_ppc.h
include/primitives/opa_gcc_sicortex.h
include/primitives/opa_nt_intrinsics.h
include/primitives/opa_sun_atomic_ops.h
+include/primitives/opa_unsafe.h
%%JAVA%%lib/clog2TOdrawable.jar
%%JAVA%%lib/clog2TOslog2.jar
%%JAVA%%lib/clog2print.jar
@@ -169,7 +168,7 @@ include/primitives/opa_sun_atomic_ops.h
lib/libfmpich.a
lib/libfmpich.so
lib/libfmpich.so.1
-lib/libfmpich.so.1.1
+lib/libfmpich.so.%%VER%%
lib/liblmpe.a
lib/libmpe.a
lib/libmpe_collchk.a
@@ -180,15 +179,15 @@ lib/libmpe_null.a
lib/libmpich.a
lib/libmpich.so
lib/libmpich.so.1
-lib/libmpich.so.1.1
+lib/libmpich.so.%%VER%%
lib/libmpichcxx.a
lib/libmpichcxx.so
lib/libmpichcxx.so.1
-lib/libmpichcxx.so.1.1
+lib/libmpichcxx.so.%%VER%%
lib/libmpichf90.a
lib/libmpichf90.so
lib/libmpichf90.so.1
-lib/libmpichf90.so.1.1
+lib/libmpichf90.so.%%VER%%
lib/libopa.a
lib/libtmpe.a
%%JAVA%%lib/logconvertor.jar
@@ -207,6 +206,7 @@ sbin/mpetestexec
sbin/mpetestexeclog
sbin/mpetestlink
sbin/mpeuninstall
+%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/index.htm
%%PORTDOCS%%%%DOCSDIR%%/install.pdf
%%PORTDOCS%%%%JAVA%%%%DOCSDIR%%/jumpshot-4/html/About24.png
@@ -353,11 +353,10 @@ sbin/mpeuninstall
%%PORTDOCS%%%%JAVA%%%%DOCSDIR%%/jumpshot-4/html/up_g.png
%%PORTDOCS%%%%JAVA%%%%DOCSDIR%%/jumpshot-4/html/usersguide.css
%%PORTDOCS%%%%JAVA%%%%DOCSDIR%%/jumpshot-4/html/usersguide.html
-%%PORTDOCS%%%%JAVA%%%%DOCSDIR%%/jumpshot-4/usersguide.pdf
%%PORTDOCS%%%%JAVA%%%%DOCSDIR%%/jumpshot-4/html/yaxis_label_panel_expanded.png
%%PORTDOCS%%%%JAVA%%%%DOCSDIR%%/jumpshot-4/html/yaxis_label_panel_simple.png
+%%PORTDOCS%%%%JAVA%%%%DOCSDIR%%/jumpshot-4/usersguide.pdf
%%PORTDOCS%%%%DOCSDIR%%/logging.pdf
-%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/smpd_pmi.pdf
%%PORTDOCS%%%%DOCSDIR%%/user.pdf
%%PORTDOCS%%%%DOCSDIR%%/www1/MPI.html
@@ -429,6 +428,10 @@ sbin/mpeuninstall
%%PORTDOCS%%%%DOCSDIR%%/www3/MPI_Comm_split.html
%%PORTDOCS%%%%DOCSDIR%%/www3/MPI_Comm_test_inter.html
%%PORTDOCS%%%%DOCSDIR%%/www3/MPI_Dims_create.html
+%%PORTDOCS%%%%DOCSDIR%%/www3/MPI_Dist_graph_create.html
+%%PORTDOCS%%%%DOCSDIR%%/www3/MPI_Dist_graph_create_adjacent.html
+%%PORTDOCS%%%%DOCSDIR%%/www3/MPI_Dist_graph_neighbors.html
+%%PORTDOCS%%%%DOCSDIR%%/www3/MPI_Dist_graph_neighbors_count.html
%%PORTDOCS%%%%DOCSDIR%%/www3/MPI_Errhandler_create.html
%%PORTDOCS%%%%DOCSDIR%%/www3/MPI_Errhandler_free.html
%%PORTDOCS%%%%DOCSDIR%%/www3/MPI_Errhandler_get.html
@@ -548,6 +551,7 @@ sbin/mpeuninstall
%%PORTDOCS%%%%DOCSDIR%%/www3/MPI_Keyval_create.html
%%PORTDOCS%%%%DOCSDIR%%/www3/MPI_Keyval_free.html
%%PORTDOCS%%%%DOCSDIR%%/www3/MPI_Lookup_name.html
+%%PORTDOCS%%%%DOCSDIR%%/www3/MPI_Op_commute.html
%%PORTDOCS%%%%DOCSDIR%%/www3/MPI_Op_create.html
%%PORTDOCS%%%%DOCSDIR%%/www3/MPI_Op_free.html
%%PORTDOCS%%%%DOCSDIR%%/www3/MPI_Open_port.html
@@ -563,7 +567,9 @@ sbin/mpeuninstall
%%PORTDOCS%%%%DOCSDIR%%/www3/MPI_Recv.html
%%PORTDOCS%%%%DOCSDIR%%/www3/MPI_Recv_init.html
%%PORTDOCS%%%%DOCSDIR%%/www3/MPI_Reduce.html
+%%PORTDOCS%%%%DOCSDIR%%/www3/MPI_Reduce_local.html
%%PORTDOCS%%%%DOCSDIR%%/www3/MPI_Reduce_scatter.html
+%%PORTDOCS%%%%DOCSDIR%%/www3/MPI_Reduce_scatter_block.html
%%PORTDOCS%%%%DOCSDIR%%/www3/MPI_Register_datarep.html
%%PORTDOCS%%%%DOCSDIR%%/www3/MPI_Request_free.html
%%PORTDOCS%%%%DOCSDIR%%/www3/MPI_Request_get_status.html
@@ -708,7 +714,6 @@ sbin/mpeuninstall
%%PORTDOCS%%%%DOCSDIR%%/www4/MPE_Update.html
%%PORTDOCS%%%%DOCSDIR%%/www4/libmpe.cit
%%DATADIR%%/examples_collchk/Makefile
-%%DATADIR%%/examples_collchk/Makefile.in
%%DATADIR%%/examples_collchk/composite.c
%%DATADIR%%/examples_collchk/scatterv.c
%%DATADIR%%/examples_collchk/time_allreduce.c
@@ -721,12 +726,10 @@ sbin/mpeuninstall
%%DATADIR%%/examples_collchk/wrong_root.c
%%DATADIR%%/examples_collchk/wrong_scatterv.c
%%X11%%%%DATADIR%%/examples_graphics/Makefile
-%%X11%%%%DATADIR%%/examples_graphics/Makefile.in
%%X11%%%%DATADIR%%/examples_graphics/cpi.c
%%X11%%%%DATADIR%%/examples_graphics/cxgraphics.c
%%X11%%%%DATADIR%%/examples_graphics/fxgraphics.f
%%DATADIR%%/examples_logging/Makefile
-%%DATADIR%%/examples_logging/Makefile.in
%%DATADIR%%/examples_logging/comm1_isr.c
%%DATADIR%%/examples_logging/comm1_isr_loop.c
%%DATADIR%%/examples_logging/comm2_connect_accept.c
@@ -749,6 +752,9 @@ sbin/mpeuninstall
%%JAVA%%%%DATADIR%%/logfiles/barrier.rlog
%%JAVA%%%%DATADIR%%/logfiles/fpilog.clog
%%JAVA%%%%DATADIR%%/logfiles/fpilog.slog2
+@unexec if diff -q %D/etc/mpd.conf %D/etc/mpd.conf.dist; then rm %D/etc/mpd.conf; fi
+etc/mpd.conf.dist
+@exec if [ ! -f %B/mpd.conf ]; then cp %B/mpd.conf.dist %B/mpd.conf; fi
%%JAVA%%@dirrm %%DATADIR%%/logfiles
@dirrm %%DATADIR%%/examples_logging
%%X11%%@dirrm %%DATADIR%%/examples_graphics
@@ -760,19 +766,7 @@ sbin/mpeuninstall
%%JAVA%%%%PORTDOCS%%@dirrm %%DOCSDIR%%/jumpshot-4/html
%%JAVA%%%%PORTDOCS%%@dirrm %%DOCSDIR%%/jumpshot-4
%%PORTDOCS%%@dirrm %%DOCSDIR%%
-%%PORTDOCS%%@dirrm share/doc
-@dirrm share
-@dirrm sbin
-%%PORTDOCS%%@dirrm man/man4
-%%PORTDOCS%%@dirrm man/man3
-%%PORTDOCS%%@dirrm man/man1
-%%PORTDOCS%%@dirrm man
%%JAVA%%@dirrm lib/trace_rlog
-@dirrm lib
@dirrm include/primitives
-@dirrm include
-@dirrm etc
-@dirrm bin
-@unexec rmdir %D 2>/dev/null || true
@cwd %%LOCALBASE%%
libdata/pkgconfig/mpich2-ch3.pc