aboutsummaryrefslogtreecommitdiff
path: root/net/net-http
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-05-15 04:57:00 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-05-15 04:57:00 +0000
commit6a580242ae88a37277769a4eaf0f31b422b50e04 (patch)
tree8ed5883eb89409f9d4086db4a8667b84a4d0bd3d /net/net-http
parent1bdf10e1da34183b6ab830b979c8cff8a7ef0816 (diff)
downloadports-6a580242ae88a37277769a4eaf0f31b422b50e04.tar.gz
ports-6a580242ae88a37277769a4eaf0f31b422b50e04.zip
add net-http
A library for doing HTTP client-side programming in Guile
Notes
Notes: svn path=/head/; revision=42610
Diffstat (limited to 'net/net-http')
-rw-r--r--net/net-http/Makefile27
-rw-r--r--net/net-http/distinfo1
-rw-r--r--net/net-http/pkg-comment1
-rw-r--r--net/net-http/pkg-descr3
-rw-r--r--net/net-http/pkg-plist2
5 files changed, 34 insertions, 0 deletions
diff --git a/net/net-http/Makefile b/net/net-http/Makefile
new file mode 100644
index 000000000000..42257b1fbb5a
--- /dev/null
+++ b/net/net-http/Makefile
@@ -0,0 +1,27 @@
+# ex:ts=8
+# New ports collection makefile for: net-http
+# Date created: May 15, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= net-http
+PORTVERSION= 0.2
+CATEGORIES= net
+MASTER_SITES= http://evan.prodromou.san-francisco.ca.us/software/net-http/
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= guile:${PORTSDIR}/lang/guile
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+GNU_CONFIGURE= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+NO_BUILD= yes
+
+do-install:
+ @${MKDIR} ${LOCALBASE}/share/guile/1.4/net
+ ${INSTALL_DATA} ${WRKSRC}/net/http.scm ${LOCALBASE}/share/guile/1.4/net
+
+.include <bsd.port.mk>
diff --git a/net/net-http/distinfo b/net/net-http/distinfo
new file mode 100644
index 000000000000..061e85fc64c8
--- /dev/null
+++ b/net/net-http/distinfo
@@ -0,0 +1 @@
+MD5 (net-http-0.2.tar.gz) = 685be98e2054551c42277f2b0dad2688
diff --git a/net/net-http/pkg-comment b/net/net-http/pkg-comment
new file mode 100644
index 000000000000..539d47db3ccf
--- /dev/null
+++ b/net/net-http/pkg-comment
@@ -0,0 +1 @@
+A library for doing HTTP client-side programming in Guile
diff --git a/net/net-http/pkg-descr b/net/net-http/pkg-descr
new file mode 100644
index 000000000000..e48757609c1b
--- /dev/null
+++ b/net/net-http/pkg-descr
@@ -0,0 +1,3 @@
+A library for doing HTTP client-side programming in Guile
+
+WWW: http://evan.prodromou.san-francisco.ca.us/software/net-http/
diff --git a/net/net-http/pkg-plist b/net/net-http/pkg-plist
new file mode 100644
index 000000000000..e1bd4b89d4af
--- /dev/null
+++ b/net/net-http/pkg-plist
@@ -0,0 +1,2 @@
+share/guile/1.4/net/http.scm
+@dirrm share/guile/1.4/net