aboutsummaryrefslogtreecommitdiff
path: root/net/netatalk/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-10-12 02:09:27 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-10-12 02:09:27 +0000
commit30af9f9d1b308ce2acc0cabc06b668583a7d6f1e (patch)
tree48b0c58eb26975ef34d329ef07b4e7c474c5ebef /net/netatalk/Makefile
parent8cc9af6661c2b7840898f302b7e053a27b5ef4ed (diff)
downloadports-30af9f9d1b308ce2acc0cabc06b668583a7d6f1e.tar.gz
ports-30af9f9d1b308ce2acc0cabc06b668583a7d6f1e.zip
for all the new features, and http://netatalk.sourceforge.net/2.0/htmldocs/upgrade.html for important upgrade instructions when moving from 1.6.x.
Notes
Notes: svn path=/head/; revision=118742
Diffstat (limited to 'net/netatalk/Makefile')
-rw-r--r--net/netatalk/Makefile50
1 files changed, 17 insertions, 33 deletions
diff --git a/net/netatalk/Makefile b/net/netatalk/Makefile
index d70f25e11d9f..a0dcc59210e1 100644
--- a/net/netatalk/Makefile
+++ b/net/netatalk/Makefile
@@ -6,9 +6,7 @@
#
PORTNAME= netatalk
-PORTVERSION= 1.6.4
-PORTREVISION= 1
-PORTEPOCH= 1
+PORTVERSION= 2.0.0
CATEGORIES= net print
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= netatalk
@@ -16,16 +14,18 @@ MASTER_SITE_SUBDIR= netatalk
MAINTAINER= marcus@FreeBSD.org
COMMENT= File and print server for AppleTalk networks
-.if !defined(WITHOUT_CNID)
-LIB_DEPENDS= db3.3:${PORTSDIR}/databases/db3
-.endif
+LIB_DEPENDS= db41.1:${PORTSDIR}/databases/db41
.if defined(WITH_SRVLOC)
LIB_DEPENDS+= slp.1:${PORTSDIR}/net/openslp
.endif
+NO_LATEST_LINK= yes
USE_BZIP2= yes
+USE_ICONV= yes
+USE_RC_SUBR= yes
CONFIGURE_ARGS+= --with-tcp-wrappers \
- --with-pkgconfdir=${PREFIX}/etc
+ --with-pkgconfdir=${PREFIX}/etc \
+ --with-libiconv=${LOCALBASE}
.if defined(WITH_PAM)
CONFIGURE_ARGS+= --with-pam=/etc/pam.d
PLIST_SUB+= NETATALKPAM=""
@@ -38,30 +38,14 @@ PLIST_SUB+= NETATALKPAM="@comment "
# pickup afpd servers in the network.
CONFIGURE_ARGS+= --enable-srvloc=${LOCALBASE}
.endif
-.if defined(WITHOUT_CNID)
-# Configure old LAST DID support. By default, the new CNID persistent DID
-# calculation scheme is used. However, if you wish to revert back to the old
-# 1.5.x default scheme, specify WITHOUT_CNID
-CONFIGURE_ARGS+= --with-did=last
-PLIST_SUB+= NETATALKCNID="@comment "
-.else
-# This method of DID calculation is not persistent, but has been tested to
-# work with MacOS X (10.0.3-10.1.3) as well as MacOS 7-9.2.2.
-CONFIGURE_ARGS+= --with-did=cnid \
- --with-bdb=${LOCALBASE}
-PLIST_SUB+= NETATALKCNID=""
-.endif
+CONFIGURE_ARGS+= --with-bdb=${LOCALBASE}
.if defined (WITH_TIMELORD)
CONFIGURE_ARGS+= --enable-timelord
PLIST_SUB+= TIMELORD=""
.else
PLIST_SUB+= TIMELORD="@comment "
.endif
-.if defined (WITH_MANGLING) && !defined (WITHOUT_CNID)
-# Enable long file name mangling support (requires CNID).
-CONFIGURE_ARGS+= --with-mangling
-.endif
-GNU_CONFIGURE= yes
+USE_LIBTOOL_VER=15
CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
USE_PERL5= yes
@@ -74,37 +58,37 @@ MAN1= achfile.1 aecho.1 afile.1 afppasswd.1 getzones.1 \
nbplkup.1 nbprgstr.1 nbpunrgstr.1 papstatus.1 \
single2bin.1 unbin.1 unhex.1 unsingle.1 acleandir.1 \
netatalk-config.1 timeout.1 apple_cp.1 apple_mv.1 \
- apple_rm.1
+ apple_rm.1 uniconv.1 asip-status.pl.1
MAN3= atalk_aton.3 nbp_name.3
MAN4= atalk.4
MAN5= AppleVolumes.default.5 afpd.conf.5 atalkd.conf.5 \
netatalk.conf.5 papd.conf.5
-MAN8= afpd.8 atalkd.8 papd.8 papstatus.8 psf.8 timelord.8
+MAN8= afpd.8 atalkd.8 cnid_dbd.8 cnid_metad.8 papd.8 papstatus.8 \
+ psf.8 timelord.8
-CONFLICTS= bigloo-2.* cap-6.0.* tct-1.* netatalk-2*
+CONFLICTS= bigloo-2.* cap-6.0.* tct-1.* netatalk-1*
+RC_SCRIPTS_SUB= PREFIX=${PREFIX} RC_SUBR=${RC_SUBR}
pre-everything::
@${ECHO_MSG} ""
@${ECHO_MSG} "Netatalk has the following tunable options:"
- @${ECHO_MSG} " WITHOUT_CNID=yes Turns off CNID persistent DID support"
@${ECHO_MSG} " WITH_SRVLOC=yes Enable Service Location Protocol support"
@${ECHO_MSG} " WITH_PAM=yes Enable PAM support"
@${ECHO_MSG} " WITH_TIMELORD=yes Enable Timelord network time service"
- @${ECHO_MSG} " WITH_MANGLING=yes Enable long file name mangling support (requires CNID)"
@${ECHO_MSG} ""
@${ECHO_MSG} "See Netatalk's Makefile for more details on some of these options."
@${ECHO_MSG} ""
post-extract:
- @${SED} -e "s=%%PREFIX%%=${PREFIX}=g" ${FILESDIR}/netatalk.sh \
- > ${WRKSRC}/netatalk.sh
+ @${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
+ ${FILESDIR}/netatalk.sh > ${WRKSRC}/netatalk.sh
post-install:
@${RM} -f ${PREFIX}/bin/nu ${PREFIX}/bin/lp2pap.sh \
${PREFIX}/bin/test_parse_mtab \
${PREFIX}/bin/afpd-mtab.pl ${PREFIX}/etc/netatalk.conf.dist
${INSTALL_SCRIPT} ${WRKSRC}/netatalk.sh \
- ${PREFIX}/etc/rc.d/netatalk.sh.sample
+ ${PREFIX}/etc/rc.d/netatalk.sh
${INSTALL_SCRIPT} ${WRKSRC}/contrib/macusers/macusers \
${PREFIX}/bin/macusers
.for i in ${FILES}