aboutsummaryrefslogtreecommitdiff
path: root/net/netatalk3
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2012-09-03 16:26:55 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2012-09-03 16:26:55 +0000
commitf846006fc835a9110f1540a24a581410d127987f (patch)
treef8c1c03e9a9546d57a9ccc509a44334eca1ed2ad /net/netatalk3
parenta474fbcc85ed8d1357ee3e27ce8b1103f81661a3 (diff)
downloadports-f846006fc835a9110f1540a24a581410d127987f.tar.gz
ports-f846006fc835a9110f1540a24a581410d127987f.zip
Add netatalk3, a copy from net/netatalk. The release notes for this new release can be
found at http://netatalk.sourceforge.net/3.0/ReleaseNotes-3.0.html. This is being added because Netatalk 3 removes AppleTalk support (and some may still need it).
Notes
Notes: svn path=/head/; revision=303601
Diffstat (limited to 'net/netatalk3')
-rw-r--r--net/netatalk3/Makefile114
-rw-r--r--net/netatalk3/distinfo2
-rw-r--r--net/netatalk3/files/netatalk.in23
-rw-r--r--net/netatalk3/files/patch-config_Makefile.in38
-rw-r--r--net/netatalk3/files/patch-config_netatalk.conf20
-rw-r--r--net/netatalk3/files/patch-configure20
-rw-r--r--net/netatalk3/files/patch-etc_apfd_Makefile.in11
-rw-r--r--net/netatalk3/files/patch-etc_cnid_dbd_cnid_metad.c10
-rw-r--r--net/netatalk3/files/patch-etc_uams_Makefile.in298
-rw-r--r--net/netatalk3/files/patch-include_atalk_util.h10
-rw-r--r--net/netatalk3/pkg-descr19
-rw-r--r--net/netatalk3/pkg-message9
-rw-r--r--net/netatalk3/pkg-plist71
13 files changed, 645 insertions, 0 deletions
diff --git a/net/netatalk3/Makefile b/net/netatalk3/Makefile
new file mode 100644
index 000000000000..a458417e5b9b
--- /dev/null
+++ b/net/netatalk3/Makefile
@@ -0,0 +1,114 @@
+# Ports collection makefile for: netatalk
+# Date created: 23 Jul 1997
+# Whom: stb
+#
+# $FreeBSD$
+#
+
+PORTNAME= netatalk
+PORTVERSION= 3.0
+CATEGORIES= net
+MASTER_SITES= SF
+
+MAINTAINER= marcus@FreeBSD.org
+COMMENT= File server for Mac OS X
+
+LIB_DEPENDS= gcrypt:${PORTSDIR}/security/libgcrypt \
+ event-2.0:${PORTSDIR}/devel/libevent2
+
+LATEST_LINK= netatalk3
+USE_AUTOTOOLS= libtool
+USE_BDB= 46+
+USE_BZIP2= yes
+USE_ICONV= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_PERL5= yes
+USE_GNOME= pkgconfig
+WANT_GNOME= yes
+USE_RC_SUBR= netatalk
+
+CONFIGURE_ARGS+= --enable-tcp-wrappers \
+ --with-pkgconfdir=${PREFIX}/etc \
+ --with-libiconv=${LOCALBASE} \
+ --with-libgcrypt-dir=${LOCALBASE} \
+ --with-uams-path=${PREFIX}/libexec/netatalk-uams \
+ --with-bdb=${LOCALBASE} \
+ --localstatedir=/var \
+ --disable-bundled-libevent
+
+OPTIONS= PAM "Enable PAM support" off \
+ KRB5 "Enable Kerberos V UAM" off \
+ ZEROCONF "Enable Zeroconf (Bonjour) support" on \
+ LDAP "Enable LDAP support" off \
+ SENDFILE "Enable sendfile support" off
+
+MAN1= ad.1 afpldaptest.1 afppasswd.1 apple_dump.1 asip-status.pl.1 \
+ dbd.1 macusers.1 \
+ netatalk-config.1 uniconv.1
+MAN5= afp.conf.5 afp_signature.conf.5 afp_voluuid.conf.5
+MAN8= afpd.8 cnid_dbd.8 cnid_metad.8 netatalk.8
+
+CONFLICTS= bigloo-2.* cap-6.0.* tct-1.* netatalk-[12]* yudit-[0-9]*
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_KRB5)
+CONFIGURE_ARGS+= --enable-krbV-uam
+PLIST_SUB+= NETATALKKRB5=""
+.else
+PLIST_SUB+= NETATALKKRB5="@comment "
+.endif
+
+.if defined(WITH_PAM)
+CONFIGURE_ARGS+= --with-pam
+PLIST_SUB+= NETATALKPAM=""
+.else
+CONFIGURE_ARGS+= --without-pam
+PLIST_SUB+= NETATALKPAM="@comment "
+.endif
+
+.if defined (WITH_ZEROCONF)
+CONFIGURE_ARGS+= --enable-zeroconf=${LOCALBASE}
+CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
+LIB_DEPENDS+= avahi-client.3:${PORTSDIR}/net/avahi-app
+USE_GNOME+= pkgconfig
+SUB_LIST+= ZEROCONF="avahi_daemon"
+.else
+CONFIGURE_ARGS+= --disable-zerconf
+SUB_LIST+= ZEROCONF=""
+.endif
+
+.if defined (WITH_LDAP)
+CONFIGURE_ARGS+= --with-ldap
+CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
+USE_OPENLDAP= yes
+.else
+CONFIGURE_ARGS+= --without-ldap
+.endif
+
+.if defined (WITH_SENDFILE)
+CONFIGURE_ARGS+= --enable-sendfile
+.else
+CONFIGURE_ARGS+= --disable-sendfile
+.endif
+
+.if ${OSVERSION} < 800031
+PLIST_SUB+= ATFUNCS="@comment "
+.else
+PLIST_SUB+= ATFUNCS=""
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%DB_NAME%%|${BDB_INCLUDE_DIR:T}| ; \
+ s|%%DB_LIB%%|-l${BDB_LIB_NAME}|g ; \
+ s|%%LOCALBASE%%|${LOCALBASE}|g' \
+ ${WRKSRC}/configure \
+ ${WRKSRC}/etc/netatalk/Makefile.in
+
+post-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/contrib/macusers/macusers \
+ ${PREFIX}/bin/macusers
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/net/netatalk3/distinfo b/net/netatalk3/distinfo
new file mode 100644
index 000000000000..f5fc3498663c
--- /dev/null
+++ b/net/netatalk3/distinfo
@@ -0,0 +1,2 @@
+SHA256 (netatalk-3.0.tar.bz2) = b7babbc986dbd6f0fca55103637de6947892b29287cb7cfbbaaa77dea3ead54c
+SIZE (netatalk-3.0.tar.bz2) = 1628026
diff --git a/net/netatalk3/files/netatalk.in b/net/netatalk3/files/netatalk.in
new file mode 100644
index 000000000000..f174db95e8ac
--- /dev/null
+++ b/net/netatalk3/files/netatalk.in
@@ -0,0 +1,23 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# PROVIDE: netatalk
+# REQUIRE: DAEMON %%ZEROCONF%%
+# KEYWORD: shutdown
+#
+# AFP fileserver for Mac clients. Add the following to /etc/rc.conf to
+# enable:
+#
+# netatalk_enable="YES"
+#
+
+netatalk_enable=${netatalk_enable-"NO"}
+
+. /etc/rc.subr
+
+name=netatalk
+rcvar=netatalk_enable
+
+load_rc_config ${name}
+run_rc_command "$1"
diff --git a/net/netatalk3/files/patch-config_Makefile.in b/net/netatalk3/files/patch-config_Makefile.in
new file mode 100644
index 000000000000..df0e892a018f
--- /dev/null
+++ b/net/netatalk3/files/patch-config_Makefile.in
@@ -0,0 +1,38 @@
+--- config/Makefile.in.orig 2012-07-09 07:43:25.000000000 -0400
++++ config/Makefile.in 2012-09-03 10:39:47.000000000 -0400
+@@ -704,8 +704,8 @@ install-data-local: install-config-files
+
+ uninstall-local:
+ for f in $(CONFFILES) $(GENFILES); do \
+- echo rm -f $(DESTDIR)$(pkgconfdir)/$$f; \
+- rm -f $(DESTDIR)$(pkgconfdir)/$$f; \
++ echo rm -f $(DESTDIR)$(pkgconfdir)/$$f.dist; \
++ rm -f $(DESTDIR)$(pkgconfdir)/$$f.dist; \
+ done
+ rm -f $(DESTDIR)$(localstatedir)/netatalk/README
+ rm -f $(DESTDIR)$(localstatedir)/netatalk/CNID/README
+@@ -714,20 +714,12 @@ uninstall-local:
+ install-config-files: $(CONFFILES) $(GENFILES)
+ $(mkinstalldirs) $(DESTDIR)$(pkgconfdir)
+ for f in $(CONFFILES) ; do \
+- if test "x$(OVERWRITE_CONFIG)" = "xyes" -o ! -f $(DESTDIR)$(pkgconfdir)/$$f; then \
+- echo "$(INSTALL_DATA) $$f $(DESTDIR)$(pkgconfdir)"; \
+- $(INSTALL_DATA) $(srcdir)/$$f $(DESTDIR)$(pkgconfdir); \
+- else \
+- echo "not overwriting $$f"; \
+- fi; \
++ echo "$(INSTALL_DATA) $$f $(DESTDIR)$(pkgconfdir)/$$f.dist"; \
++ $(INSTALL_DATA) $$f $(DESTDIR)$(pkgconfdir)/$$f.dist; \
+ done
+ for f in $(GENFILES); do \
+- if test "x$(OVERWRITE_CONFIG)" = "xyes" -o ! -f $(DESTDIR)$(pkgconfdir)/$$f; then \
+- echo "$(INSTALL_DATA) $$f $(DESTDIR)$(pkgconfdir)"; \
+- $(INSTALL_DATA) $$f $(DESTDIR)$(pkgconfdir); \
+- else \
+- echo "not overwriting $$f"; \
+- fi; \
++ echo "$(INSTALL_DATA) $$f $(DESTDIR)$(pkgconfdir)/$$f.dist"; \
++ $(INSTALL_DATA) $$f $(DESTDIR)$(pkgconfdir)/$$f.dist; \
+ done
+
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
diff --git a/net/netatalk3/files/patch-config_netatalk.conf b/net/netatalk3/files/patch-config_netatalk.conf
new file mode 100644
index 000000000000..9d3c7bf4c25f
--- /dev/null
+++ b/net/netatalk3/files/patch-config_netatalk.conf
@@ -0,0 +1,20 @@
+--- config/netatalk.conf.orig 2011-07-22 00:30:42.000000000 -0400
++++ config/netatalk.conf 2011-07-30 18:01:04.000000000 -0400
+@@ -1,4 +1,5 @@
+-# Netatalk configuration
++# netatalk configuration
++# For details see man netatalk.conf
+
+ #########################################################################
+ # Global configuration
+@@ -21,8 +22,8 @@ export ATALK_MAC_CHARSET
+
+ #### Set which daemons to run.
+ #### If you use AFP file server, run both cnid_metad and afpd.
+-CNID_METAD_RUN=yes
+-AFPD_RUN=yes
++#CNID_METAD_RUN=yes
++#AFPD_RUN=yes
+
+ #### maximum number of clients that can connect:
+ #AFPD_MAX_CLIENTS=20
diff --git a/net/netatalk3/files/patch-configure b/net/netatalk3/files/patch-configure
new file mode 100644
index 000000000000..32e1af48bff0
--- /dev/null
+++ b/net/netatalk3/files/patch-configure
@@ -0,0 +1,20 @@
+--- configure.orig 2012-04-26 10:27:12.000000000 -0400
++++ configure 2012-07-08 21:21:38.000000000 -0400
+@@ -16127,7 +16127,7 @@ fi
+ fi
+
+ # mDNS support using mDNSResponder
+- ac_fn_c_check_header_mongrel "$LINENO" "dns_sd.h" "ac_cv_header_dns_sd_h" "$ac_includes_default"
++ ac_fn_c_check_header_mongrel "$LINENO" "xxxdns_sd.hxxx" "ac_cv_header_dns_sd_h" "$ac_includes_default"
+ if test "x$ac_cv_header_dns_sd_h" = xyes; then :
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for DNSServiceRegister in -ldns_sd" >&5
+ $as_echo_n "checking for DNSServiceRegister in -ldns_sd... " >&6; }
+@@ -18150,7 +18150,7 @@ if test "x$bdb_required" = "xyes"; then
+ trybdbdir=""
+ dobdbsearch=yes
+ bdb_search_dirs="/usr/local /usr"
+- search_subdirs="/ /db5 /db5.1 /db51 /db5.0 /db50 /db4.8 /db48 /db4.7 /db47 /db4.6 /db46 /db4"
++ search_subdirs="/%%DB_NAME%% / /db5 /db5.1 /db51 /db5.0 /db50 /db4.8 /db48 /db4.7 /db47 /db4.6 /db46 /db4"
+
+ bdbfound=no
+ savedcflags="$CFLAGS"
diff --git a/net/netatalk3/files/patch-etc_apfd_Makefile.in b/net/netatalk3/files/patch-etc_apfd_Makefile.in
new file mode 100644
index 000000000000..2c59cf360086
--- /dev/null
+++ b/net/netatalk3/files/patch-etc_apfd_Makefile.in
@@ -0,0 +1,11 @@
+--- etc/afpd/Makefile.in.orig 2012-07-09 07:43:26.000000000 -0400
++++ etc/afpd/Makefile.in 2012-09-03 10:41:54.000000000 -0400
+@@ -370,7 +370,7 @@ afpd_SOURCES = afp_avahi.c afp_config.c
+ $(am__append_1)
+ afpd_LDADD = \
+ $(top_builddir)/libatalk/libatalk.la \
+- @LIBGCRYPT_LIBS@ @QUOTA_LIBS@ @WRAP_LIBS@ @LIBADD_DL@ @ACL_LIBS@ @ZEROCONF_LIBS@ @PTHREAD_LIBS@ @GSSAPI_LIBS@ @KRB5_LIBS@
++ @LIBGCRYPT_LIBS@ @QUOTA_LIBS@ @WRAP_LIBS@ @LIBADD_DL@ @ACL_LIBS@ @ZEROCONF_LIBS@ @PTHREAD_LIBS@ @GSSAPI_LIBS@ @KRB5_LIBS@ @PAM_LIBS@
+
+ afpd_LDFLAGS = -export-dynamic
+ afpd_CFLAGS = \
diff --git a/net/netatalk3/files/patch-etc_cnid_dbd_cnid_metad.c b/net/netatalk3/files/patch-etc_cnid_dbd_cnid_metad.c
new file mode 100644
index 000000000000..e83a11997d16
--- /dev/null
+++ b/net/netatalk3/files/patch-etc_cnid_dbd_cnid_metad.c
@@ -0,0 +1,10 @@
+--- etc/cnid_dbd/cnid_metad.c.orig 2011-07-30 18:28:32.000000000 -0400
++++ etc/cnid_dbd/cnid_metad.c 2011-07-30 18:29:01.000000000 -0400
+@@ -39,6 +39,7 @@
+ #include <string.h>
+ #include <signal.h>
+ #include <sys/types.h>
++#include <sys/resource.h>
+ #include <sys/time.h>
+ #include <sys/wait.h>
+ #include <sys/uio.h>
diff --git a/net/netatalk3/files/patch-etc_uams_Makefile.in b/net/netatalk3/files/patch-etc_uams_Makefile.in
new file mode 100644
index 000000000000..71f239cd1a92
--- /dev/null
+++ b/net/netatalk3/files/patch-etc_uams_Makefile.in
@@ -0,0 +1,298 @@
+--- etc/uams/Makefile.in.orig 2012-05-30 02:09:51.000000000 -0400
++++ etc/uams/Makefile.in 2012-05-30 02:18:21.000000000 -0400
+@@ -63,33 +63,10 @@ target_triplet = @target@
+ @HAVE_LIBGCRYPT_TRUE@@USE_DHX2_TRUE@@USE_PAM_SO_TRUE@am__append_5 = && $(LN_S) uams_dhx2_pam.so uams_dhx2.so
+ @HAVE_LIBGCRYPT_TRUE@@USE_DHX2_TRUE@@USE_PAM_SO_FALSE@am__append_6 = && $(LN_S) uams_dhx2_passwd.so uams_dhx2.so
+ subdir = etc/uams
+-DIST_COMMON = $(srcdir)/Makefile.am $(srcdir)/Makefile.in
++DIST_COMMON = $(srcdir)/Makefile.am $(srcdir)/Makefile.in \
++ $(top_srcdir)/depcomp
+ ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
+-am__aclocal_m4_deps = $(top_srcdir)/macros/afs-check.m4 \
+- $(top_srcdir)/macros/cnid-backend.m4 \
+- $(top_srcdir)/macros/config-checks.m4 \
+- $(top_srcdir)/macros/cups.m4 $(top_srcdir)/macros/db3-check.m4 \
+- $(top_srcdir)/macros/grep-check.m4 \
+- $(top_srcdir)/macros/gssapi-check.m4 \
+- $(top_srcdir)/macros/iconv.m4 \
+- $(top_srcdir)/macros/largefile-check.m4 \
+- $(top_srcdir)/macros/libgcrypt.m4 \
+- $(top_srcdir)/macros/libtool.m4 \
+- $(top_srcdir)/macros/ltoptions.m4 \
+- $(top_srcdir)/macros/ltsugar.m4 \
+- $(top_srcdir)/macros/ltversion.m4 \
+- $(top_srcdir)/macros/lt~obsolete.m4 \
+- $(top_srcdir)/macros/pam-check.m4 \
+- $(top_srcdir)/macros/perl-check.m4 \
+- $(top_srcdir)/macros/ps-check.m4 \
+- $(top_srcdir)/macros/quota-check.m4 \
+- $(top_srcdir)/macros/snprintf-check.m4 \
+- $(top_srcdir)/macros/srvloc.m4 \
+- $(top_srcdir)/macros/ssl-check.m4 \
+- $(top_srcdir)/macros/summary.m4 \
+- $(top_srcdir)/macros/tcp-wrappers.m4 \
+- $(top_srcdir)/macros/util.m4 $(top_srcdir)/macros/webmin.m4 \
+- $(top_srcdir)/macros/zeroconf.m4 $(top_srcdir)/configure.ac
++am__aclocal_m4_deps = $(top_srcdir)/configure.ac
+ am__configure_deps = $(am__aclocal_m4_deps) $(CONFIGURE_DEPENDENCIES) \
+ $(ACLOCAL_M4)
+ mkinstalldirs = $(install_sh) -d
+@@ -271,22 +248,12 @@ am__relativize = \
+ reldir="$$dir2"
+ ACLOCAL = @ACLOCAL@
+ ACL_LIBS = @ACL_LIBS@
+-AFS_CFLAGS = @AFS_CFLAGS@
+-AFS_LIBS = @AFS_LIBS@
+ AMTAR = @AMTAR@
+ AR = @AR@
+ AUTOCONF = @AUTOCONF@
+ AUTOHEADER = @AUTOHEADER@
+ AUTOMAKE = @AUTOMAKE@
+-AVAHI_CFLAGS = @AVAHI_CFLAGS@
+-AVAHI_LIBS = @AVAHI_LIBS@
+-AVAHI_TPOLL_CFLAGS = @AVAHI_TPOLL_CFLAGS@
+-AVAHI_TPOLL_LIBS = @AVAHI_TPOLL_LIBS@
+ AWK = @AWK@
+-BDB_BIN = @BDB_BIN@
+-BDB_CFLAGS = @BDB_CFLAGS@
+-BDB_LIBS = @BDB_LIBS@
+-BDB_PATH = @BDB_PATH@
+ CC = @CC@
+ CCDEPMODE = @CCDEPMODE@
+ CFLAGS = @CFLAGS@
+@@ -294,13 +261,7 @@ COMPILE_64BIT_KMODULE = @COMPILE_64BIT_K
+ COMPILE_KERNEL_GCC = @COMPILE_KERNEL_GCC@
+ CPP = @CPP@
+ CPPFLAGS = @CPPFLAGS@
+-CRYPT_LIBS = @CRYPT_LIBS@
+-CUPS_CFLAGS = @CUPS_CFLAGS@
+-CUPS_CONFIG = @CUPS_CONFIG@
+-CUPS_LDFLAGS = @CUPS_LDFLAGS@
+-CUPS_LIBS = @CUPS_LIBS@
+ CYGPATH_W = @CYGPATH_W@
+-DEFAULT_CNID_SCHEME = @DEFAULT_CNID_SCHEME@
+ DEFS = @DEFS@
+ DEPDIR = @DEPDIR@
+ DLLTOOL = @DLLTOOL@
+@@ -313,11 +274,6 @@ EGREP = @EGREP@
+ EXEEXT = @EXEEXT@
+ FGREP = @FGREP@
+ GREP = @GREP@
+-GSSAPI_CFLAGS = @GSSAPI_CFLAGS@
+-GSSAPI_LDFLAGS = @GSSAPI_LDFLAGS@
+-GSSAPI_LIBS = @GSSAPI_LIBS@
+-ICONV_CFLAGS = @ICONV_CFLAGS@
+-ICONV_LIBS = @ICONV_LIBS@
+ INSTALL = @INSTALL@
+ INSTALL_DATA = @INSTALL_DATA@
+ INSTALL_PROGRAM = @INSTALL_PROGRAM@
+@@ -325,7 +281,6 @@ INSTALL_SCRIPT = @INSTALL_SCRIPT@
+ INSTALL_STRIP_PROGRAM = @INSTALL_STRIP_PROGRAM@
+ KCFLAGS = @KCFLAGS@
+ KLDFLAGS = @KLDFLAGS@
+-KRB5_CONFIG = @KRB5_CONFIG@
+ LD = @LD@
+ LDFLAGS = @LDFLAGS@
+ LIBADD_DL = @LIBADD_DL@
+@@ -362,42 +317,15 @@ PACKAGE_STRING = @PACKAGE_STRING@
+ PACKAGE_TARNAME = @PACKAGE_TARNAME@
+ PACKAGE_URL = @PACKAGE_URL@
+ PACKAGE_VERSION = @PACKAGE_VERSION@
+-PAMDIR = @PAMDIR@
+-PAM_ACCOUNT = @PAM_ACCOUNT@
+-PAM_AUTH = @PAM_AUTH@
+-PAM_CFLAGS = @PAM_CFLAGS@
+-PAM_DIRECTIVE = @PAM_DIRECTIVE@
+-PAM_LIBS = @PAM_LIBS@
+-PAM_PASSWORD = @PAM_PASSWORD@
+-PAM_SESSION = @PAM_SESSION@
+ PATH_SEPARATOR = @PATH_SEPARATOR@
+-PERL = @PERL@
+-PKGCONFDIR = @PKGCONFDIR@
+-PKG_CONFIG = @PKG_CONFIG@
+-PS = @PS@
+ PTHREAD_LIBS = @PTHREAD_LIBS@
+-QUOTA_LIBS = @QUOTA_LIBS@
+ RANLIB = @RANLIB@
+ SED = @SED@
+-SERVERTEXT = @SERVERTEXT@
+ SET_MAKE = @SET_MAKE@
+ SHELL = @SHELL@
+-SLP_CFLAGS = @SLP_CFLAGS@
+-SLP_LIBS = @SLP_LIBS@
+-SPOOLDIR = @SPOOLDIR@
+-SSL_CFLAGS = @SSL_CFLAGS@
+-SSL_LIBS = @SSL_LIBS@
+ STRIP = @STRIP@
+ UAMS_PATH = @UAMS_PATH@
+ VERSION = @VERSION@
+-WEBMIN_PASS = @WEBMIN_PASS@
+-WEBMIN_PATH = @WEBMIN_PATH@
+-WEBMIN_PORT = @WEBMIN_PORT@
+-WEBMIN_USER = @WEBMIN_USER@
+-WEBMIN_VERSION = @WEBMIN_VERSION@
+-WRAP_LIBS = @WRAP_LIBS@
+-ZEROCONF_CFLAGS = @ZEROCONF_CFLAGS@
+-ZEROCONF_LIBS = @ZEROCONF_LIBS@
+ abs_builddir = @abs_builddir@
+ abs_srcdir = @abs_srcdir@
+ abs_top_builddir = @abs_top_builddir@
+@@ -417,7 +345,6 @@ build_cpu = @build_cpu@
+ build_os = @build_os@
+ build_vendor = @build_vendor@
+ builddir = @builddir@
+-compiled_backends = @compiled_backends@
+ datadir = @datadir@
+ datarootdir = @datarootdir@
+ docdir = @docdir@
+@@ -543,9 +470,9 @@ $(srcdir)/Makefile.in: @MAINTAINER_MODE_
+ exit 1;; \
+ esac; \
+ done; \
+- echo ' cd $(top_srcdir) && $(AUTOMAKE) --foreign etc/uams/Makefile'; \
++ echo ' cd $(top_srcdir) && $(AUTOMAKE) --gnu etc/uams/Makefile'; \
+ $(am__cd) $(top_srcdir) && \
+- $(AUTOMAKE) --foreign etc/uams/Makefile
++ $(AUTOMAKE) --gnu etc/uams/Makefile
+ .PRECIOUS: Makefile
+ Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
+ @case '$?' in \
+@@ -590,12 +517,14 @@ uninstall-uamsLTLIBRARIES:
+
+ clean-uamsLTLIBRARIES:
+ -test -z "$(uams_LTLIBRARIES)" || rm -f $(uams_LTLIBRARIES)
+- @list='$(uams_LTLIBRARIES)'; for p in $$list; do \
+- dir="`echo $$p | sed -e 's|/[^/]*$$||'`"; \
+- test "$$dir" != "$$p" || dir=.; \
+- echo "rm -f \"$${dir}/so_locations\""; \
+- rm -f "$${dir}/so_locations"; \
+- done
++ @list='$(uams_LTLIBRARIES)'; \
++ locs=`for p in $$list; do echo $$p; done | \
++ sed 's|^[^/]*$$|.|; s|/[^/]*$$||; s|$$|/so_locations|' | \
++ sort -u`; \
++ test -z "$$locs" || { \
++ echo rm -f $${locs}; \
++ rm -f $${locs}; \
++ }
+ uams_dhx2_pam.la: $(uams_dhx2_pam_la_OBJECTS) $(uams_dhx2_pam_la_DEPENDENCIES) $(EXTRA_uams_dhx2_pam_la_DEPENDENCIES)
+ $(uams_dhx2_pam_la_LINK) $(am_uams_dhx2_pam_la_rpath) $(uams_dhx2_pam_la_OBJECTS) $(uams_dhx2_pam_la_LIBADD) $(LIBS)
+ uams_dhx2_passwd.la: $(uams_dhx2_passwd_la_OBJECTS) $(uams_dhx2_passwd_la_DEPENDENCIES) $(EXTRA_uams_dhx2_passwd_la_DEPENDENCIES)
+@@ -690,11 +619,11 @@ clean-libtool:
+ -rm -rf .libs _libs
+
+ # This directory's subdirectories are mostly independent; you can cd
+-# into them and run `make' without going through this Makefile.
+-# To change the values of `make' variables: instead of editing Makefiles,
+-# (1) if the variable is set in `config.status', edit `config.status'
+-# (which will cause the Makefiles to be regenerated when you run `make');
+-# (2) otherwise, pass the desired values on the `make' command line.
++# into them and run 'make' without going through this Makefile.
++# To change the values of 'make' variables: instead of editing Makefiles,
++# (1) if the variable is set in 'config.status', edit 'config.status'
++# (which will cause the Makefiles to be regenerated when you run 'make');
++# (2) otherwise, pass the desired values on the 'make' command line.
+ $(RECURSIVE_TARGETS):
+ @fail= failcom='exit 1'; \
+ for f in x $$MAKEFLAGS; do \
+@@ -758,6 +687,10 @@ ctags-recursive:
+ list='$(SUBDIRS)'; for subdir in $$list; do \
+ test "$$subdir" = . || ($(am__cd) $$subdir && $(MAKE) $(AM_MAKEFLAGS) ctags); \
+ done
++cscopelist-recursive:
++ list='$(SUBDIRS)'; for subdir in $$list; do \
++ test "$$subdir" = . || ($(am__cd) $$subdir && $(MAKE) $(AM_MAKEFLAGS) cscopelist); \
++ done
+
+ ID: $(HEADERS) $(SOURCES) $(LISP) $(TAGS_FILES)
+ list='$(SOURCES) $(HEADERS) $(LISP) $(TAGS_FILES)'; \
+@@ -821,6 +754,20 @@ GTAGS:
+ && $(am__cd) $(top_srcdir) \
+ && gtags -i $(GTAGS_ARGS) "$$here"
+
++cscopelist: cscopelist-recursive $(HEADERS) $(SOURCES) $(LISP)
++ list='$(SOURCES) $(HEADERS) $(LISP)'; \
++ case "$(srcdir)" in \
++ [\\/]* | ?:[\\/]*) sdir="$(srcdir)" ;; \
++ *) sdir=$(subdir)/$(srcdir) ;; \
++ esac; \
++ for i in $$list; do \
++ if test -f "$$i"; then \
++ echo "$(subdir)/$$i"; \
++ else \
++ echo "$$sdir/$$i"; \
++ fi; \
++ done >> $(top_builddir)/cscope.files
++
+ distclean-tags:
+ -rm -f TAGS ID GTAGS GRTAGS GSYMS GPATH tags
+
+@@ -941,14 +888,14 @@ info: info-recursive
+ info-am:
+
+ install-data-am: install-uamsLTLIBRARIES
+-
++ @$(NORMAL_INSTALL)
++ $(MAKE) $(AM_MAKEFLAGS) install-data-hook
+ install-dvi: install-dvi-recursive
+
+ install-dvi-am:
+
+ install-exec-am:
+- @$(NORMAL_INSTALL)
+- $(MAKE) $(AM_MAKEFLAGS) install-exec-hook
++
+ install-html: install-html-recursive
+
+ install-html-am:
+@@ -990,32 +937,33 @@ ps-am:
+ uninstall-am: uninstall-uamsLTLIBRARIES
+ @$(NORMAL_INSTALL)
+ $(MAKE) $(AM_MAKEFLAGS) uninstall-hook
+-.MAKE: $(RECURSIVE_CLEAN_TARGETS) $(RECURSIVE_TARGETS) ctags-recursive \
+- install-am install-exec-am install-strip tags-recursive \
+- uninstall-am
++.MAKE: $(RECURSIVE_CLEAN_TARGETS) $(RECURSIVE_TARGETS) \
++ cscopelist-recursive ctags-recursive install-am \
++ install-data-am install-strip tags-recursive uninstall-am
+
+ .PHONY: $(RECURSIVE_CLEAN_TARGETS) $(RECURSIVE_TARGETS) CTAGS GTAGS \
+ all all-am check check-am clean clean-generic clean-libtool \
+- clean-uamsLTLIBRARIES ctags ctags-recursive distclean \
+- distclean-compile distclean-generic distclean-libtool \
+- distclean-tags distdir dvi dvi-am html html-am info info-am \
+- install install-am install-data install-data-am install-dvi \
+- install-dvi-am install-exec install-exec-am install-exec-hook \
+- install-html install-html-am install-info install-info-am \
+- install-man install-pdf install-pdf-am install-ps \
+- install-ps-am install-strip install-uamsLTLIBRARIES \
+- installcheck installcheck-am installdirs installdirs-am \
+- maintainer-clean maintainer-clean-generic mostlyclean \
+- mostlyclean-compile mostlyclean-generic mostlyclean-libtool \
+- pdf pdf-am ps ps-am tags tags-recursive uninstall uninstall-am \
+- uninstall-hook uninstall-uamsLTLIBRARIES
++ clean-uamsLTLIBRARIES cscopelist cscopelist-recursive ctags \
++ ctags-recursive distclean distclean-compile distclean-generic \
++ distclean-libtool distclean-tags distdir dvi dvi-am html \
++ html-am info info-am install install-am install-data \
++ install-data-am install-data-hook install-dvi install-dvi-am \
++ install-exec install-exec-am install-html install-html-am \
++ install-info install-info-am install-man install-pdf \
++ install-pdf-am install-ps install-ps-am install-strip \
++ install-uamsLTLIBRARIES installcheck installcheck-am \
++ installdirs installdirs-am maintainer-clean \
++ maintainer-clean-generic mostlyclean mostlyclean-compile \
++ mostlyclean-generic mostlyclean-libtool pdf pdf-am ps ps-am \
++ tags tags-recursive uninstall uninstall-am uninstall-hook \
++ uninstall-uamsLTLIBRARIES
+
+
+ #
+ # link creation
+ #
+
+-install-exec-hook:
++install-data-hook:
+ (if [ -d $(DESTDIR)$(uamsdir) ] ; then \
+ cd $(DESTDIR)$(uamsdir) && \
+ rm -f $(uams_LINKS) && \
diff --git a/net/netatalk3/files/patch-include_atalk_util.h b/net/netatalk3/files/patch-include_atalk_util.h
new file mode 100644
index 000000000000..7df14fa51921
--- /dev/null
+++ b/net/netatalk3/files/patch-include_atalk_util.h
@@ -0,0 +1,10 @@
+--- include/atalk/util.h.orig 2010-06-09 18:45:10.000000000 -0400
++++ include/atalk/util.h 2010-06-09 18:45:22.000000000 -0400
+@@ -17,6 +17,7 @@
+
+ #include <sys/cdefs.h>
+ #include <sys/types.h>
++#include <sys/socket.h>
+ #ifdef HAVE_UNISTD_H
+ #include <unistd.h>
+ #endif /* HAVE_UNISTD_H */
diff --git a/net/netatalk3/pkg-descr b/net/netatalk3/pkg-descr
new file mode 100644
index 000000000000..ad933ec4bcd4
--- /dev/null
+++ b/net/netatalk3/pkg-descr
@@ -0,0 +1,19 @@
+Netatalk is an OpenSource software package, that can be used to turn an
+inexpensive *NIX machine into an extremely high-performance and reliable
+file server for Macintosh computers.
+
+Using Netatalk's AFP 3.2 compliant file-server leads to significantly higher
+transmission speeds compared with Macs accessing a server via SaMBa/NFS
+while providing clients with the best possible user experience (full support
+for Macintosh metadata, flawlessly supporting mixed environments of classic
+MacOS and MacOS X clients)
+
+Due to Netatalk speaking AppleTalk, the print-server task can provide
+printing clients with full AppleTalk support as well as the server itself
+with printing capabilities for AppleTalk-only printers. Starting with
+version 2.0, Netatalk seamlessly interacts with CUPS on the server.
+
+After all, Netatalk can be used to act as an AppleTalk router, providing
+both segmentation and zone names in Macintosh networks.
+
+WWW: http://netatalk.sourceforge.net/
diff --git a/net/netatalk3/pkg-message b/net/netatalk3/pkg-message
new file mode 100644
index 000000000000..23d91dbf7b03
--- /dev/null
+++ b/net/netatalk3/pkg-message
@@ -0,0 +1,9 @@
+###
+If you compiled WITH_PAM support, you need to edit /etc/pam.conf to add
+support for netatalk. To do so, add the following three lines to this
+file:
+
+netatalk auth required pam_unix.so try_first_pass
+netatalk account required pam_unix.so try_first_pass
+netatalk session required pam_permit.so
+###
diff --git a/net/netatalk3/pkg-plist b/net/netatalk3/pkg-plist
new file mode 100644
index 000000000000..14c7298c32b4
--- /dev/null
+++ b/net/netatalk3/pkg-plist
@@ -0,0 +1,71 @@
+%%ATFUNCS%%bin/ad
+bin/afpldaptest
+bin/afppasswd
+bin/apple_dump
+bin/asip-status.pl
+bin/cnid2_create
+bin/dbd
+bin/macusers
+bin/netatalk-config
+bin/uniconv
+@unexec if cmp -s %D/etc/afp.conf %D/etc/afp.conf.dist; then rm -f %D/etc/afp.conf; fi
+etc/afp.conf.dist
+@exec [ ! -f %B/afp.conf ] && cp %B/%f %B/afp.conf
+libexec/netatalk-uams/uams_clrtxt.so
+libexec/netatalk-uams/uams_dhx.so
+libexec/netatalk-uams/uams_dhx2.so
+%%NETATALKPAM%%libexec/netatalk-uams/uams_dhx2_pam.a
+%%NETATALKPAM%%libexec/netatalk-uams/uams_dhx2_pam.la
+%%NETATALKPAM%%libexec/netatalk-uams/uams_dhx2_pam.so
+libexec/netatalk-uams/uams_dhx2_passwd.a
+libexec/netatalk-uams/uams_dhx2_passwd.la
+libexec/netatalk-uams/uams_dhx2_passwd.so
+%%NETATALKPAM%%libexec/netatalk-uams/uams_dhx_pam.a
+%%NETATALKPAM%%libexec/netatalk-uams/uams_dhx_pam.la
+%%NETATALKPAM%%libexec/netatalk-uams/uams_dhx_pam.so
+libexec/netatalk-uams/uams_dhx_passwd.a
+libexec/netatalk-uams/uams_dhx_passwd.la
+libexec/netatalk-uams/uams_dhx_passwd.so
+%%NETATALKKRB5%%libexec/netatalk-uams/uams_gss.a
+%%NETATALKKRB5%%libexec/netatalk-uams/uams_gss.la
+%%NETATALKKRB5%%libexec/netatalk-uams/uams_gss.so
+libexec/netatalk-uams/uams_guest.a
+libexec/netatalk-uams/uams_guest.la
+libexec/netatalk-uams/uams_guest.so
+%%NETATALKPAM%%libexec/netatalk-uams/uams_pam.a
+%%NETATALKPAM%%libexec/netatalk-uams/uams_pam.la
+%%NETATALKPAM%%libexec/netatalk-uams/uams_pam.so
+libexec/netatalk-uams/uams_passwd.a
+libexec/netatalk-uams/uams_passwd.la
+libexec/netatalk-uams/uams_passwd.so
+libexec/netatalk-uams/uams_randnum.a
+libexec/netatalk-uams/uams_randnum.la
+libexec/netatalk-uams/uams_randnum.so
+include/atalk/acl.h
+include/atalk/adouble.h
+include/atalk/afp.h
+include/atalk/cnid.h
+include/atalk/ea.h
+include/atalk/logger.h
+include/atalk/netatalk_conf.h
+include/atalk/paths.h
+include/atalk/unicode.h
+include/atalk/unix.h
+include/atalk/util.h
+include/atalk/vfs.h
+include/atalk/volume.h
+lib/libatalk.a
+lib/libatalk.la
+lib/libatalk.so
+lib/libatalk.so.1
+sbin/afpd
+sbin/cnid_dbd
+sbin/cnid_metad
+sbin/netatalk
+share/aclocal/netatalk.m4
+@dirrm include/atalk
+@dirrm libexec/netatalk-uams
+@unexec rm -f /var/netatalk/CNID/README
+@unexec rm -f /var/netatalk/README
+@unexec rmdir /var/netatalk/CNID 2>/dev/null || true
+@unexec rmdir /var/netatalk 2>/dev/null || true