aboutsummaryrefslogtreecommitdiff
path: root/net/netatalk
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2012-04-08 01:55:05 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2012-04-08 01:55:05 +0000
commit50d12c264011fba3a8c117ff23c4eb567124e3bb (patch)
treedef30ef10ef6318ac9e1d91fe9af13e093f28782 /net/netatalk
parentc16e2ad0443a770c7ab4dfa947ff163471614bd7 (diff)
downloadports-50d12c264011fba3a8c117ff23c4eb567124e3bb.tar.gz
ports-50d12c264011fba3a8c117ff23c4eb567124e3bb.zip
Add optional (default: off) support for LDAP.
Feature safe: yes
Notes
Notes: svn path=/head/; revision=294358
Diffstat (limited to 'net/netatalk')
-rw-r--r--net/netatalk/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/net/netatalk/Makefile b/net/netatalk/Makefile
index 7c70088da862..922857e1f99f 100644
--- a/net/netatalk/Makefile
+++ b/net/netatalk/Makefile
@@ -38,7 +38,8 @@ OPTIONS= APPLETALK "Enable AppleTalk protocol support" on \
PAM "Enable PAM support" off \
TIMELORD "Enable Timelord network time service" off \
KRB5 "Enable Kerberos V UAM" off \
- ZEROCONF "Enable Zeroconf (Bonjour) support" on
+ ZEROCONF "Enable Zeroconf (Bonjour) support" on \
+ LDAP "Enable LDAP support" off
FILES= AppleVolumes.default AppleVolumes.system afpd.conf netatalk.conf
LINKS= unbin unhex unsingle hqx2bin single2bin macbinary \
@@ -110,6 +111,14 @@ SUB_LIST+= ZEROCONF="avahi_daemon"
SUB_LIST+= ZEROCONF=""
.endif
+.if defined (WITH_LDAP)
+CONFIGURE_ARGS+= --with-ldap
+CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
+USE_OPENLDAP= yes
+.else
+CONFIGURE_ARGS+= --without-ldap
+.endif
+
.if ${OSVERSION} < 800031
PLIST_SUB+= ATFUNCS="@comment "
.else