aboutsummaryrefslogtreecommitdiff
path: root/net/netmap
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2004-09-20 19:34:58 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2004-09-20 19:34:58 +0000
commit1f16f5e923efdaa0086ab117a0ea1b0598c150b3 (patch)
treecc78404f78489cb2a0bce187031dd6d96dbfdfd1 /net/netmap
parentc51569415992084e7092c73b9c76a28cd8adbadf (diff)
downloadports-1f16f5e923efdaa0086ab117a0ea1b0598c150b3.tar.gz
ports-1f16f5e923efdaa0086ab117a0ea1b0598c150b3.zip
Fix bad C++ code, to unbreak on 5.X and -CURRENT.
Reported by: kris Approved by: portmgr (marcus), fjoe (mentor, implicit)
Notes
Notes: svn path=/head/; revision=118304
Diffstat (limited to 'net/netmap')
-rw-r--r--net/netmap/Makefile8
-rw-r--r--net/netmap/files/patch-belgolib::dirs.h9
-rw-r--r--net/netmap/files/patch-netmap::misc.h18
3 files changed, 28 insertions, 7 deletions
diff --git a/net/netmap/Makefile b/net/netmap/Makefile
index d986e59dd422..e067bdcd25ed 100644
--- a/net/netmap/Makefile
+++ b/net/netmap/Makefile
@@ -20,14 +20,8 @@ RUN_DEPENDS= dotty:${PORTSDIR}/graphics/graphviz
USE_GMAKE= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 502126
-BROKEN= "Does not compile on FreeBSD >= 5.x"
-.endif
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/makelist/makelist ${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/netmap/netmap ${PREFIX}/bin
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/netmap/files/patch-belgolib::dirs.h b/net/netmap/files/patch-belgolib::dirs.h
index 4d912a46559c..27542fb44f9c 100644
--- a/net/netmap/files/patch-belgolib::dirs.h
+++ b/net/netmap/files/patch-belgolib::dirs.h
@@ -8,3 +8,12 @@
#ifndef __make_dep__
#include <string>
+@@ -91,7 +92,7 @@
+ {
+ list<T*> result=ld1;
+
+- for(list<T*>::const_iterator i = ld2.begin(); i != ld2.end(); i++)
++ for(typename list<T*>::const_iterator i = ld2.begin(); i != ld2.end(); i++)
+ result.push_back(*i);
+
+ return result;
diff --git a/net/netmap/files/patch-netmap::misc.h b/net/netmap/files/patch-netmap::misc.h
index 8ba4bdb46e24..4ea51bf3124e 100644
--- a/net/netmap/files/patch-netmap::misc.h
+++ b/net/netmap/files/patch-netmap::misc.h
@@ -8,3 +8,21 @@
string indent(unsigned);
+@@ -21,7 +22,7 @@
+ template <class T>
+ bool contains(list<T>& l, const T& t)
+ {
+- for(list<T>::iterator li = l.begin(); li != l.end(); li++)
++ for(typename list<T>::iterator li = l.begin(); li != l.end(); li++)
+ if((*li) == t)
+ return true;
+ return false;
+@@ -31,7 +32,7 @@
+ list<T> intersect(list<T>& l1, list<T>& l2)
+ {
+ list<T> result;
+- for(list<T>::iterator li = l1.begin(); li != l1.end(); li++)
++ for(typename list<T>::iterator li = l1.begin(); li != l1.end(); li++)
+ if(contains(l2, *li))
+ result.push_back(*li);
+