aboutsummaryrefslogtreecommitdiff
path: root/net/ng_netflow
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-02-18 10:10:55 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-02-18 10:10:55 +0000
commit8be0394bd494c5fe241506135b8372fe177490c5 (patch)
treec6557dc3fc0ccd841a9737a65cdd6fc92ed15d14 /net/ng_netflow
parent0ea628f65660c89899536fdc0894c7991ae11706 (diff)
downloadports-8be0394bd494c5fe241506135b8372fe177490c5.tar.gz
ports-8be0394bd494c5fe241506135b8372fe177490c5.zip
Add ng_netflow 0.2.1,
The ng_netflow node implements Cisco's Netflow (c) version 5 protocol on router running FreeBSD. ng_netflow listens for incoming traffic and identifies unique flows in it. Flows are distinguished by endpoint IP addresses, TCP/UDP port numbers and ToS. Expired flows are exported out of the node. All operation is done in kernel: both traffic capturing and export datagram generation. Exported data contaion almost all Netflow version 5 fields, except of AS numbers. PR: ports/62982 Submitted by: Gleb Smirnoff <glebius@cell.sick.ru>
Notes
Notes: svn path=/head/; revision=101312
Diffstat (limited to 'net/ng_netflow')
-rw-r--r--net/ng_netflow/Makefile37
-rw-r--r--net/ng_netflow/distinfo2
-rw-r--r--net/ng_netflow/pkg-descr14
-rw-r--r--net/ng_netflow/pkg-message6
-rw-r--r--net/ng_netflow/pkg-plist4
5 files changed, 63 insertions, 0 deletions
diff --git a/net/ng_netflow/Makefile b/net/ng_netflow/Makefile
new file mode 100644
index 000000000000..7d78a187128b
--- /dev/null
+++ b/net/ng_netflow/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: ng_netflow
+# Date Created: Feb 17, 2003
+# Whom: Gleb Smirnoff <glebius@cell.sick.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ng_netflow
+PORTVERSION= 0.2.1
+CATEGORIES= net
+MASTER_SITES= http://cell.sick.ru/~glebius/ \
+ ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ng-netflow
+
+MAINTAINER= glebius@cell.sick.ru
+COMMENT= Netgraph node implementing Cisco (c) netflow
+
+NO_PACKAGE= Should be in sync with the kernel to work correctly
+
+PLIST_SUB= KMODDIR=${KMODDIR}
+
+MAN4= ng_netflow.4
+MAN8= flowctl.8
+MANCOMPRESSED= yes
+
+.include <bsd.port.pre.mk>
+
+pre-fetch:
+
+.if !exists(${SRC_BASE}/sys/Makefile)
+ IGNORE= "This port requires kernel sources"
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/net/ng_netflow/distinfo b/net/ng_netflow/distinfo
new file mode 100644
index 000000000000..d5ac54cb51ea
--- /dev/null
+++ b/net/ng_netflow/distinfo
@@ -0,0 +1,2 @@
+MD5 (ng_netflow-0.2.1.tar.gz) = d1e24fa0eb60008ce5da13bcd637da0a
+SIZE (ng_netflow-0.2.1.tar.gz) = 18098
diff --git a/net/ng_netflow/pkg-descr b/net/ng_netflow/pkg-descr
new file mode 100644
index 000000000000..e4af334cfeee
--- /dev/null
+++ b/net/ng_netflow/pkg-descr
@@ -0,0 +1,14 @@
+The ng_netflow node implements Cisco's Netflow (c) version 5 protocol
+on router running FreeBSD. ng_netflow listens for incoming traffic and
+identifies unique flows in it. Flows are distinguished by endpoint IP
+addresses, TCP/UDP port numbers and ToS. Expired flows are exported out
+of the node.
+All operation is done in kernel: both traffic capturing and export
+datagram generation. Exported data contaion almost all Netflow version 5
+fields, except of AS numbers.
+
+WWW: http://www.sourceforge.net/projects/ng-netflow
+
+--
+Gleb Smirnoff
+<glebius@cell.sick.ru>
diff --git a/net/ng_netflow/pkg-message b/net/ng_netflow/pkg-message
new file mode 100644
index 000000000000..1b89eb66ff11
--- /dev/null
+++ b/net/ng_netflow/pkg-message
@@ -0,0 +1,6 @@
+
+*******************************************************************************
+* This port contains a prebuilt kernel module. Due to the ever changing *
+* nature of FreeBSD it may be necessary to rebuild the module after a kernel *
+* source update. To do this reinstall the port. *
+*******************************************************************************
diff --git a/net/ng_netflow/pkg-plist b/net/ng_netflow/pkg-plist
new file mode 100644
index 000000000000..f4f878418c06
--- /dev/null
+++ b/net/ng_netflow/pkg-plist
@@ -0,0 +1,4 @@
+@cwd /
+%%KMODDIR%%/ng_netflow.ko
+@cwd /usr/local
+sbin/flowctl