aboutsummaryrefslogtreecommitdiff
path: root/net/ngrep
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2006-12-07 10:43:58 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2006-12-07 10:43:58 +0000
commit747b5dd95d794be57974c61b84c86606acb0eb40 (patch)
tree65b8cc94c7e033a840715e205255729691040c83 /net/ngrep
parent9afa7c3a16d935eb82ef923ba6bb68256fcc6a4b (diff)
downloadports-747b5dd95d794be57974c61b84c86606acb0eb40.tar.gz
ports-747b5dd95d794be57974c61b84c86606acb0eb40.zip
Update to 1.45
v1.45 o fixed bug where setting the snaplen smaller than the minimum necessary to read the full headres would cause garbage to be fed into the pattern matcher o fixed unreported bug in IPv6/TCP packet length calculation o relocated the privilege-dropping routine to be invoked right before entering the packet processing loop, to prevent interference with necessary permissions to read or write dumpfiles/etc. o fixed integer overflow with the snaplen that resulted from an implicit signed/unsigned conversion o minor change to compensate for some broken compiler optimizers o fixed double-free race condition during ngrep termination o reworked packet length calculation in the main processing loop, improving performance and readability o simplified regex build logic in configure and Makefile o updated Win32 version to use config.h for preprocessor definitions instead of the Visual Studio project files, making manual tweaking and config of ngrep for Win32 consistent with *NIX and more obvious o changed third-party Makefiles to properly clean up after themselves o added support for radiotap (IEEE802_11_RADIO) o changed ``-s 0'' invocation to mimic the equivalent of tcpdump
Notes
Notes: svn path=/head/; revision=179109
Diffstat (limited to 'net/ngrep')
-rw-r--r--net/ngrep/Makefile5
-rw-r--r--net/ngrep/distinfo6
-rw-r--r--net/ngrep/files/patch-ngrep.c10
3 files changed, 5 insertions, 16 deletions
diff --git a/net/ngrep/Makefile b/net/ngrep/Makefile
index 4e6fdb74101c..16d4a36342ba 100644
--- a/net/ngrep/Makefile
+++ b/net/ngrep/Makefile
@@ -7,12 +7,11 @@
#
PORTNAME= ngrep
-PORTVERSION= 1.44
-PORTREVISION= 1
+PORTVERSION= 1.45
CATEGORIES= net security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTNAME= ${PORTNAME}-${PORTVERSION}-1
+DISTNAME= ${PORTNAME}-${PORTVERSION}
MAINTAINER= edwin@mavetju.org
COMMENT= Network grep
diff --git a/net/ngrep/distinfo b/net/ngrep/distinfo
index 57ce7f8db1b6..1ddeb32a17db 100644
--- a/net/ngrep/distinfo
+++ b/net/ngrep/distinfo
@@ -1,3 +1,3 @@
-MD5 (ngrep-1.44-1.tar.bz2) = c8aed4d0fac077cc09524b3c7d623974
-SHA256 (ngrep-1.44-1.tar.bz2) = 7c2e98f428e01c856f344c98558ccd9619892276accc39858178c6760df6aff6
-SIZE (ngrep-1.44-1.tar.bz2) = 451130
+MD5 (ngrep-1.45.tar.bz2) = bc8150331601f3b869549c94866b4f1c
+SHA256 (ngrep-1.45.tar.bz2) = aea6dd337da8781847c75b3b5b876e4de9c58520e0d77310679a979fc6402fa7
+SIZE (ngrep-1.45.tar.bz2) = 463361
diff --git a/net/ngrep/files/patch-ngrep.c b/net/ngrep/files/patch-ngrep.c
deleted file mode 100644
index 42a398ea09d9..000000000000
--- a/net/ngrep/files/patch-ngrep.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- ngrep.c.orig Tue Apr 11 09:20:31 2006
-+++ ngrep.c Tue Apr 11 09:20:59 2006
-@@ -15,6 +15,7 @@
- #include <netinet/in.h>
- #include <netinet/in_systm.h>
- #include <net/if.h>
-+#include <arpa/inet.h>
- #include <sys/tty.h>
- #include <pwd.h>
- #endif