aboutsummaryrefslogtreecommitdiff
path: root/net/nss_ldap/Makefile
diff options
context:
space:
mode:
authorTom McLaughlin <tmclaugh@FreeBSD.org>2006-07-29 20:47:45 +0000
committerTom McLaughlin <tmclaugh@FreeBSD.org>2006-07-29 20:47:45 +0000
commit6b63eb25739e1670d6f527e98a2e5c5029cb5e79 (patch)
treeb8b7fce789df3fd7490e29602f4d5faf7b32fe62 /net/nss_ldap/Makefile
parentb0aebff3f6342e15186a6c1b810268bb311c727f (diff)
downloadports-6b63eb25739e1670d6f527e98a2e5c5029cb5e79.tar.gz
ports-6b63eb25739e1670d6f527e98a2e5c5029cb5e79.zip
- Update to 1.251
- Install man page - Make krb5_ccname option in nss_ldap.conf work nss_ldap has two different arguments that can be used at compile time to make this work. The --enable-configurable-krb5-ccname-env configure option was chossen because it works with both the Heimdal and MIT Kerberos implementations and does not require a kerberos dependency. A note has been made in UPDATING that this now works because misconfiguration can lockout users. PR: 100104 Submitted by: Joerg Pulz <Joerg.Pulz@frm2.tum.de> Approved by: Maintainer
Notes
Notes: svn path=/head/; revision=169086
Diffstat (limited to 'net/nss_ldap/Makefile')
-rw-r--r--net/nss_ldap/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/net/nss_ldap/Makefile b/net/nss_ldap/Makefile
index 00dc1437c655..eee1bb19a7f6 100644
--- a/net/nss_ldap/Makefile
+++ b/net/nss_ldap/Makefile
@@ -18,7 +18,7 @@ COMMENT= RFC 2307 NSS module
USE_OPENLDAP= yes
-NSS_LDAP_VERSION=250
+NSS_LDAP_VERSION=251
GNU_CONFIGURE= yes
USE_GMAKE= yes
@@ -31,7 +31,10 @@ CONFIGURE_ARGS= --with-ldap-conf-file=${PREFIX}/etc/nss_ldap.conf \
--with-ldap-secret-file=${PREFIX}/etc/nss_ldap.secret \
--enable-rfc2307bis \
--enable-schema-mapping \
- --enable-paged-results
+ --enable-paged-results \
+ --enable-configurable-krb5-ccname-env
+
+MAN5= nss_ldap.5
post-extract:
${CP} ${FILESDIR}/bsdnss.c ${WRKSRC}
@@ -39,6 +42,9 @@ post-extract:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/nss_ldap.so ${PREFIX}/lib/nss_ldap.so.1
${INSTALL_DATA} ${WRKSRC}/ldap.conf ${PREFIX}/etc/nss_ldap.conf.sample
+ @${REINPLACE_CMD} 's,/etc/ldap.,${PREFIX}/etc/nss_ldap.,g' \
+ ${WRKSRC}/${MAN5}
+ ${INSTALL_MAN} ${WRKSRC}/${MAN5} ${PREFIX}/man/man5
${SED} -e "s,%%PREFIX%%,${PREFIX},g" ${PKGMESSAGE}
.include <bsd.port.pre.mk>