aboutsummaryrefslogtreecommitdiff
path: root/net/nss_ldap/Makefile
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-01-04 05:28:43 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-01-04 05:28:43 +0000
commita4df9b833ad6fa06d85aba8ba481b1bf80ab64e7 (patch)
tree4ec98bffc194675442ea0fce3a86b1e666293332 /net/nss_ldap/Makefile
parentf65bb6b637d42a9066af92ae46323b3eb14e3783 (diff)
downloadports-a4df9b833ad6fa06d85aba8ba481b1bf80ab64e7.tar.gz
ports-a4df9b833ad6fa06d85aba8ba481b1bf80ab64e7.zip
- OPTIONS += LCLASS
Allow the use of login classes in nss_ldap via a new LDAP attribute (loginClass). Administrators should be able to add this attribute to their schemata easily. PR: ports/14107 Submitted by: Jacob Myers <jacob@whotookspaz.org>
Notes
Notes: svn path=/head/; revision=247103
Diffstat (limited to 'net/nss_ldap/Makefile')
-rw-r--r--net/nss_ldap/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/net/nss_ldap/Makefile b/net/nss_ldap/Makefile
index 222028eeb2f5..61ba5e93cdfb 100644
--- a/net/nss_ldap/Makefile
+++ b/net/nss_ldap/Makefile
@@ -23,6 +23,8 @@ USE_AUTOTOOLS= automake:19 aclocal:19 autoconf:262 autoheader:262
USE_LDCONFIG= yes
USE_OPENLDAP= yes
+OPTIONS= LCLASS "Enable login classes via the loginClass attribute" on
+
PLIST_FILES= etc/nss_ldap.conf.sample \
lib/nss_ldap.so.1
@@ -41,6 +43,10 @@ MAN5= nss_ldap.5
CONFIGURE_ARGS+=--enable-configurable-krb5-ccname-env
.endif
+.if defined(WITH_LCLASS)
+CFLAGS+="-DHAVE_LOGIN_CLASSES"
+.endif
+
post-extract:
${CP} ${FILESDIR}/bsdnss.c ${WRKSRC}