aboutsummaryrefslogtreecommitdiff
path: root/net/nss_ldap/Makefile
diff options
context:
space:
mode:
authorAndrey Slusar <anray@FreeBSD.org>2006-05-24 10:48:59 +0000
committerAndrey Slusar <anray@FreeBSD.org>2006-05-24 10:48:59 +0000
commitfbecc92707ffa33319466395d5dfff03fcd7edbe (patch)
treeaf106afddf63e3d3410c264e950bc04f14ca6c42 /net/nss_ldap/Makefile
parentbf0da7dba47242416aa1c334207858b922ea0177 (diff)
downloadports-fbecc92707ffa33319466395d5dfff03fcd7edbe.tar.gz
ports-fbecc92707ffa33319466395d5dfff03fcd7edbe.zip
- Now it is possible to use ldap as source for hosts database.
Only gethosbyname, gethostbyname2, gethostbyaddr are implemented. Behavior of getpwXXX functions is made traditional for BSD. When uid=0 they return user password, otherwise returned password is "x". Also, in previous version of the port functions setpwent/endpwent and setgrent/endgrent were mixed. Now they are not. - Assign maintainership to submitter. Submitted by: Artem Kazakov <kazakov@gmail.com>
Notes
Notes: svn path=/head/; revision=163254
Diffstat (limited to 'net/nss_ldap/Makefile')
-rw-r--r--net/nss_ldap/Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/net/nss_ldap/Makefile b/net/nss_ldap/Makefile
index 748b5a803e30..595099ef1028 100644
--- a/net/nss_ldap/Makefile
+++ b/net/nss_ldap/Makefile
@@ -7,13 +7,14 @@
PORTNAME= nss_ldap
PORTVERSION= 1.${NSS_LDAP_VERSION}
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://www.padl.com/download/ \
${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= sem
DISTNAME= ${PORTNAME}-${NSS_LDAP_VERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= kazakov@gmail.com
COMMENT= RFC 2307 NSS module
USE_OPENLDAP= yes
@@ -23,7 +24,6 @@ NSS_LDAP_VERSION=249
GNU_CONFIGURE= yes
USE_GMAKE= yes
INSTALLS_SHLIB= yes
-PKGMESSAGE= ${WRKDIR}/pkg-message
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -Wl,-rpath,${LOCALBASE}/lib"
@@ -37,13 +37,10 @@ CONFIGURE_ARGS= --with-ldap-conf-file=${PREFIX}/etc/nss_ldap.conf \
post-extract:
${CP} ${FILESDIR}/bsdnss.c ${WRKSRC}
-post-build:
- ${SED} -e "s,%%PREFIX%%,${PREFIX},g" ${PKGDIR}/pkg-message > ${PKGMESSAGE}
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/nss_ldap.so ${PREFIX}/lib/nss_ldap.so.1
${INSTALL_DATA} ${WRKSRC}/ldap.conf ${PREFIX}/etc/nss_ldap.conf.sample
- ${CAT} ${PKGMESSAGE}
+ ${SED} -e "s,%%PREFIX%%,${PREFIX},g" ${PKGMESSAGE}
.include <bsd.port.pre.mk>