aboutsummaryrefslogtreecommitdiff
path: root/net/ntop
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2014-07-03 12:36:11 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2014-07-03 12:36:11 +0000
commit387cef53bd751fe7f7af535b686b9a2c11c5564c (patch)
tree1811ec3ba412e18779c970861424ba47df2c2d71 /net/ntop
parentde3d0b257991212968d605c4e9ccffa6311f6c44 (diff)
downloadports-387cef53bd751fe7f7af535b686b9a2c11c5564c.tar.gz
ports-387cef53bd751fe7f7af535b686b9a2c11c5564c.zip
- Finalize switch to libtool (remove USE_AUTOTOOLS=libtool)
- Strip all installed libraries (not stripped by install-strip target)
Notes
Notes: svn path=/head/; revision=360362
Diffstat (limited to 'net/ntop')
-rw-r--r--net/ntop/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/net/ntop/Makefile b/net/ntop/Makefile
index ef34f68ef2a0..ad5683d5ae4b 100644
--- a/net/ntop/Makefile
+++ b/net/ntop/Makefile
@@ -23,7 +23,7 @@ RUN_DEPENDS:= ${BUILD_DEPENDS} \
DBDIR?= /var/db
USES= gmake libtool
-USE_AUTOTOOLS= libtool automake autoconf
+USE_AUTOTOOLS= automake autoconf libtoolize
USE_GNOME= libxml2
USE_PYTHON= yes
USE_OPENSSL= yes
@@ -85,4 +85,7 @@ pre-configure:
pre-install:
@cd ${WRKSRC} && ${MAKE_CMD} dnetter
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/ntop/plugins/*.so
+
.include <bsd.port.mk>