aboutsummaryrefslogtreecommitdiff
path: root/net/ntop
diff options
context:
space:
mode:
authorClement Laforet <clement@FreeBSD.org>2005-01-16 11:13:37 +0000
committerClement Laforet <clement@FreeBSD.org>2005-01-16 11:13:37 +0000
commit83a39eb79310b17e343a3e8daceea88395499e9a (patch)
tree9c6566e878008542f18cb512ea13db769d8e98b7 /net/ntop
parent5de6b175d70dd1dfcd43a8c1f2f43acc20a13d72 (diff)
downloadports-83a39eb79310b17e343a3e8daceea88395499e9a.tar.gz
ports-83a39eb79310b17e343a3e8daceea88395499e9a.zip
- Update to 3.1
Notes: - IPv6 support is disabled - now startup script prompts for admin password, if unset.
Notes
Notes: svn path=/head/; revision=126571
Diffstat (limited to 'net/ntop')
-rw-r--r--net/ntop/Makefile12
-rw-r--r--net/ntop/distinfo4
-rw-r--r--net/ntop/files/ntop.sh13
-rw-r--r--net/ntop/files/patch-configure40
-rw-r--r--net/ntop/files/patch-util.c10
-rw-r--r--net/ntop/pkg-message13
-rw-r--r--net/ntop/pkg-plist26
7 files changed, 51 insertions, 67 deletions
diff --git a/net/ntop/Makefile b/net/ntop/Makefile
index a6006139f415..4f71c9236ca3 100644
--- a/net/ntop/Makefile
+++ b/net/ntop/Makefile
@@ -6,9 +6,8 @@
#
PORTNAME= ntop
-PORTVERSION= 3.0
-PORTREVISION= 1
-CATEGORIES= net ipv6
+PORTVERSION= 3.1
+CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
DISTNAME= ${PORTNAME}-${PORTVERSION:S/.p/pre/}
@@ -22,6 +21,7 @@ LIB_DEPENDS= gd.4:${PORTSDIR}/graphics/gd \
png.5:${PORTSDIR}/graphics/png
DBDIR?= /var/db
+WRKSRC= ${WRKDIR}/${PORTNAME}
USE_GETOPT_LONG=yes
USE_GMAKE= yes
@@ -38,6 +38,8 @@ CONFIGURE_ARGS= --localstatedir=${DBDIR} \
--with-gd-root=${LOCALBASE} \
--with-libpng-root=${LOCALBASE} \
--with-zlib-root=/usr
+# we currently disable IPv6
+CONFIGURE_ARGS+=--disable-ipv6
MAN8= ntop.8
@@ -94,8 +96,8 @@ post-install:
@${MKDIR} ${DBDIR}/ntop
@${CHOWN} -R nobody:nobody ${DBDIR}/ntop
@${RMDIR} ${PREFIX}/lib/plugins
- @${SED} -e "s#%%PREFIX%%#${PREFIX}#g" ${FILESDIR}/ntop.sh > \
- ${WRKDIR}/ntop.sh
+ @${SED} -e "s#%%PREFIX%%#${PREFIX}#g;s#%%DBDIR%%#${DBDIR}#g" \
+ ${FILESDIR}/ntop.sh > ${WRKDIR}/ntop.sh
@${INSTALL_DATA} ${WRKDIR}/ntop.sh ${PREFIX}/etc/rc.d
@${SED} "s,%%LOCALBASE%%,${LOCALBASE},g" < ${PKGMESSAGE}
diff --git a/net/ntop/distinfo b/net/ntop/distinfo
index 0199a028be10..661f9e965a78 100644
--- a/net/ntop/distinfo
+++ b/net/ntop/distinfo
@@ -1,2 +1,2 @@
-MD5 (ntop-3.0.tgz) = 1ec6055c75f1acbb5d5600492481ef85
-SIZE (ntop-3.0.tgz) = 2990872
+MD5 (ntop-3.1.tgz) = 1c9b4097c2e464b84f2fe8f6626d2b06
+SIZE (ntop-3.1.tgz) = 3286596
diff --git a/net/ntop/files/ntop.sh b/net/ntop/files/ntop.sh
index a4afe32a9b03..577d8a77f0f7 100644
--- a/net/ntop/files/ntop.sh
+++ b/net/ntop/files/ntop.sh
@@ -28,7 +28,7 @@ additional_args=''
# End of user-configurable variables
#----------------------------------------------------------------------
-args='-d -L --set-pcap-nonblocking'
+args='-d -L --set-pcap-nonblocking --skip-version-check'
[ ! -z $interfaces ] && args="$args -i $interfaces"
[ ! -z $http_port ] && args="$args -w $http_port"
@@ -39,6 +39,17 @@ args='-d -L --set-pcap-nonblocking'
case "$1" in
start)
+ # is it the first time we run ntop
+ [ ! -e %%DBDIR%%/ntop/ntop_pw.db ] && {
+ # just in case...
+ [ ! -d %%DBDIR%%/ntop ] && {
+ echo "Reinstalling database directory"
+ mkdir -p %%DBDIR%%/ntop
+ chown -R $userid:$userid %%DBDIR%%/ntop
+ }
+ %%PREFIX%%/bin/ntop -u $userid -A || exit 1
+ echo "Now we can start ntop!"
+ }
if [ -d $logdir ]; then
touch ${logdir}/ntop.access.log
chown $userid ${logdir}/ntop.access.log
diff --git a/net/ntop/files/patch-configure b/net/ntop/files/patch-configure
index 3f0bbae6a3df..c2b8791b843e 100644
--- a/net/ntop/files/patch-configure
+++ b/net/ntop/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig Sun Mar 21 23:45:17 2004
-+++ configure Tue Mar 23 14:37:28 2004
-@@ -4898,7 +4898,7 @@
+--- configure.orig Tue Dec 21 05:07:24 2004
++++ configure Sun Jan 16 10:19:25 2005
+@@ -5173,7 +5173,7 @@
exit 1
;;
*1\.3\.[45]\-freebsd\-ports*)
@@ -9,7 +9,7 @@
echo "*"
echo "* Fasten your seat belt and good luck! If you are injured, the"
echo "* development team will disavow any knowledge of your intentions."
-@@ -20276,13 +20276,13 @@
+@@ -22928,13 +22928,13 @@
@@ -25,9 +25,9 @@
-LIBS="-lglib $LIBS"
+LIBS="-lglib-2.0 $LIBS"
cat >conftest.$ac_ext <<_ACEOF
- #line $LINENO "configure"
/* confdefs.h. */
-@@ -20297,11 +20297,11 @@
+ _ACEOF
+@@ -22948,11 +22948,11 @@
#endif
/* We use char because int might match the return type of a gcc2
builtin and then its argument prototype would still apply. */
@@ -41,29 +41,7 @@
;
return 0;
}
-@@ -20318,24 +20318,24 @@
- ac_status=$?
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
- (exit $ac_status); }; }; then
-- ac_cv_lib_glib_g_date_julian=yes
-+ ac_cv_lib_glib_g_date_new_julian=yes
- else
- echo "$as_me: failed program was:" >&5
- sed 's/^/| /' conftest.$ac_ext >&5
-
--ac_cv_lib_glib_g_date_julian=no
-+ac_cv_lib_glib_g_date_new_julian=no
- fi
- rm -f conftest.$ac_objext conftest$ac_exeext conftest.$ac_ext
- LIBS=$ac_check_lib_save_LIBS
- fi
--echo "$as_me:$LINENO: result: $ac_cv_lib_glib_g_date_julian" >&5
--echo "${ECHO_T}$ac_cv_lib_glib_g_date_julian" >&6
--if test $ac_cv_lib_glib_g_date_julian = yes; then
-+echo "$as_me:$LINENO: result: $ac_cv_lib_glib_g_date_new_julian" >&5
-+echo "${ECHO_T}$ac_cv_lib_glib_g_date_new_julian" >&6
-+if test $ac_cv_lib_glib_g_date_new_julian = yes; then
- cat >>confdefs.h <<_ACEOF
+@@ -22997,7 +22997,7 @@
#define HAVE_LIBGLIB 1
_ACEOF
@@ -72,7 +50,7 @@
fi
-@@ -24989,7 +24989,7 @@
+@@ -28604,7 +28604,7 @@
test ".${ac_cv_header_glibconfig_h}" = ".yes" &&
test ".${ac_cv_header_xmlversion_h}" = ".yes" &&
test ".${ac_cv_header_gdome_h}" = ".yes" &&
@@ -81,7 +59,7 @@
test ".${ac_cv_lib_xml2_xmlCheckVersion}" = ".yes" &&
test ".${ac_cv_lib_gdome_gdome_di_saveDocToFile}" = ".yes"; then
echo "$as_me:$LINENO: result: ok" >&5
-@@ -25008,7 +25008,7 @@
+@@ -28623,7 +28623,7 @@
echo "* gdome.h...${ac_cv_header_gdome_h}"
echo "* libgdome.so or libgdome.a...${ac_cv_lib_gdome_gdome_di_saveDocToFile}"
echo "* glib.h...${ac_cv_header_glib_h}"
diff --git a/net/ntop/files/patch-util.c b/net/ntop/files/patch-util.c
index 0fa09ede8247..abb1c662541a 100644
--- a/net/ntop/files/patch-util.c
+++ b/net/ntop/files/patch-util.c
@@ -1,12 +1,12 @@
---- util.c.orig Thu Oct 28 03:00:09 2004
-+++ util.c Thu Oct 28 02:58:27 2004
-@@ -453,7 +453,8 @@
+--- util.c.orig Thu Dec 16 20:13:26 2004
++++ util.c Sun Jan 16 12:05:04 2005
+@@ -494,7 +494,8 @@
if(!strcmp(ii->name,device))
if(iface_if_getinfo(ii) & IFACE_INFO_UP) {
/* Allocate memory for IPv6 addresses*/
- count = iface_if_addrcount(ii, AF_INET6);
+ if ((count = iface_if_addrcount(ii, AF_INET6)) == 0)
-+ return NULL;
++ return NULL;
+ if(count == 0) break;
addrs = (NtopIfaceAddr *)calloc(count, sizeof(NtopIfaceAddr));
addr_pos = 0;
- for(ia = iface_getaddr_first(ii, AF_INET6) ; ia ;
diff --git a/net/ntop/pkg-message b/net/ntop/pkg-message
index e116dc429a49..560a3913ba83 100644
--- a/net/ntop/pkg-message
+++ b/net/ntop/pkg-message
@@ -2,17 +2,7 @@
ntop has been installed, but is not quite ready to be used yet!
You need to set an administrator password for ntop before it may be used.
-As root, execute the following command to set this password:
-
- # ntop -A
-
-ntop may now be started. The recommended method to do so is via the
-installed startup script. As root, execute the following command:
-
- # sh %%LOCALBASE%%/etc/rc.d/ntop.sh
-
-The recommended way to change startup flags for ntop is to edit this
-startup script.
+Just run startup script to be prompted for the password.
Note that the installed startup script will NOT be execute at system
startup by default. If you wish ntop to start when your system boots,
@@ -25,5 +15,6 @@ In the past, ntop has been the subject of repeated security vulner-
abilities, particularly relating to its web interface. It is strongly
suggested that you protect your ntop web interface via packet filters
or TCP wrappers.
+IPv6 isn't currently supported by the port.
----------------------------------------------------------------------------
diff --git a/net/ntop/pkg-plist b/net/ntop/pkg-plist
index 24d25499ea4c..bb8a48930395 100644
--- a/net/ntop/pkg-plist
+++ b/net/ntop/pkg-plist
@@ -1,6 +1,6 @@
@exec mkdir -p %%DBDIR%%/ntop
bin/ntop
-etc/ntop/etter.passive.os.fp.gz
+etc/ntop/etter.finger.os.gz
etc/ntop/ntop-cert.pem
etc/ntop/oui.txt.gz
etc/ntop/p2c.opt.table.gz
@@ -13,12 +13,11 @@ lib/libicmpPlugin.so
lib/liblastSeenPlugin-%%SHLIB%%.so
lib/liblastSeenPlugin.a
lib/liblastSeenPlugin.so
+lib/libmyrrd-%%SHLIB%%.so
+lib/libmyrrd.a
lib/libnetflowPlugin-%%SHLIB%%.so
lib/libnetflowPlugin.a
lib/libnetflowPlugin.so
-lib/libnfsPlugin-%%SHLIB%%.so
-lib/libnfsPlugin.a
-lib/libnfsPlugin.so
lib/libntop-%%SHLIB%%.so
lib/libntop.a
lib/libntop.so
@@ -34,19 +33,29 @@ lib/librrdPlugin.so
lib/libsflowPlugin-%%SHLIB%%.so
lib/libsflowPlugin.a
lib/libsflowPlugin.so
+lib/libsnmpPlugin-%%SHLIB%%.so
+lib/libsnmpPlugin.a
lib/libxmldumpPlugin-%%SHLIB%%.so
lib/libxmldumpPlugin.a
lib/libxmldumpPlugin.so
lib/ntop/plugins/icmpPlugin.so
lib/ntop/plugins/lastSeenPlugin.so
lib/ntop/plugins/netflowPlugin.so
-lib/ntop/plugins/nfsPlugin.so
lib/ntop/plugins/pdaPlugin.so
lib/ntop/plugins/rrdPlugin.so
lib/ntop/plugins/sflowPlugin.so
+lib/ntop/plugins/snmpPlugin.so
lib/ntop/plugins/xmldumpPlugin.so
@dirrm lib/ntop/plugins
@dirrm lib/ntop
+%%DATADIR%%/html/JSCookMenu.js
+%%DATADIR%%/html/theme.js
+%%DATADIR%%/html/arrow.gif
+%%DATADIR%%/html/blank.gif
+%%DATADIR%%/html/ntop_logo.gif
+%%DATADIR%%/html/spacer.gif
+%%DATADIR%%/html/theme.css
+%%DATADIR%%/html/statsicons/flags/local.gif
%%DATADIR%%/html/About.html
%%DATADIR%%/html/Admin.html
%%DATADIR%%/html/All.html
@@ -103,13 +112,6 @@ lib/ntop/plugins/xmldumpPlugin.so
%%DATADIR%%/html/help.png
%%DATADIR%%/html/hostSortNote.html
%%DATADIR%%/html/index.html
-%%DATADIR%%/html/index_inner.html
-%%DATADIR%%/html/index_inner_w3c.html
-%%DATADIR%%/html/index_left.html
-%%DATADIR%%/html/index_left_w3c.html
-%%DATADIR%%/html/index_top.html
-%%DATADIR%%/html/index_top_w3c.html
-%%DATADIR%%/html/index_w3c.html
%%DATADIR%%/html/info.gif
%%DATADIR%%/html/initiator.gif
%%DATADIR%%/html/lock.png