aboutsummaryrefslogtreecommitdiff
path: root/net/ntp
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2016-11-24 16:01:51 +0000
committerCy Schubert <cy@FreeBSD.org>2016-11-24 16:01:51 +0000
commit3c2e32662585c95aea625302b3a5b3625345ea53 (patch)
treee2b61e6cfa4db80b4afcefeba2000907d1b10e51 /net/ntp
parent5aa8cab72d36505a1193e2044253eee11d8bdfa4 (diff)
downloadports-3c2e32662585c95aea625302b3a5b3625345ea53.tar.gz
ports-3c2e32662585c95aea625302b3a5b3625345ea53.zip
Unbreak Makefile, set up appropriate support for BROKEN.
As suggested by koobs, describe error in BROKEN=.
Notes
Notes: svn path=/head/; revision=427038
Diffstat (limited to 'net/ntp')
-rw-r--r--net/ntp/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/net/ntp/Makefile b/net/ntp/Makefile
index 03c2ad89d84d..3aa5960b7578 100644
--- a/net/ntp/Makefile
+++ b/net/ntp/Makefile
@@ -13,10 +13,6 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:S/P/p/:S/.r/-RC/}
MAINTAINER= cy@FreeBSD.org
COMMENT= The Network Time Protocol Distribution
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000000
-BROKEN= Does not build under FreeBSD-9
-.endif
-
BUILD_DEPENDS= autogen:devel/autogen
LIB_DEPENDS= libevent.so:devel/libevent2 \
libmd5.so:www/libwww
@@ -68,6 +64,12 @@ THREADS_CONFIGURE_WITH= threads
${D}_CONFIGURE_ON= --enable-${D}
.endfor
+.include <bsd.port.pre.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000000
+BROKEN= Does not build under FreeBSD-9, aclocal not found
+.endif
+
# XXX Temporary hack. Remember to remove this next commit.
post-extract:
@${TOUCH} ${WRKSRC}/scripts/build/checkHtmlFileDates
@@ -81,4 +83,4 @@ post-install:
@cd ${WRKSRC}/html && ${FIND} . -print | \
${CPIO} -pdu -R ${SHAREOWN}:${SHAREGRP} --quiet ${STAGEDIR}${DOCSDIR}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>