aboutsummaryrefslogtreecommitdiff
path: root/net/ntp
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2014-12-22 08:30:00 +0000
committerCy Schubert <cy@FreeBSD.org>2014-12-22 08:30:00 +0000
commit146b477e3afdb907db993b54fed5b2ffd3f48a03 (patch)
tree23c232ca99d3b92cb7e0bd4c979e798887fed96b /net/ntp
parente63924267f345b0ba2d66acd636259fdd0338841 (diff)
downloadports-146b477e3afdb907db993b54fed5b2ffd3f48a03.tar.gz
ports-146b477e3afdb907db993b54fed5b2ffd3f48a03.zip
Unbreak MX4200.
Submitted by: delphij
Notes
Notes: svn path=/head/; revision=375215
Diffstat (limited to 'net/ntp')
-rw-r--r--net/ntp/Makefile6
-rw-r--r--net/ntp/files/patch-ntpd__refclock__mx4200.c25
2 files changed, 26 insertions, 5 deletions
diff --git a/net/ntp/Makefile b/net/ntp/Makefile
index 38e1d077def8..6bd00d2a9181 100644
--- a/net/ntp/Makefile
+++ b/net/ntp/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ntp
PORTVERSION= 4.2.8
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net ipv6
MASTER_SITES= ftp://ftp.udel.edu/pub/ntp/ntp4/ \
http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ \
@@ -48,10 +48,6 @@ CONFIGURE_ARGS+= --enable-${D}
.endif
.endfor
-.if ${PORT_OPTIONS:MMX4200}
-BROKEN= Fails to compile when MX4200 is enabled.
-.endif
-
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}4
# XXX Temporary hack. Remember to remove this next commit.
diff --git a/net/ntp/files/patch-ntpd__refclock__mx4200.c b/net/ntp/files/patch-ntpd__refclock__mx4200.c
new file mode 100644
index 000000000000..f0181520b7c3
--- /dev/null
+++ b/net/ntp/files/patch-ntpd__refclock__mx4200.c
@@ -0,0 +1,25 @@
+--- ntpd/refclock_mx4200.c.orig 2014-12-19 11:56:52 UTC
++++ ntpd/refclock_mx4200.c
+@@ -1572,7 +1572,7 @@ mx4200_debug(struct peer *peer, char *fm
+ * Print debug message to stdout
+ * In the future, we may want to get get more creative...
+ */
+- mvprintf(fmt, ap);
++ vprintf(fmt, ap);
+
+ va_end(ap);
+ }
+@@ -1613,11 +1613,11 @@ mx4200_send(peer, fmt, va_alist)
+
+ cp = buf;
+ *cp++ = '$';
+- n = VSNPRINTF((cp, sizeof(buf) - 1, fmt, ap));
++ n = vsnprintf(cp, sizeof(buf) - 1, fmt, ap);
+ ck = mx4200_cksum(cp, n);
+ cp += n;
+ ++n;
+- n += SNPRINTF((cp, sizeof(buf) - n - 5, "*%02X\r\n", ck));
++ n += snprintf(cp, sizeof(buf) - n - 5, "*%02X\r\n", ck);
+
+ m = write(pp->io.fd, buf, (unsigned)n);
+ if (m < 0)