aboutsummaryrefslogtreecommitdiff
path: root/net/opal3/Makefile
diff options
context:
space:
mode:
authorRoger Hardiman <roger@FreeBSD.org>2002-11-12 10:12:06 +0000
committerRoger Hardiman <roger@FreeBSD.org>2002-11-12 10:12:06 +0000
commit833a44278e85ce43b33540463fbbe2199983d19c (patch)
tree116763b3938ef89993d84d379cfe85b591107963 /net/opal3/Makefile
parent2c20fc9cb844ff5fccb446d241c5d4e34e00bbcc (diff)
downloadports-833a44278e85ce43b33540463fbbe2199983d19c.tar.gz
ports-833a44278e85ce43b33540463fbbe2199983d19c.zip
The IXJ driver does not compile on 5.x machines, so only add it as a
port dependency on FreeBSD 4.x and lower.
Notes
Notes: svn path=/head/; revision=69947
Diffstat (limited to 'net/opal3/Makefile')
-rw-r--r--net/opal3/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/net/opal3/Makefile b/net/opal3/Makefile
index 2e8b387007fc..97438c2b6b81 100644
--- a/net/opal3/Makefile
+++ b/net/opal3/Makefile
@@ -19,6 +19,9 @@ MAINTAINER= roger@freebsd.org
LIB_DEPENDS= speex.0:${PORTSDIR}/audio/speex \
expat.4:${PORTSDIR}/textproc/expat2
+
+.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 500000
# Check for telephony.h in the two places the source is hard coded to check
# /usr/include/sys and /usr/local/include/sys
# If it is not present, extract it from the comms/ixj port
@@ -27,6 +30,7 @@ LIB_DEPENDS= speex.0:${PORTSDIR}/audio/speex \
BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/comms/ixj:patch
.endif
.endif
+.endif
WRKSRC= ${WRKDIR}/${PORTNAME}
@@ -52,4 +56,4 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/samples/simple/obj_${OPSYS}_${THE_MACHTYPE}_r/simph323 ${PREFIX}/bin
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>