aboutsummaryrefslogtreecommitdiff
path: root/net/opal3
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2006-04-21 13:03:32 +0000
committerVolker Stolz <vs@FreeBSD.org>2006-04-21 13:03:32 +0000
commit2d872d7a886748e074dba1fa2227fda0c9c9250f (patch)
tree5826add8ae9af12ab6dcdf36d8056cbeb099521a /net/opal3
parent9ca0cbea7fd12771db68b4ddfaeff67e36e61ffd (diff)
downloadports-2d872d7a886748e074dba1fa2227fda0c9c9250f.tar.gz
ports-2d872d7a886748e074dba1fa2227fda0c9c9250f.zip
Fix build on AMD
PR: ports/96102 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=160069
Diffstat (limited to 'net/opal3')
-rw-r--r--net/opal3/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/net/opal3/Makefile b/net/opal3/Makefile
index ef2c52fb2f26..8a691c50ee98 100644
--- a/net/opal3/Makefile
+++ b/net/opal3/Makefile
@@ -37,6 +37,11 @@ CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -I${WRKSRC}/include
BROKEN= Does not build on FreeBSD 4.x, if you manage to make it work, please send a patch to the maintainer: ${MAINTAINER}
.endif
+# Avoid build error on amd64: relocation R_X86_64_32 can not be used when making a shared object; recompile with -fPIC
+.if (${ARCH} == "amd64")
+CFLAGS+= -fPIC
+.endif
+
.ifdef (WITH_FFMPEG)
LIB_DEPENDS+= avcodec.1:${PORTSDIR}/multimedia/ffmpeg
CONFIGURE_ARGS+= --enable-h263avcodec=${LOCALBASE}/include/ffmpeg