aboutsummaryrefslogtreecommitdiff
path: root/net/opal3
diff options
context:
space:
mode:
authorAlexander Leidinger <netchild@FreeBSD.org>2006-03-05 16:17:53 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2006-03-05 16:17:53 +0000
commitf18c95d97c983df9f62e41400c7b1ead1b6ec7ea (patch)
treeb558340ce5b7c6c2e34d39f37506fd2900b5476f /net/opal3
parent64bf6428bfd98e6a083f9222029b746746530857 (diff)
downloadports-f18c95d97c983df9f62e41400c7b1ead1b6ec7ea.tar.gz
ports-f18c95d97c983df9f62e41400c7b1ead1b6ec7ea.zip
Fix the amd64 build (and perhaps other arches which need -fPIC).
Maintainer informed. Tested on: amd64 tinderbox Approved by: portmgr (linnimon)
Notes
Notes: svn path=/head/; revision=156967
Diffstat (limited to 'net/opal3')
-rw-r--r--net/opal3/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/net/opal3/Makefile b/net/opal3/Makefile
index 6dafd32d2e6d..10517f59056f 100644
--- a/net/opal3/Makefile
+++ b/net/opal3/Makefile
@@ -27,9 +27,15 @@ USE_AUTOTOOLS= autoconf:259
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -I${WRKSRC}/include" LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib" BUILDTIME="YES"
+.include <bsd.port.pre.mk>
+
+.if (${ARCH} == "amd64") || (${ARCH} == "ia64") || (${ARCH} == "sparc64")
+CFLAGS+= -fPIC
+.endif
+
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include -I${WRKSRC}/include" LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib" BUILDTIME="YES"
NO_FILTER_SHLIBS= yes
ALL_TARGET= optshared
MAKE_ENV= BUILDTIME="YES"
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>