aboutsummaryrefslogtreecommitdiff
path: root/net/openh323
diff options
context:
space:
mode:
authorSergei Kolobov <sergei@FreeBSD.org>2005-02-21 13:17:35 +0000
committerSergei Kolobov <sergei@FreeBSD.org>2005-02-21 13:17:35 +0000
commitfee45a88346f5f2e78b4e599ab4a9dd6d1c27597 (patch)
tree5118a28b9e7b6c09539a2ad70265eac86b3d3b83 /net/openh323
parent0f5f85bafcab34f7b13c788b4f94b9972d3c586f (diff)
downloadports-fee45a88346f5f2e78b4e599ab4a9dd6d1c27597.tar.gz
ports-fee45a88346f5f2e78b4e599ab4a9dd6d1c27597.zip
- Try harder when determining WRKSRC of pwlib build-time dependency:
use cd ${PORTSDIR}/deve/pwlib && make -V WRKSRC instead of hard-coding default location which is not always applicable - While I'm here, pacify portlint(1) (spaces -> tab)
Notes
Notes: svn path=/head/; revision=129475
Diffstat (limited to 'net/openh323')
-rw-r--r--net/openh323/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/net/openh323/Makefile b/net/openh323/Makefile
index 07eeffec3a8c..41869d00548e 100644
--- a/net/openh323/Makefile
+++ b/net/openh323/Makefile
@@ -28,7 +28,7 @@ LIB_DEPENDS= expat.5:${PORTSDIR}/textproc/expat2
# If it is not present, extract it from the comms/ixj port
.if !exists(/usr/include/sys/telephony.h)
.if !exists(/usr/local/include/sys/telephony.h)
-PATCH_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/comms/ixj:patch
+PATCH_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/comms/ixj:patch
.endif
.endif
.endif
@@ -42,11 +42,10 @@ USE_GMAKE= yes
USE_OPENLDAP= yes
USE_AUTOCONF_VER= 253
GNU_CONFIGURE= yes
-CONFIGURE_ENV= PWLIBDIR=${WRKDIR}/../../../devel/pwlib/work/pwlib \
- OPENH323DIR=${WRKDIR}/openh323
+PWLIBDIR!= cd ${PORTSDIR}/devel/pwlib && make -V WRKSRC
+CONFIGURE_ENV= PWLIBDIR=${PWLIBDIR} OPENH323DIR=${WRKSRC}
ALL_TARGET= optnoshared
-MAKE_ENV= PWLIBDIR=${WRKDIR}/../../../devel/pwlib/work/pwlib \
- OPENH323DIR=${WRKDIR}/openh323
+MAKE_ENV= PWLIBDIR=${PWLIBDIR} OPENH323DIR=${WRKSRC}
THE_MACHTYPE= ${ARCH:S/i386/x86/}
MAKE_ARGS= OSTYPE=${OPSYS} MACHTYPE=${THE_MACHTYPE} OSRELEASE=${OSVERSION} CPLUS=${CXX}