aboutsummaryrefslogtreecommitdiff
path: root/net/openldap20
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-02-23 17:04:43 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-02-23 17:04:43 +0000
commitd06e0b07dc4fadcc312e379847aafdc7537f3ea3 (patch)
treeeecc5f4ed580eabdf04a91b13feeb328b4709841 /net/openldap20
parenta147aeb5633a20075effa37bb7063be3ccbfd246 (diff)
downloadports-d06e0b07dc4fadcc312e379847aafdc7537f3ea3.tar.gz
ports-d06e0b07dc4fadcc312e379847aafdc7537f3ea3.zip
Improve toward multithreading:
- Use Sleepycat Berkeley DB 3.2 that OpenLDAP2's README recommends. It is known to be multithread friendlier than Berkeley DB 1.85 included in our libc or GDBM. - Add -D_REENTRANT and -D_THREAD_SAFE to CPPFLAGS Submitted by: Yarema <yds@dppl.com>
Notes
Notes: svn path=/head/; revision=38648
Diffstat (limited to 'net/openldap20')
-rw-r--r--net/openldap20/Makefile19
1 files changed, 9 insertions, 10 deletions
diff --git a/net/openldap20/Makefile b/net/openldap20/Makefile
index 070e623d7112..89fb38e000f5 100644
--- a/net/openldap20/Makefile
+++ b/net/openldap20/Makefile
@@ -7,6 +7,7 @@
PORTNAME= openldap
PORTVERSION= 2.0.7
+PORTREVISION= 1
CATEGORIES= net databases
MASTER_SITES= ftp://ftp.OpenLDAP.org/pub/OpenLDAP/%SUBDIR%/ \
ftp://ftp.net.lut.ac.uk/openldap/%SUBDIR%/ \
@@ -22,6 +23,8 @@ EXTRACT_SUFX= .tgz
MAINTAINER= knu@FreeBSD.org
+LIB_DEPENDS= db3.2:${PORTSDIR}/databases/db3
+
USE_AUTOCONF= yes
USE_LIBTOOL= yes
USE_OPENSSL= yes
@@ -37,18 +40,14 @@ CONFIGURE_ARGS= --localstatedir=/var/run \
CONFIGURE_ARGS+= --enable-wrappers
.endif
-CPPFLAGS+= -I${LOCALBASE}/include
+# math.h uses _REENTRANT and stdio.h uses _THREAD_SAFE, so define both.
+CPPFLAGS+= -D_REENTRANT -D_THREAD_SAFE \
+ -I${LOCALBASE}/include \
+ -I${LOCALBASE}/include/db3
LDFLAGS+= -L${LOCALBASE}/lib
-.if defined(WITH_DB2)
-BUILD_DEPENDS= ${LOCALBASE}/lib/libdb2.a:${PORTSDIR}/databases/db
-CPPFLAGS+= -I${LOCALBASE}/include/db2 -D_THREAD_SAFE
-CONFIGURE_ARGS+= --enable-ldbm \
- --with-ldbm-api=db2
-.endif
-
.if defined(WITH_SASL)
-LIB_DEPENDS= sasl.8:${PORTSDIR}/security/cyrus-sasl
+LIB_DEPENDS+= sasl.8:${PORTSDIR}/security/cyrus-sasl
CPPFLAGS+= -I${LOCALBASE}/include/sasl
.endif
@@ -56,7 +55,7 @@ CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
LDFLAGS="${LDFLAGS}"
INSTALLS_SHLIB= yes
-
+
BINS= bin/ldapadd \
bin/ldapdelete \
bin/ldapmodify \