aboutsummaryrefslogtreecommitdiff
path: root/net/p5-JavaScript-RPC
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2006-05-27 16:29:12 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2006-05-27 16:29:12 +0000
commita8d57c3935d4c30ffb67d9a8302941c713cd1da7 (patch)
tree595c2b91afdbb1c886307323d986e7f0a2a7e2a6 /net/p5-JavaScript-RPC
parent61f6af37f726c9a7b1191ac08ad6ede643270773 (diff)
downloadports-a8d57c3935d4c30ffb67d9a8302941c713cd1da7.tar.gz
ports-a8d57c3935d4c30ffb67d9a8302941c713cd1da7.zip
Add port net/p5-JavaScript-RPC:
JavaScript::RPC::Server::CGI is a CGI-based server library for use with Brent Ashley's JavaScript Remote Scripting (JSRS) client library. It works asynchronously and uses DHTML to deal with the payload. In order to add your custom meothds, this module should be subclassed. The most current version (as of the release of this module) of the client library as well as a demo application have been included in this distribution. WWW: http://search.cpan.org/dist/JavaScript-RPC/ PR: ports/95124 Submitted by: Tony Shadwick <tshadwick@oss-solutions.com> Approved by: krion (mentor)
Notes
Notes: svn path=/head/; revision=163623
Diffstat (limited to 'net/p5-JavaScript-RPC')
-rw-r--r--net/p5-JavaScript-RPC/Makefile28
-rw-r--r--net/p5-JavaScript-RPC/distinfo3
-rw-r--r--net/p5-JavaScript-RPC/pkg-descr11
-rw-r--r--net/p5-JavaScript-RPC/pkg-plist7
4 files changed, 49 insertions, 0 deletions
diff --git a/net/p5-JavaScript-RPC/Makefile b/net/p5-JavaScript-RPC/Makefile
new file mode 100644
index 000000000000..c0d98b256e42
--- /dev/null
+++ b/net/p5-JavaScript-RPC/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-JavaScript-RPC
+# Date created: 30 March 2006
+# Whom: Tony Shadwick <tshadwick@oss-solutions.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= JavaScript-RPC
+PORTVERSION= 0.1
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= JavaScript
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tshadwick@oss-solutions.com
+COMMENT= Remote procedure calls from JavaScript
+
+PERL_CONFIGURE= yes
+
+MAN3= JavaScript::RPC::Server::CGI.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires Perl 5.8.0 or superior. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/p5-JavaScript-RPC/distinfo b/net/p5-JavaScript-RPC/distinfo
new file mode 100644
index 000000000000..d2a86b907f1f
--- /dev/null
+++ b/net/p5-JavaScript-RPC/distinfo
@@ -0,0 +1,3 @@
+MD5 (JavaScript-RPC-0.1.tar.gz) = edc8f6eb96cf76cc9b073a867b741912
+SHA256 (JavaScript-RPC-0.1.tar.gz) = e60631a49ef3cd84ef9a82ebf9269e158963b26f5d97f0abb9698b73716e5c02
+SIZE (JavaScript-RPC-0.1.tar.gz) = 9696
diff --git a/net/p5-JavaScript-RPC/pkg-descr b/net/p5-JavaScript-RPC/pkg-descr
new file mode 100644
index 000000000000..5898122420b2
--- /dev/null
+++ b/net/p5-JavaScript-RPC/pkg-descr
@@ -0,0 +1,11 @@
+JavaScript::RPC::Server::CGI is a CGI-based server library for use with
+Brent Ashley's JavaScript Remote Scripting (JSRS) client library. It
+works asynchronously and uses DHTML to deal with the payload.
+
+In order to add your custom meothds, this module should be subclassed.
+
+The most current version (as of the release of this module) of the
+client library as well as a demo application have been included in this
+distribution.
+
+WWW: http://search.cpan.org/dist/JavaScript-RPC/
diff --git a/net/p5-JavaScript-RPC/pkg-plist b/net/p5-JavaScript-RPC/pkg-plist
new file mode 100644
index 000000000000..aaefd5d9b6e9
--- /dev/null
+++ b/net/p5-JavaScript-RPC/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/JavaScript/RPC/Server/CGI.pm
+%%SITE_PERL%%/mach/auto/JavaScript/RPC/.packlist
+@dirrm %%SITE_PERL%%/mach/auto/JavaScript/RPC
+@dirrmtry %%SITE_PERL%%/mach/auto/JavaScript
+@dirrm %%SITE_PERL%%/JavaScript/RPC/Server
+@dirrm %%SITE_PERL%%/JavaScript/RPC
+@dirrmtry %%SITE_PERL%%/JavaScript