aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-Frame-Dump
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2007-01-15 06:13:25 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2007-01-15 06:13:25 +0000
commit250c182f5a5f79c346cafd7e3c2e061c2ffc3d9b (patch)
tree3f5e7eea29d52bb91bbd52de47084248d88fae84 /net/p5-Net-Frame-Dump
parent2a8a26e21934e83e41d49a774a821f50d7230a74 (diff)
downloadports-250c182f5a5f79c346cafd7e3c2e061c2ffc3d9b.tar.gz
ports-250c182f5a5f79c346cafd7e3c2e061c2ffc3d9b.zip
Net::Frame::Dump is the base class for all dump modules. With them,
you can open a device for live capture, for offline analysis, or for creating a pcap file. WWW: http://search.cpan.org/dist/Net-Frame-Dump/
Notes
Notes: svn path=/head/; revision=182399
Diffstat (limited to 'net/p5-Net-Frame-Dump')
-rw-r--r--net/p5-Net-Frame-Dump/Makefile41
-rw-r--r--net/p5-Net-Frame-Dump/distinfo3
-rw-r--r--net/p5-Net-Frame-Dump/pkg-descr5
-rw-r--r--net/p5-Net-Frame-Dump/pkg-plist11
4 files changed, 60 insertions, 0 deletions
diff --git a/net/p5-Net-Frame-Dump/Makefile b/net/p5-Net-Frame-Dump/Makefile
new file mode 100644
index 000000000000..c7d755fa2c48
--- /dev/null
+++ b/net/p5-Net-Frame-Dump/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: Net-Frame-Dump
+# Date created: 08 Jan 2007
+# Whom: Cheng-Lung Sung <clsung@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-Frame-Dump
+PORTVERSION= 1.00
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= Tcpdump like perl implementation
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Bit/Vector.pm:${PORTSDIR}/math/p5-Bit-Vector \
+ ${SITE_PERL}/Net/Frame.pm:${PORTSDIR}/net/p5-Net-Frame \
+ p5-Net-Pcap>=0.12:${PORTSDIR}/net/p5-Net-Pcap \
+ p5-Class-Gomor>=1.00:${PORTSDIR}/devel/p5-Class-Gomor
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::Frame::Dump.3 \
+ Net::Frame::Dump::Offline.3 \
+ Net::Frame::Dump::Online.3 \
+ Net::Frame::Dump::Writer.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500703
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes
+.endif
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= requires perl 5.6.x or later. Install lang/perl5.8 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/p5-Net-Frame-Dump/distinfo b/net/p5-Net-Frame-Dump/distinfo
new file mode 100644
index 000000000000..f0e2e1b57142
--- /dev/null
+++ b/net/p5-Net-Frame-Dump/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-Frame-Dump-1.00.tar.gz) = 85764c650b9b7871c85fea4c2ec4e2a0
+SHA256 (Net-Frame-Dump-1.00.tar.gz) = 7dcc324e9f8b2a1a72250104367e30468e4584035f8d884d26343e31e781b8c5
+SIZE (Net-Frame-Dump-1.00.tar.gz) = 11327
diff --git a/net/p5-Net-Frame-Dump/pkg-descr b/net/p5-Net-Frame-Dump/pkg-descr
new file mode 100644
index 000000000000..dc69cd4a6826
--- /dev/null
+++ b/net/p5-Net-Frame-Dump/pkg-descr
@@ -0,0 +1,5 @@
+Net::Frame::Dump is the base class for all dump modules. With them,
+you can open a device for live capture, for offline analysis, or
+for creating a pcap file.
+
+WWW: http://search.cpan.org/dist/Net-Frame-Dump/
diff --git a/net/p5-Net-Frame-Dump/pkg-plist b/net/p5-Net-Frame-Dump/pkg-plist
new file mode 100644
index 000000000000..3aced19caec9
--- /dev/null
+++ b/net/p5-Net-Frame-Dump/pkg-plist
@@ -0,0 +1,11 @@
+%%SITE_PERL%%/Net/Frame/Dump.pm
+%%SITE_PERL%%/Net/Frame/Dump/Offline.pm
+%%SITE_PERL%%/Net/Frame/Dump/Online.pm
+%%SITE_PERL%%/Net/Frame/Dump/Writer.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Frame/Dump/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Frame/Dump
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Frame
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+@dirrm %%SITE_PERL%%/Net/Frame/Dump
+@dirrmtry %%SITE_PERL%%/Net/Frame
+@dirrmtry %%SITE_PERL%%/Net