aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-Jifty
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2008-03-22 00:42:55 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2008-03-22 00:42:55 +0000
commit6e9337247b7d137d2cc724727dd548677fd3608c (patch)
treeaa418047bf651142667d288798f617b305661854 /net/p5-Net-Jifty
parente35dedf9c8788ebc8f37d20d41234f6d33d85fd1 (diff)
downloadports-6e9337247b7d137d2cc724727dd548677fd3608c.tar.gz
ports-6e9337247b7d137d2cc724727dd548677fd3608c.zip
Jifty is a full-stack web framework. It provides an optional REST interface
for applications. Using this module, you can interact with that REST interface to write client-side utilities. You can use this module directly, but you'll be better off subclassing it. This module also provides a number of convenient methods for writing short scripts. For example, passing use_config => 1 to new will look at the config file for the username and password (or SID) of the user. If neither is available, it will prompt the user for them. WWW: http://search.cpan.org/dist/Net-Jifty/
Notes
Notes: svn path=/head/; revision=209565
Diffstat (limited to 'net/p5-Net-Jifty')
-rw-r--r--net/p5-Net-Jifty/Makefile32
-rw-r--r--net/p5-Net-Jifty/distinfo3
-rw-r--r--net/p5-Net-Jifty/pkg-descr12
-rw-r--r--net/p5-Net-Jifty/pkg-plist5
4 files changed, 52 insertions, 0 deletions
diff --git a/net/p5-Net-Jifty/Makefile b/net/p5-Net-Jifty/Makefile
new file mode 100644
index 000000000000..54615e806764
--- /dev/null
+++ b/net/p5-Net-Jifty/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-Net-Jifty
+# Date created: 2008-03-18
+# Whom: Cheng-Lung Sung <clsung@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-Jifty
+PORTVERSION= 0.06
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= Perl interface to online Jifty applications
+
+RUN_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/${PERL_ARCH}/Term/ReadKey.pm:${PORTSDIR}/devel/p5-Term-ReadKey \
+ ${SITE_PERL}/${PERL_ARCH}/DateTime.pm:${PORTSDIR}/devel/p5-DateTime \
+ ${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI \
+ ${SITE_PERL}/YAML.pm:${PORTSDIR}/textproc/p5-YAML \
+ ${SITE_PERL}/Email/Address.pm:${PORTSDIR}/mail/p5-Email-Address \
+ ${SITE_PERL}/Hash/Merge.pm:${PORTSDIR}/textproc/p5-Hash-Merge \
+ ${SITE_PERL}/Path/Class.pm:${PORTSDIR}/devel/p5-Path-Class \
+ ${SITE_PERL}/Moose.pm:${PORTSDIR}/devel/p5-Moose
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::Jifty.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-Jifty/distinfo b/net/p5-Net-Jifty/distinfo
new file mode 100644
index 000000000000..485092b7c122
--- /dev/null
+++ b/net/p5-Net-Jifty/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-Jifty-0.06.tar.gz) = 3906d7bd548b4bd4965ab80d1f6b0728
+SHA256 (Net-Jifty-0.06.tar.gz) = fd24533c734909a082a43c8ef883d310f33d9b5a45502aae9467628f6015e50e
+SIZE (Net-Jifty-0.06.tar.gz) = 29579
diff --git a/net/p5-Net-Jifty/pkg-descr b/net/p5-Net-Jifty/pkg-descr
new file mode 100644
index 000000000000..295b8819bc29
--- /dev/null
+++ b/net/p5-Net-Jifty/pkg-descr
@@ -0,0 +1,12 @@
+Jifty is a full-stack web framework. It provides an optional REST interface
+for applications. Using this module, you can interact with that
+REST interface to write client-side utilities.
+
+You can use this module directly, but you'll be better off subclassing it.
+
+This module also provides a number of convenient methods for writing
+short scripts. For example, passing use_config => 1 to new will look at
+the config file for the username and password (or SID) of the user.
+If neither is available, it will prompt the user for them.
+
+WWW: http://search.cpan.org/dist/Net-Jifty/
diff --git a/net/p5-Net-Jifty/pkg-plist b/net/p5-Net-Jifty/pkg-plist
new file mode 100644
index 000000000000..6fad1554814d
--- /dev/null
+++ b/net/p5-Net-Jifty/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Net/Jifty.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Jifty/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Jifty
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+@dirrmtry %%SITE_PERL%%/Net