aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-Random
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2005-12-14 07:01:26 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2005-12-14 07:01:26 +0000
commitf075e7a418ee57d62347a9f72e82dcd51b4bfad4 (patch)
tree46245d74eecc1cc8595d7190986c0747a588b814 /net/p5-Net-Random
parent6994b912e9c9d549453e0dd2788d73123c69c515 (diff)
downloadports-f075e7a418ee57d62347a9f72e82dcd51b4bfad4.tar.gz
ports-f075e7a418ee57d62347a9f72e82dcd51b4bfad4.zip
- perl module which get random data from online sources
Notes
Notes: svn path=/head/; revision=151137
Diffstat (limited to 'net/p5-Net-Random')
-rw-r--r--net/p5-Net-Random/Makefile30
-rw-r--r--net/p5-Net-Random/distinfo3
-rw-r--r--net/p5-Net-Random/pkg-descr18
-rw-r--r--net/p5-Net-Random/pkg-plist5
4 files changed, 56 insertions, 0 deletions
diff --git a/net/p5-Net-Random/Makefile b/net/p5-Net-Random/Makefile
new file mode 100644
index 000000000000..4cf2b65cb8b5
--- /dev/null
+++ b/net/p5-Net-Random/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-Net-Random
+# Date created: Wed Dec 14 11:40:50 CST 2005
+# Whom: clsung
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-Random
+PORTVERSION= 1.2
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= A perl5 module to get random data from online sources
+
+RUN_DEPENDS= ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww
+
+PERL_CONFIGURE= YES
+
+MAN3= Net::Random.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= requires perl 5.6.x or later. Install lang/perl5 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/p5-Net-Random/distinfo b/net/p5-Net-Random/distinfo
new file mode 100644
index 000000000000..8c811b6dff45
--- /dev/null
+++ b/net/p5-Net-Random/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-Random-1.2.tar.gz) = 3b4ebef35868621789c0d6f0eaebc740
+SHA256 (Net-Random-1.2.tar.gz) = c860bf7c0c8fbb4fc986db070d82c17a6666cbabe14f92bb430f803f0264c3a1
+SIZE (Net-Random-1.2.tar.gz) = 5040
diff --git a/net/p5-Net-Random/pkg-descr b/net/p5-Net-Random/pkg-descr
new file mode 100644
index 000000000000..f48824cf7bec
--- /dev/null
+++ b/net/p5-Net-Random/pkg-descr
@@ -0,0 +1,18 @@
+Net::Random - get random data from online sources
+
+This module gets truly random data from online sources. Or at least,
+they claim to be truly random.
+
+The two sources of randomness above correspond to
+http://www.fourmilab.ch/cgi-bin/uncgi/Hotbits?nbytes=1024&fmt=hex and
+http://random.org/cgi-bin/randbyte?nbytes=1024&format=hex.
+We always get chunks of 1024 bytes at a time, storing it in a pool
+which is used up as and when needed. The pool is shared between all
+objects using the same randomness source. When we run out of randomness
+we go back to the source for more juicy random goodness.
+
+The maintainers of both randomness sources claim that their data
+is *truly* random. A some simple tests show that they are certainly
+more random than the rand() function on this 'ere machine.
+
+WWW: http://search.cpan.org/dist/Net-Random/
diff --git a/net/p5-Net-Random/pkg-plist b/net/p5-Net-Random/pkg-plist
new file mode 100644
index 000000000000..6d1dd361bc66
--- /dev/null
+++ b/net/p5-Net-Random/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Net/Random.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Random/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Random
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Net 2>/dev/null || true