aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-SSH2/Makefile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2007-03-02 01:46:20 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2007-03-02 01:46:20 +0000
commitbf4ccb013c658b8633d24f2ced8a6c7980953f43 (patch)
tree3e6fa0c64fff902426a8ddeb9830198a521b52f5 /net/p5-Net-SSH2/Makefile
parentef1c123f54ea8d68efe9f5564027d5b4faa210a0 (diff)
downloadports-bf4ccb013c658b8633d24f2ced8a6c7980953f43.tar.gz
ports-bf4ccb013c658b8633d24f2ced8a6c7980953f43.zip
Add p5-Net-SSH2 0.10, support for the SSH 2 protocol via libSSH2.
PR: ports/109702 Submitted by: Jin-Shan Tseng <tjs at cdpa.nsysu.edu.tw>
Notes
Notes: svn path=/head/; revision=186323
Diffstat (limited to 'net/p5-Net-SSH2/Makefile')
-rw-r--r--net/p5-Net-SSH2/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/net/p5-Net-SSH2/Makefile b/net/p5-Net-SSH2/Makefile
new file mode 100644
index 000000000000..f3f82335d9a0
--- /dev/null
+++ b/net/p5-Net-SSH2/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-Net-SSH2
+# Date created: 2007-03-01
+# Whom: Jin-Shan Tseng <tjs@cdpa.nsysu.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-SSH2
+PORTVERSION= 0.10
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tjs@cdpa.nsysu.edu.tw
+COMMENT= Support for the SSH 2 protocol via libSSH2
+
+LIB_DEPENDS= ssh2.0:${PORTSDIR}/security/libssh2
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::SSH2.3 Net::SSH2::Channel.3 \
+ Net::SSH2::Dir.3 Net::SSH2::File.3 \
+ Net::SSH2::Listener.3 Net::SSH2::PublicKey.3 \
+ Net::SSH2::SFTP.3
+
+.include <bsd.port.mk>