aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-TiVo
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-01-10 21:11:48 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-01-10 21:11:48 +0000
commit60f09f5d864d437f073f52962a517a6b2579291e (patch)
tree37b58d4a32e751ad5ab14c381dabc8018424616c /net/p5-Net-TiVo
parent18b0c8029105207d680de6882da72bdbf3e93115 (diff)
downloadports-60f09f5d864d437f073f52962a517a6b2579291e.tar.gz
ports-60f09f5d864d437f073f52962a517a6b2579291e.zip
Net::TiVo provides an object-oriented interface to TiVo's REST interface. This
makes it possible to query your TiVo for information about recorded content, such as a show's download URL, and space consumed. WWW: http://search.cpan.org/dist/Net-TiVo/ Author: Christopher Boumenot <boumenot@gmail.com> PR: ports/107752 Submitted by: Christopher Boumenot <boumenot at gmail.com>
Notes
Notes: svn path=/head/; revision=182018
Diffstat (limited to 'net/p5-Net-TiVo')
-rw-r--r--net/p5-Net-TiVo/Makefile35
-rw-r--r--net/p5-Net-TiVo/distinfo3
-rw-r--r--net/p5-Net-TiVo/pkg-descr6
-rw-r--r--net/p5-Net-TiVo/pkg-plist8
4 files changed, 52 insertions, 0 deletions
diff --git a/net/p5-Net-TiVo/Makefile b/net/p5-Net-TiVo/Makefile
new file mode 100644
index 000000000000..75a0df9ff6f0
--- /dev/null
+++ b/net/p5-Net-TiVo/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: Net-TiVo
+# Date created: Jan 10 2006
+# Whom: Christopher Boumenot <boumenot@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-TiVo
+PORTVERSION= 0.05
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= boumenot@gmail.com
+COMMENT= Framework for accessing TiVo using XML/HTTP
+
+BUILD_DEPENDS= ${SITE_PERL}/LWP/UserAgent.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/XML/Simple.pm:${PORTSDIR}/textproc/p5-XML-Simple \
+ ${SITE_PERL}/Log/Log4perl.pm:${PORTSDIR}/devel/p5-Log-Log4perl
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::TiVo.3 \
+ Net::TiVo::Show.3 \
+ Net::TiVo::Folder.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500801
+IGNORE= requires perl 5.8.x or later. Install lang/perl58 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/p5-Net-TiVo/distinfo b/net/p5-Net-TiVo/distinfo
new file mode 100644
index 000000000000..8c3238453191
--- /dev/null
+++ b/net/p5-Net-TiVo/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-TiVo-0.05.tar.gz) = 03f913678af1fe047f3d623abf7e6307
+SHA256 (Net-TiVo-0.05.tar.gz) = 42af48d8078f72bbc4a4417928a643337a96e8056742a651170ba316a039de73
+SIZE (Net-TiVo-0.05.tar.gz) = 8031
diff --git a/net/p5-Net-TiVo/pkg-descr b/net/p5-Net-TiVo/pkg-descr
new file mode 100644
index 000000000000..867a308ea712
--- /dev/null
+++ b/net/p5-Net-TiVo/pkg-descr
@@ -0,0 +1,6 @@
+Net::TiVo provides an object-oriented interface to TiVo's REST interface. This
+makes it possible to query your TiVo for information about recorded content,
+such as a show's download URL, and space consumed.
+
+WWW: http://search.cpan.org/dist/Net-TiVo/
+Author: Christopher Boumenot <boumenot@gmail.com>
diff --git a/net/p5-Net-TiVo/pkg-plist b/net/p5-Net-TiVo/pkg-plist
new file mode 100644
index 000000000000..0c6b339e9da8
--- /dev/null
+++ b/net/p5-Net-TiVo/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/Net/TiVo.pm
+%%SITE_PERL%%/Net/TiVo/Folder.pm
+%%SITE_PERL%%/Net/TiVo/Show.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/TiVo/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/TiVo
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+@dirrm %%SITE_PERL%%/Net/TiVo
+@dirrmtry %%SITE_PERL%%/Net