aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-Z3950
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2001-12-23 21:23:49 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2001-12-23 21:23:49 +0000
commit2c1e95715c6b9216b733a57322535a09b538f267 (patch)
tree34968cbb650fdd3d6d8168d4e669efa3a5fcd50a /net/p5-Net-Z3950
parent95dd100c0d24433130e615c370ac6278bd20e347 (diff)
downloadports-2c1e95715c6b9216b733a57322535a09b538f267.tar.gz
ports-2c1e95715c6b9216b733a57322535a09b538f267.zip
New port: p5-Net-Z3950:
This Perl module provides interface to the Z39.50 information retrieval protocol (aka ISO 23950), a mature and powerful protocol used in application domains as diverse as bibliographic information, geo-spatial mapping, museums and other cultural heritage information, and structured vocabulary navigation.
Notes
Notes: svn path=/head/; revision=52062
Diffstat (limited to 'net/p5-Net-Z3950')
-rw-r--r--net/p5-Net-Z3950/Makefile29
-rw-r--r--net/p5-Net-Z3950/distinfo1
-rw-r--r--net/p5-Net-Z3950/files/patch-Makefile.PL14
-rw-r--r--net/p5-Net-Z3950/pkg-comment1
-rw-r--r--net/p5-Net-Z3950/pkg-descr7
-rw-r--r--net/p5-Net-Z3950/pkg-plist13
6 files changed, 65 insertions, 0 deletions
diff --git a/net/p5-Net-Z3950/Makefile b/net/p5-Net-Z3950/Makefile
new file mode 100644
index 000000000000..5e2783048bbf
--- /dev/null
+++ b/net/p5-Net-Z3950/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: p5-Net-RawIP
+# Date created: 23 December 2001
+# Whom: Dmitry Sivachenko <demon@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-Z3950
+PORTVERSION= 0.22
+CATEGORIES= net perl5
+MASTER_SITES= http://perl.z3950.org/download/
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= demon@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Event.pm:${PORTSDIR}/devel/p5-Event
+LIB_DEPENDS= yaz.1:${PORTSDIR}/net/yaz
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/MARC.pm:${PORTSDIR}/textproc/p5-MARC \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Event.pm:${PORTSDIR}/devel/p5-Event
+
+PERL_CONFIGURE= yes
+CONFIGURE_ENV+= LOCALBASE=${LOCALBASE}
+
+MAN3= Net::Z3950::ResultSet.3 Net::Z3950::Manager.3 \
+ Net::Z3950::Tutorial.3 Net::Z3950::Record.3 \
+ Net::Z3950::Connection.3 Net::Z3950::APDU.3 Net::Z3950.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-Z3950/distinfo b/net/p5-Net-Z3950/distinfo
new file mode 100644
index 000000000000..081860e78fa6
--- /dev/null
+++ b/net/p5-Net-Z3950/distinfo
@@ -0,0 +1 @@
+MD5 (Net-Z3950-0.22.tar.gz) = 220355216ebae55e990103b36911b894
diff --git a/net/p5-Net-Z3950/files/patch-Makefile.PL b/net/p5-Net-Z3950/files/patch-Makefile.PL
new file mode 100644
index 000000000000..08723e422c66
--- /dev/null
+++ b/net/p5-Net-Z3950/files/patch-Makefile.PL
@@ -0,0 +1,14 @@
+--- Makefile.PL.orig Sun Dec 23 23:08:17 2001
++++ Makefile.PL Sun Dec 23 23:09:10 2001
+@@ -7,9 +7,9 @@
+ 'NAME' => 'Net::Z3950',
+ 'VERSION_FROM' => 'Z3950.pm', # finds $VERSION
+ # 'LIBS' => ['-L/usr/local/src/yaz/lib/.libs -lyaz'], # e.g., '-lm'
+- 'LIBS' => ['-lyaz'], # e.g., '-lm'
++ 'LIBS' => ["-L$ENV{LOCALBASE}/lib -lyaz"], # e.g., '-lm'
+ 'DEFINE' => '', # e.g., '-DHAVE_SOMETHING'
+-# 'INC' => '-I/usr/local/src/yaz/include',
++ 'INC' => "-I$ENV{LOCALBASE}/include",
+ 'PREREQ_PM' => { Event => 0.77 },
+ 'MYEXTLIB' => 'yazwrap/libyazwrap$(LIB_EXT)',
+ );
diff --git a/net/p5-Net-Z3950/pkg-comment b/net/p5-Net-Z3950/pkg-comment
new file mode 100644
index 000000000000..68be5c0dd107
--- /dev/null
+++ b/net/p5-Net-Z3950/pkg-comment
@@ -0,0 +1 @@
+A perl interface to the Z39.50 information retrieval protocol
diff --git a/net/p5-Net-Z3950/pkg-descr b/net/p5-Net-Z3950/pkg-descr
new file mode 100644
index 000000000000..744c3f72848b
--- /dev/null
+++ b/net/p5-Net-Z3950/pkg-descr
@@ -0,0 +1,7 @@
+This Perl module provides interface to the Z39.50 information
+retrieval protocol (aka ISO 23950), a mature and powerful protocol
+used in application domains as diverse as bibliographic information,
+geo-spatial mapping, museums and other cultural heritage information,
+and structured vocabulary navigation.
+
+WWW: http://perl.z3950.org/
diff --git a/net/p5-Net-Z3950/pkg-plist b/net/p5-Net-Z3950/pkg-plist
new file mode 100644
index 000000000000..266390e46c58
--- /dev/null
+++ b/net/p5-Net-Z3950/pkg-plist
@@ -0,0 +1,13 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/Z3950/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/Z3950/autosplit.ix
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/Z3950/Z3950.bs
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/Z3950/Z3950.so
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Net/Z3950.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Net/Z3950/APDU.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Net/Z3950/Connection.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Net/Z3950/Manager.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Net/Z3950/Record.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Net/Z3950/ResultSet.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Net/Z3950/Tutorial.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/Z3950
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Net/Z3950