aboutsummaryrefslogtreecommitdiff
path: root/net/p5-Net-ext/Makefile
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-04-24 02:05:55 +0000
committerWill Andrews <will@FreeBSD.org>2000-04-24 02:05:55 +0000
commit893faf26fcf8bc4ce151d2c05208b1a5c8ad0753 (patch)
treea39814b8e1d744e30ae219862ea437e5a0370e60 /net/p5-Net-ext/Makefile
parentfbe0989ef0877b2cf88e4186b2a314588627f4b1 (diff)
downloadports-893faf26fcf8bc4ce151d2c05208b1a5c8ad0753.tar.gz
ports-893faf26fcf8bc4ce151d2c05208b1a5c8ad0753.zip
Add p5-Net-ext, a set of Perl5 modules for using sockets with.
PR: 17597 Submitted by: Igor Vinokurov <igor@zynaps.ru>
Notes
Notes: svn path=/head/; revision=27945
Diffstat (limited to 'net/p5-Net-ext/Makefile')
-rw-r--r--net/p5-Net-ext/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/net/p5-Net-ext/Makefile b/net/p5-Net-ext/Makefile
new file mode 100644
index 000000000000..bec96ff5eace
--- /dev/null
+++ b/net/p5-Net-ext/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-Net-ext
+# Date created: 25 March 2000
+# Whom: Igor Vinokurov <igor@zynaps.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-ext
+PORTVERSION= 0.931
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= igor@zynaps.ru
+
+USE_PERL5= yes
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+MAN3= Net::Gen.3 \
+ Net::Inet.3 \
+ Net::TCP.3 \
+ Net::TCP::Server.3 \
+ Net::UDP.3 \
+ Net::UNIX.3 \
+ Net::UNIX::Server.3
+
+do-configure:
+ @cd ${WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${PERL5} Makefile.PL
+
+.include <bsd.port.mk>