aboutsummaryrefslogtreecommitdiff
path: root/net/p5-POE-Component-Client-Traceroute
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-06 14:03:19 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-06 14:03:19 +0000
commitc1dd0f00d8a364c67862748284b611bd7a55757d (patch)
treec4fda802b3c5b01348a876c0238ea340c7e87b32 /net/p5-POE-Component-Client-Traceroute
parentcb509656c2970b4330380c7e49be605b8328da77 (diff)
downloadports-c1dd0f00d8a364c67862748284b611bd7a55757d.tar.gz
ports-c1dd0f00d8a364c67862748284b611bd7a55757d.zip
- Support staging
- Use shebangfix
Notes
Notes: svn path=/head/; revision=343083
Diffstat (limited to 'net/p5-POE-Component-Client-Traceroute')
-rw-r--r--net/p5-POE-Component-Client-Traceroute/Makefile17
-rw-r--r--net/p5-POE-Component-Client-Traceroute/pkg-plist3
2 files changed, 10 insertions, 10 deletions
diff --git a/net/p5-POE-Component-Client-Traceroute/Makefile b/net/p5-POE-Component-Client-Traceroute/Makefile
index 48ceffc8a0c0..02f8804e3076 100644
--- a/net/p5-POE-Component-Client-Traceroute/Makefile
+++ b/net/p5-POE-Component-Client-Traceroute/Makefile
@@ -13,17 +13,18 @@ COMMENT= A non-blocking traceroute client
RUN_DEPENDS= p5-POE>=0.11:${PORTSDIR}/devel/p5-POE
BUILD_DEPENDS:= ${RUN_DEPENDS}
-USES= perl5
+USES= perl5 shebangfix
USE_PERL5= configure
-MAN3= POE::Component::Client::Traceroute.3
+OPTIONS_DEFINE= EXAMPLES
+
+PORTEXAMPLES= *
+SHEBANG_FILES= examples/poe-traceroute.pl
+
+.include <bsd.port.options.mk>
-NO_STAGE= yes
post-install:
-.if !defined(NOPORTDOCS)
- @${ECHO_MSG} "===> Installing examples for ${PKGNAME}"
- @${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_SCRIPT} ${WRKSRC}/examples/* ${EXAMPLESDIR}
-.endif
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/examples/* ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>
diff --git a/net/p5-POE-Component-Client-Traceroute/pkg-plist b/net/p5-POE-Component-Client-Traceroute/pkg-plist
index 0165feb901e2..1d878e879bf8 100644
--- a/net/p5-POE-Component-Client-Traceroute/pkg-plist
+++ b/net/p5-POE-Component-Client-Traceroute/pkg-plist
@@ -1,6 +1,6 @@
%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/Client/Traceroute/.packlist
%%SITE_PERL%%/POE/Component/Client/Traceroute.pm
-%%PORTDOCS%%%%EXAMPLESDIR%%/poe-traceroute.pl
+%%PERL5_MAN3%%/POE::Component::Client::Traceroute.3.gz
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/Client/Traceroute
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/Client
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component
@@ -8,4 +8,3 @@
@dirrmtry %%SITE_PERL%%/POE/Component/Client
@dirrmtry %%SITE_PERL%%/POE/Component
@dirrmtry %%SITE_PERL%%/POE
-%%PORTDOCS%%@dirrmtry %%EXAMPLESDIR%%