aboutsummaryrefslogtreecommitdiff
path: root/net/p5-POE-Component-RRDTool
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2002-08-05 14:55:36 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2002-08-05 14:55:36 +0000
commit96c8ed2d25fa69ec39b568e71c7b00eb7ce0c9c4 (patch)
tree615cac6921695406bfe8866f3f1daafe7a32faf2 /net/p5-POE-Component-RRDTool
parentf46c1dd93b85af519512d46bf40ca99bdc7faa40 (diff)
downloadports-96c8ed2d25fa69ec39b568e71c7b00eb7ce0c9c4.tar.gz
ports-96c8ed2d25fa69ec39b568e71c7b00eb7ce0c9c4.zip
Add p5-POE-Component-RRDTool 0.14,
POE interface to Round Robin Database Tools.
Notes
Notes: svn path=/head/; revision=64047
Diffstat (limited to 'net/p5-POE-Component-RRDTool')
-rw-r--r--net/p5-POE-Component-RRDTool/Makefile26
-rw-r--r--net/p5-POE-Component-RRDTool/distinfo1
-rw-r--r--net/p5-POE-Component-RRDTool/pkg-comment1
-rw-r--r--net/p5-POE-Component-RRDTool/pkg-descr14
-rw-r--r--net/p5-POE-Component-RRDTool/pkg-plist7
5 files changed, 49 insertions, 0 deletions
diff --git a/net/p5-POE-Component-RRDTool/Makefile b/net/p5-POE-Component-RRDTool/Makefile
new file mode 100644
index 000000000000..c383cf859b56
--- /dev/null
+++ b/net/p5-POE-Component-RRDTool/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: POE-Component-RRDTool
+# Date created: 05 July 2002
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= POE-Component-RRDTool
+PORTVERSION= 0.14
+CATEGORIES= net perl5 devel
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= POE
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/POE.pm:${PORTSDIR}/devel/p5-POE \
+ ${LOCALBASE}/bin/rrdtool:${PORTSDIR}/net/rrdtool
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= POE::Component::RRDTool.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-POE-Component-RRDTool/distinfo b/net/p5-POE-Component-RRDTool/distinfo
new file mode 100644
index 000000000000..e36884354da9
--- /dev/null
+++ b/net/p5-POE-Component-RRDTool/distinfo
@@ -0,0 +1 @@
+MD5 (POE-Component-RRDTool-0.14.tar.gz) = da74dd9b17ac29fa516759e2104f1ba7
diff --git a/net/p5-POE-Component-RRDTool/pkg-comment b/net/p5-POE-Component-RRDTool/pkg-comment
new file mode 100644
index 000000000000..f3231ec1d92f
--- /dev/null
+++ b/net/p5-POE-Component-RRDTool/pkg-comment
@@ -0,0 +1 @@
+POE interface to Round Robin Database Tools
diff --git a/net/p5-POE-Component-RRDTool/pkg-descr b/net/p5-POE-Component-RRDTool/pkg-descr
new file mode 100644
index 000000000000..0bf9ece17b64
--- /dev/null
+++ b/net/p5-POE-Component-RRDTool/pkg-descr
@@ -0,0 +1,14 @@
+RRDtool refers to round robin database tool. Round robin databases have
+a fixed number of data points in them and contain a pointer to the
+current element. Since the databases have a fixed number of data points
+the database size doesn't change after creation. RRDtool allows you to
+define a set of archives which consolidate the primary data points in
+higher granularity. RRDtool is specialized for time series data and can
+be used to create RRD files, update RRDs, retreive data from RRDs, and
+generate graphs from the databases. This module provides a POE wrapper
+around the rrdtool command line interface.
+
+WWW: http://search.cpan.org/search?dist=POE-Component-RRDTool
+
+-- Sergey Skvortsov
+skv@FreeBSD.org
diff --git a/net/p5-POE-Component-RRDTool/pkg-plist b/net/p5-POE-Component-RRDTool/pkg-plist
new file mode 100644
index 000000000000..975c5b42eda6
--- /dev/null
+++ b/net/p5-POE-Component-RRDTool/pkg-plist
@@ -0,0 +1,7 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/POE/Component/RRDTool/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/POE/Component/RRDTool.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/POE/Component/RRDTool
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/POE/Component 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/POE/Component 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/POE 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/POE 2>/dev/null || true