aboutsummaryrefslogtreecommitdiff
path: root/net/p5-REST-Google/Makefile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2008-04-30 14:13:38 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2008-04-30 14:13:38 +0000
commitedd68985afb93a6ee2230e091726276f7f3531fb (patch)
treedc8eaaf48585a1e9623aee1fc509b84adbd2c210 /net/p5-REST-Google/Makefile
parentfef3cacda4c3414fb893577b77e56e409e94d376 (diff)
downloadports-edd68985afb93a6ee2230e091726276f7f3531fb.tar.gz
ports-edd68985afb93a6ee2230e091726276f7f3531fb.zip
REST::Google -
This module provides OO interface to Google REST (aka AJAX) API. Currently support for Search, Feeds and Translate services. WWW: http://search.cpan.org/dist/REST-Google/
Notes
Notes: svn path=/head/; revision=212366
Diffstat (limited to 'net/p5-REST-Google/Makefile')
-rw-r--r--net/p5-REST-Google/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/net/p5-REST-Google/Makefile b/net/p5-REST-Google/Makefile
new file mode 100644
index 000000000000..0e77ee5d5058
--- /dev/null
+++ b/net/p5-REST-Google/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: p5-REST-Google
+# Date created: 01 May 2008
+# Whom: Cheng-Lung Sung <clsung@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= REST-Google
+PORTVERSION= 1.0.2
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/E/EJ/EJS/
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= Access Google REST (aka AJAX) API from Perl
+
+RUN_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
+ p5-version>=0.50:${PORTSDIR}/devel/p5-version \
+ p5-Class-Accessor>0:${PORTSDIR}/devel/p5-Class-Accessor \
+ p5-Class-Data-Inheritable>0:${PORTSDIR}/devel/p5-Class-Data-Inheritable \
+ p5-URI>=1.35:${PORTSDIR}/net/p5-URI \
+ p5-JSON-Any>=1.16:${PORTSDIR}/converters/p5-JSON-Any
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+USE_PERL5= 5.6.1+
+PERL_MODBUILD= yes
+
+MAN3= REST::Google.3 \
+ REST::Google::Feeds.3 \
+ REST::Google::Search.3 \
+ REST::Google::Search::Blogs.3 \
+ REST::Google::Search::Books.3 \
+ REST::Google::Search::Images.3 \
+ REST::Google::Search::Local.3 \
+ REST::Google::Search::News.3 \
+ REST::Google::Search::Video.3 \
+ REST::Google::Search::Web.3 \
+ REST::Google::Translate.3
+
+.include <bsd.port.mk>