aboutsummaryrefslogtreecommitdiff
path: root/net/p5-RPC-Simple
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-08-22 07:02:36 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-08-22 07:02:36 +0000
commit373af94e47f1a137dcc0c60ce700d60579e6bb5f (patch)
treed5826cd5ce993a53504cf4263bf88737e20bbb2f /net/p5-RPC-Simple
parent3f861d0268c0b949ce8442c581262646136b5d11 (diff)
downloadports-373af94e47f1a137dcc0c60ce700d60579e6bb5f.tar.gz
ports-373af94e47f1a137dcc0c60ce700d60579e6bb5f.zip
Add p5-RPC-Simple 1.002, perl classes to handle simple asynchronous RPC
calls with call-back. PR: ports/102256 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Notes
Notes: svn path=/head/; revision=171151
Diffstat (limited to 'net/p5-RPC-Simple')
-rw-r--r--net/p5-RPC-Simple/Makefile25
-rw-r--r--net/p5-RPC-Simple/distinfo3
-rw-r--r--net/p5-RPC-Simple/pkg-descr18
-rw-r--r--net/p5-RPC-Simple/pkg-plist15
4 files changed, 61 insertions, 0 deletions
diff --git a/net/p5-RPC-Simple/Makefile b/net/p5-RPC-Simple/Makefile
new file mode 100644
index 000000000000..2ebfd1cbff4a
--- /dev/null
+++ b/net/p5-RPC-Simple/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-RPC-Simple
+# Date created: 2006-08-19
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= RPC-Simple
+PORTVERSION= 1.002
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= RPC
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Perl classes to handle simple asynchronous RPC calls with call-back
+
+PERL_CONFIGURE= yes
+
+MAN3= RPC::Simple.3 RPC::Simple::Agent.3 RPC::Simple::AnyLocal.3 \
+ RPC::Simple::AnyRemote.3 RPC::Simple::AnyWhere.3 \
+ RPC::Simple::CallHandler.3 RPC::Simple::Factory.3 \
+ RPC::Simple::ObjectHandler.3 RPC::Simple::Server.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-RPC-Simple/distinfo b/net/p5-RPC-Simple/distinfo
new file mode 100644
index 000000000000..521bbfce888b
--- /dev/null
+++ b/net/p5-RPC-Simple/distinfo
@@ -0,0 +1,3 @@
+MD5 (RPC-Simple-1.002.tar.gz) = 115b7c59defc0878d606ceaab3b1c58d
+SHA256 (RPC-Simple-1.002.tar.gz) = 6f282e73a706aecdfe3e09647a083da7cbdc57591535f44ba853f8b83a61d3f9
+SIZE (RPC-Simple-1.002.tar.gz) = 19064
diff --git a/net/p5-RPC-Simple/pkg-descr b/net/p5-RPC-Simple/pkg-descr
new file mode 100644
index 000000000000..ab5e9e9a0bce
--- /dev/null
+++ b/net/p5-RPC-Simple/pkg-descr
@@ -0,0 +1,18 @@
+This module implements remote procedure call. I've tried to keep
+things simple.
+
+So this module should be :
+- quite simple to use (thanks to autoload mechanisms)
+- lightweight
+
+It sure is not :
+- DCE
+- CORBA
+- bulletproof
+- securityproof
+- foolproof
+
+But it works. (Although I'm opened to suggestion regarding the
+"un-proof" areas)
+
+WWW: http://search.cpan.org/dist/RPC-Simple/
diff --git a/net/p5-RPC-Simple/pkg-plist b/net/p5-RPC-Simple/pkg-plist
new file mode 100644
index 000000000000..224e20002842
--- /dev/null
+++ b/net/p5-RPC-Simple/pkg-plist
@@ -0,0 +1,15 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/RPC/Simple/.packlist
+%%SITE_PERL%%/RPC/Simple.pm
+%%SITE_PERL%%/RPC/Simple/Agent.pm
+%%SITE_PERL%%/RPC/Simple/AnyLocal.pm
+%%SITE_PERL%%/RPC/Simple/AnyRemote.pm
+%%SITE_PERL%%/RPC/Simple/AnyWhere.pm
+%%SITE_PERL%%/RPC/Simple/CallHandler.pm
+%%SITE_PERL%%/RPC/Simple/Factory.pm
+%%SITE_PERL%%/RPC/Simple/ObjectHandler.pm
+%%SITE_PERL%%/RPC/Simple/Server.pm
+@dirrmtry %%SITE_PERL%%/RPC/Simple
+@dirrmtry %%SITE_PERL%%/RPC
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/RPC/Simple
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/RPC